summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzhangjinqiang2021-02-18 03:08:26 +0000
committerzhangjinqiang2021-02-18 11:08:26 +0800
commit4c2dc41db654af508a20563b4ddd3be6ff7807a6 (patch)
tree9d6a4b2af9761d7c0b8565458385ec74cb543aa4
parent71f3cb660498862fd44c581d497d9bb234b13280 (diff)
downloadaur-4c2dc41db654af508a20563b4ddd3be6ff7807a6.tar.gz
bump version to 5.1
deprecate qemu-debootstrap since https://salsa.debian.org/qemu-team/qemu/-/commit/9899b1723119e57354c5d8e6f68f15ed762bd570
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD4
-rw-r--r--qemu-debootstrap171
-rw-r--r--qemu-debootstrap.119
4 files changed, 4 insertions, 194 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 03071848edfa..f6c99a640a43 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = qemu-debootstrap
pkgdesc = QEMU debootstrap wrapper
- pkgver = 4.1
+ pkgver = 5.2
pkgrel = 1
url = https://salsa.debian.org/qemu-team/qemu
arch = any
@@ -9,7 +9,7 @@ pkgbase = qemu-debootstrap
depends = debootstrap
source = https://salsa.debian.org/qemu-team/qemu/-/raw/master/debian/qemu-debootstrap
source = https://salsa.debian.org/qemu-team/qemu/-/raw/master/debian/qemu-debootstrap.1
- sha1sums = d756058d0a4bf955dda8dcaeea693df5377a39cd
+ sha1sums = 2eef819f34f609f59e0c754ca698369e6ad82fda
sha1sums = 8f4b540c52db9f2753dd1ef62507497f5f844027
pkgname = qemu-debootstrap
diff --git a/PKGBUILD b/PKGBUILD
index 3a6c12d2d79a..5d5aed4272f3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: peeweep <peeweep at 0x0 dot ee>
pkgname=qemu-debootstrap
-pkgver=4.1
+pkgver=5.2
pkgrel=1
pkgdesc='QEMU debootstrap wrapper'
arch=('any')
@@ -12,7 +12,7 @@ source=(
'https://salsa.debian.org/qemu-team/qemu/-/raw/master/debian/qemu-debootstrap'
'https://salsa.debian.org/qemu-team/qemu/-/raw/master/debian/qemu-debootstrap.1'
)
-sha1sums=('d756058d0a4bf955dda8dcaeea693df5377a39cd'
+sha1sums=('2eef819f34f609f59e0c754ca698369e6ad82fda'
'8f4b540c52db9f2753dd1ef62507497f5f844027')
package() {
diff --git a/qemu-debootstrap b/qemu-debootstrap
deleted file mode 100644
index 913a3fdcec9b..000000000000
--- a/qemu-debootstrap
+++ /dev/null
@@ -1,171 +0,0 @@
-#!/bin/sh
-# qemu-debootstrap - setup qemu syscall emulation in a debootstrap chroot
-# Copyright (C) 2010 Loïc Minier <lool@dooz.org>
-#
-# Permission is hereby granted, free of charge, to any person obtaining a
-# copy of this software and associated documentation files (the "Software"),
-# to deal in the Software without restriction, including without limitation
-# the rights to use, copy, modify, merge, publish, distribute, sublicense,
-# and/or sell copies of the Software, and to permit persons to whom the
-# Software is furnished to do so, subject to the following conditions:
-#
-# The above copyright notice and this permission notice shall be included in
-# all copies or substantial portions of the Software.
-#
-# THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
-# IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
-# FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL
-# SOFTWARE IN THE PUBLIC INTEREST, INC. BE LIABLE FOR ANY CLAIM, DAMAGES OR
-# OTHER LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE,
-# ARISING FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER
-# DEALINGS IN THE SOFTWARE.
-#
-# Except as contained in this notice, the name of the author shall not be used
-# in advertising or otherwise to promote the sale, use or other dealings in
-# this Software without prior written authorization from the author.
-
-set -e
-
-log() {
- local format="$1"
- shift
- printf -- "$format\n" "$@" >&2
-}
-
-warn() {
- local format="$1"
- shift
- log "W: $format" "$@"
-}
-
-die() {
- local format="$1"
- shift
- log "E: $format" "$@"
- exit 1
-}
-
-run() {
- log "I: Running command: %s" "$*"
- "$@"
-}
-
-escape() {
- echo "$*" | sed "s/'/'\"'\"'/g; s/.*/'&'/"
-}
-unescape () {
- eval "echo" "$*"
-}
-
-system_arch="$(dpkg --print-architecture)"
-deb_arch="$system_arch"
-
-opts=""
-args=""
-suite=""
-target=""
-mirror=""
-script=""
-while [ $# -gt 0 ]; do
- case "$1" in
- --help)
- die "I'm just a debootstrap wrapper; please see debootstrap --help"
- ;;
- --arch|--arch=?*)
- if [ "$1" = "--arch" -a $# -ge 2 -a -n "$2" ]; then
- deb_arch="$2"
- shift 2
- elif [ "$1" != "${1#--arch=}" ]; then
- deb_arch="${1#--arch=}"
- shift
- else
- die "option %s requires an argument" "$1"
- fi
- ;;
- --include|--exclude|--components|--variant|--keyring|--unpack-tarball|--make-tarball|--second-stage-target|--extractor|--private-key|--certificate)
- if [ $# -ge 2 -a -n "$2" ]; then
- opts="$opts $(escape "$1") $(escape "$2")"
- shift 2
- else
- die "option %s requires an argument" "$1"
- fi
- ;;
- --*)
- opts="$opts $(escape "$1")"
- shift
- ;;
- *)
- if [ -z "$suite" ]; then stage="suite";
- elif [ -z "$target" ]; then stage="target";
- elif [ -z "$mirror" ]; then stage="mirror";
- elif [ -z "$script" ]; then stage="script";
- fi
- if [ -n "$1" ]; then
- eval $stage=\"\$1\"
- args="$args $(escape "$1")"
- else
- die "option %s may not be empty" "$stage"
- fi
- shift
- ;;
- esac
-done
-
-which debootstrap >/dev/null 2>/dev/null ||
- die "debootstrap isn't found in \$PATH, is debootstrap package installed?"
-
-needs_qemu="yes"
-if [ "$deb_arch" = "$system_arch" ]; then
- warn "Target architecture is the same as host architecture; disabling QEMU support"
- needs_qemu="no"
-fi
-# bi-arch; TODO test whether the running kernel is actually bi-arch capable
-case "$system_arch-$deb_arch" in
- amd64-i386|arm-armel|armel-arm|arm-armhf|armhf-arm|armel-armhf|armhf-armel|i386-amd64|powerpc-ppc64|ppc64-powerpc|sparc-sparc64|sparc64-sparc|s390-s390x|s390x-s390)
- warn "Host architecture might allow running target architecture; disabling QEMU support"
- needs_qemu="no"
- ;;
-esac
-
-if [ "$needs_qemu" = no ]; then
- eval run debootstrap --arch "$deb_arch" $opts $args
- exit $?
-fi
-
-qemu_arch=""
-case "$deb_arch" in
- alpha|arm|armeb|hppa|i386|m68k|mips|mipsel|mips64el|ppc64|riscv32|riscv64|sh4|sh4eb|sparc|sparc64|s390x)
- qemu_arch="$deb_arch"
- ;;
- amd64)
- qemu_arch="x86_64"
- ;;
- armel|armhf)
- qemu_arch="arm"
- ;;
- arm64)
- qemu_arch="aarch64"
- ;;
- lpia)
- qemu_arch="i386"
- ;;
- powerpc|powerpcspe)
- qemu_arch="ppc"
- ;;
- ppc64el)
- qemu_arch="ppc64le"
- ;;
- *)
- die "Sorry, I don't know how to support arch %s" "$deb_arch"
- ;;
-esac
-
-if ! which "qemu-$qemu_arch-static" >/dev/null 2>&1; then
- die "Sorry, couldn't find binary %s" "qemu-$qemu_arch-static"
-fi
-
-eval run debootstrap --arch "$deb_arch" --foreign $opts $args
-mkdir -p "$target/usr/bin"
-cp $(which "qemu-$qemu_arch-static") "$target/usr/bin"
-run chroot "$target" /debootstrap/debootstrap --second-stage
-
diff --git a/qemu-debootstrap.1 b/qemu-debootstrap.1
deleted file mode 100644
index 8e76a1b48251..000000000000
--- a/qemu-debootstrap.1
+++ /dev/null
@@ -1,19 +0,0 @@
-.TH qemu\-debootstrap 1 2011-07-02 "0.14.1+dfsg" Debian
-.SH NAME
-qemu\-debootstrap \- QEMU debootstrap wrapper
-.SH SYNOPSIS
-.B qemu\-debootstrap
-.RI [ options ]
-.SH DESCRIPTION
-The
-.B qemu\-debootstrap
-wrapper calls
-.BR debootstrap (8)
-making use of the \-\-foreign and \-\-second-stage options, and copies the appropriate
-.BR qemu\-user\-static (1)
-binary into place in order to install cross-architecture chroots. In order for it to work seamlessly, the binfmt-support package must be installed.
-.SH SEE ALSO
-.BR debootstrap (8),
-.BR qemu\-user\-static (1).
-.SH AUTHOR
-This manual page was written by Vagrant Cascadian <vagrant@debian.org>.