summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSaren Arterius2017-03-01 03:50:03 +0800
committerSaren Arterius2017-03-01 03:50:03 +0800
commit7c2686c8b77bde60f916fd8c000e21e91967d909 (patch)
tree791d52b1da1eb9fe31d2fade632c068de74c83b5
parenta824b67382727141bf05c45a8ed21c3d727937c5 (diff)
downloadaur-7c2686c8b77bde60f916fd8c000e21e91967d909.tar.gz
add patch
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD10
-rw-r--r--qemu-devel-msg431844.patch12
3 files changed, 21 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9b311c5d43ec..aa4b1cb09138 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
pkgbase = qemu-saren-git
- pkgver = 2.8.0.r51295.ad584d37f2
+ pkgver = 2.8.0.r51657.9514f2648c
pkgrel = 1
url = http://wiki.qemu.org/
arch = i686
@@ -49,12 +49,14 @@ pkgbase = qemu-saren-git
source = 65-kvm.rules
source = qemu.install
source = https://launchpadlibrarian.net/282321876/pulseaudio-microphone-workaround.patch
+ source = qemu-devel-msg431844.patch
sha256sums = SKIP
sha256sums = dd43e2ef062b071a0b9d0d5ea54737f41600ca8a84a8aefbebb1ff09f978acfb
sha256sums = 0b4f3283973bb3bc876735f051d8eaab68f0065502a3a5012141fad193538ea1
sha256sums = 60dcde5002c7c0b983952746e6fb2cf06d6c5b425d64f340f819356e561e7fc7
sha256sums = 0df69a77645c9a05f98635773666b6212084525d7801ef8382242b06baebe5aa
sha256sums = 57d87ba45340f9b7f4b70834fc35da25be72cf4092abcc5012e853aa7b37c83a
+ sha256sums = 07d60426021d096983c6af2c72cc465259c059f2adc5e76ac4f98a00978b838a
pkgname = qemu-saren-git
pkgdesc = A generic and open source processor emulator which achieves a good emulation speed by using dynamic translation. Git version. GTK support, Spice support and Pulseaudio microphone input delay workaround patch included.
diff --git a/PKGBUILD b/PKGBUILD
index 9dfc4b620b8b..221769b6eb33 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -12,7 +12,7 @@ pkgname=('qemu-saren-git'
'qemu-block-rbd-saren-git'
'qemu-block-gluster-saren-git'
'qemu-guest-agent-saren-git')
-pkgver=2.8.0.r51295.ad584d37f2
+pkgver=2.8.0.r51657.9514f2648c
pkgrel=1
arch=('i686' 'x86_64')
license=('GPL2' 'LGPL2.1')
@@ -29,14 +29,15 @@ source=(git://git.qemu.org/qemu.git
qemu-ga.service
65-kvm.rules
qemu.install
- https://launchpadlibrarian.net/282321876/pulseaudio-microphone-workaround.patch)
+ https://launchpadlibrarian.net/282321876/pulseaudio-microphone-workaround.patch
+ qemu-devel-msg431844.patch)
sha256sums=('SKIP'
'dd43e2ef062b071a0b9d0d5ea54737f41600ca8a84a8aefbebb1ff09f978acfb'
'0b4f3283973bb3bc876735f051d8eaab68f0065502a3a5012141fad193538ea1'
'60dcde5002c7c0b983952746e6fb2cf06d6c5b425d64f340f819356e561e7fc7'
'0df69a77645c9a05f98635773666b6212084525d7801ef8382242b06baebe5aa'
- '57d87ba45340f9b7f4b70834fc35da25be72cf4092abcc5012e853aa7b37c83a')
-
+ '57d87ba45340f9b7f4b70834fc35da25be72cf4092abcc5012e853aa7b37c83a'
+ '07d60426021d096983c6af2c72cc465259c059f2adc5e76ac4f98a00978b838a')
_extra_arches=(aarch64 alpha arm armeb cris lm32 m68k microblaze microblazeel mips
mips64 mips64el mipsel mipsn32 mipsn32el or1k ppc ppc64 ppc64abi32 ppc64le s390x
sh4 sh4eb sparc sparc32plus sparc64 moxie ppcemb tricore unicore32 xtensa xtensaeb)
@@ -53,6 +54,7 @@ pkgver() {
build() {
cd $_gitname
patch -p1 < ../pulseaudio-microphone-workaround.patch
+ patch -p1 < ../qemu-devel-msg431844.patch
# qemu vs. make 4 == bad
export ARFLAGS="rv"
# http://permalink.gmane.org/gmane.comp.emulators.qemu/238740
diff --git a/qemu-devel-msg431844.patch b/qemu-devel-msg431844.patch
new file mode 100644
index 000000000000..ac2a4178ab79
--- /dev/null
+++ b/qemu-devel-msg431844.patch
@@ -0,0 +1,12 @@
+diff --git a/hw/virtio/virtio.c b/hw/virtio/virtio.c
+index 23483c7..e487e36 100644
+--- a/hw/virtio/virtio.c
++++ b/hw/virtio/virtio.c
+@@ -2291,7 +2291,7 @@ static bool virtio_queue_host_notifier_aio_poll(void *opaque)
+ VirtQueue *vq = container_of(n, VirtQueue, host_notifier);
+ bool progress;
+
+- if (virtio_queue_empty(vq)) {
++ if (!vq->vring.desc || virtio_queue_empty(vq)) {
+ return false;
+ }