summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFlorian Dejonckheere2014-11-21 12:27:24 +0100
committerFlorian Dejonckheere2014-11-21 12:27:24 +0100
commit283d9895cf8ea20574bf8eb37c3c401188dcf404 (patch)
treed5d5e476a9c0c64abbc6370a6431bc43223c823e
downloadaur-283d9895cf8ea20574bf8eb37c3c401188dcf404.tar.gz
Added qemu-ugent
-rw-r--r--.SRCINFO30
-rw-r--r--PKGBUILD42
-rw-r--r--qemu.patch56
3 files changed, 128 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..15dc95c8ece0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,30 @@
+pkgbase = qemu-ugent
+ pkgdesc = QEMU 0.13.0 required for UGent 'Besturingssystemen' course
+ pkgver = 0.13.0
+ pkgrel = 1
+ url = http://wiki.qemu.org/Index.html
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ license = LGPL2.1
+ license = BSD
+ makedepends = texi2html
+ makedepends = perl
+ depends = sdl
+ depends = alsa-lib
+ depends = esound
+ depends = gnutls>=2.4.1
+ depends = bluez
+ depends = vde2
+ depends = util-linux-ng
+ depends = curl
+ depends = libsasl
+ conflicts = qemu
+ conflicts = seabios
+ source = http://wiki.qemu-project.org/download/qemu-0.13.0.tar.gz
+ source = qemu.patch
+ md5sums = 397a0d665da8ba9d3b9583629f3d6421
+ md5sums = ce1f43c4d76f426ba796a6524fe9fc65
+
+pkgname = qemu-ugent
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cfed70298db1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# Maintainer: Florian Dejonckheere <florian@floriandejonckheere.be>
+# Contributor: Cyker Way <cykerway@gmail.com>
+
+# Based on qemu-6828's PKGBUILD
+pkgname=qemu-ugent
+pkgver=0.13.0
+pkgrel=1
+pkgdesc="QEMU 0.13.0 required for UGent 'Besturingssystemen' course"
+arch=('i686' 'x86_64')
+license=('GPL2' 'LGPL2.1' 'BSD')
+url="http://wiki.qemu.org/Index.html"
+makedepends=('texi2html' 'perl')
+depends=('sdl' 'alsa-lib' 'esound' 'gnutls>=2.4.1' 'bluez' 'vde2' 'util-linux-ng' 'curl' 'libsasl')
+conflicts=('qemu' 'seabios')
+source=("http://wiki.qemu-project.org/download/qemu-${pkgver}.tar.gz"
+ "qemu.patch")
+md5sums=('397a0d665da8ba9d3b9583629f3d6421'
+ 'ce1f43c4d76f426ba796a6524fe9fc65')
+
+prepare(){
+ cd "${srcdir}/qemu-${pkgver}"
+
+ # Replace 'Schütz' by 'Schutz'
+ sed -e 's/ü/u/g' -i qemu-doc.texi
+
+ # Apply small patches
+ patch -p1 < ../qemu.patch
+
+ ./configure --prefix=/usr --target-list="i386-softmmu"
+}
+build()
+{
+ cd "${srcdir}/qemu-${pkgver}"
+
+ make
+}
+
+package(){
+ cd "${srcdir}/qemu-${pkgver}"
+
+ make DESTDIR=${pkgdir} install
+}
diff --git a/qemu.patch b/qemu.patch
new file mode 100644
index 000000000000..a276f465c8c8
--- /dev/null
+++ b/qemu.patch
@@ -0,0 +1,56 @@
+diff -rupN A/configure B/configure
+--- A/configure 2010-10-15 22:56:09.000000000 +0200
++++ B/configure 2014-11-21 12:12:50.121607406 +0100
+@@ -2002,18 +2002,21 @@ fi
+ cat > $TMPC <<EOF
+ #include <signal.h>
+ #include <time.h>
+-int main(void) { clockid_t id; return clock_gettime(id, NULL); }
++int main(void) {
++ timer_create(CLOCK_REALTIME, NULL, NULL);
++ return clock_gettime(CLOCK_REALTIME, NULL);
++}
+ EOF
+-
+ if compile_prog "" "" ; then
+- :
+-elif compile_prog "" "-lrt" ; then
++:
++# we need pthread for static linking. use previous pthread test result
++elif compile_prog "" "-lrt $pthread_lib" ; then
+ LIBS="-lrt $LIBS"
++ libs_qga="-lrt $libs_qga"
+ fi
+-
+ if test "$darwin" != "yes" -a "$mingw32" != "yes" -a "$solaris" != yes -a \
+- "$aix" != "yes" ; then
+- libs_softmmu="-lutil $libs_softmmu"
++ "$aix" != "yes" -a "$haiku" != "yes" ; then
++ libs_softmmu="-lutil $libs_softmmu"
+ fi
+
+ ##########################################
+diff -rupN A/hw/eepro100.c B/hw/eepro100.c
+--- A/hw/eepro100.c 2010-10-15 22:56:09.000000000 +0200
++++ B/hw/eepro100.c 2014-11-21 12:12:50.121607406 +0100
+@@ -95,7 +95,7 @@
+ #define PCI_IO_SIZE 64
+ #define PCI_FLASH_SIZE (128 * KiB)
+
+-#define BIT(n) (1 << (n))
++//#define BIT(n) (1 << (n))
+ #define BITS(n, m) (((0xffffffffU << (31 - n)) >> (31 - n + m)) << m)
+
+ /* The SCB accepts the following controls for the Tx and Rx units: */
+diff -rupN A/qemu-common.h B/qemu-common.h
+--- A/qemu-common.h 2010-10-15 22:56:09.000000000 +0200
++++ B/qemu-common.h 2014-11-21 12:12:50.121607406 +0100
+@@ -56,6 +56,8 @@ typedef struct DeviceState DeviceState;
+ #define ENOTSUP 4096
+ #endif
+
++#define BIT(n) (1 << (n))
++
+ #ifndef CONFIG_IOVEC
+ #define CONFIG_IOVEC
+ struct iovec {