summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTioDuke2015-06-26 21:46:21 -0400
committerTioDuke2015-06-26 21:46:21 -0400
commitbabecc53bcc3dc39657c475df02fe36b97fec5ca (patch)
tree88768bea642584001784644bc4e05fec30dd6360
parent66f182e064b5fa7b7bb581a941d25af6769bec7b (diff)
downloadaur-babecc53bcc3dc39657c475df02fe36b97fec5ca.tar.gz
Update binfmts
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD15
2 files changed, 9 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6d61486f4041..a96bf07d6ce1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = qemu-user-static
pkgdesc = A generic and open source processor emulator which achieves a good emulation speed by using dynamic translation, statically linked.
pkgver = 2.3
- pkgrel = 1
+ pkgrel = 2
url = http://wiki.qemu.org/Index.html
arch = i686
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index 4f41fa4b9d16..1b93f54faea9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=qemu-user-static
pkgver=2.3
-pkgrel=1
+pkgrel=2
pkgdesc="A generic and open source processor emulator which achieves a good emulation speed by using dynamic translation, statically linked."
arch=('i686' 'x86_64')
license=('GPL2' 'LGPL2.1')
@@ -79,12 +79,13 @@ create_binfmts() {
for fmt in $fmts ; do
eval "magic=\"\$${fmt}_magic\" mask=\"\$${fmt}_mask\""
cat >> "${pkgdir}/var/lib/binfmts/qemu-$fmt" << EOF
-package qemu-user-static
-interpreter /usr/bin/qemu-$fmt-static
-credentials yes
-offset 0
-magic $magic
-mask $mask
+qemu-user-static
+magic
+0
+$magic
+$mask
+/usr/bin/qemu-$fmt-static
+yes
EOF
done
}