summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDavid Herrmann2019-01-08 12:44:34 +0100
committerDavid Herrmann2019-01-08 12:44:34 +0100
commit3de804944375a703352d7168812820763eb18631 (patch)
treed722215dac3a951fe99d1fd2e34d91f78a197b64
parent031c968b18404d071ad0cc1236a14f28183b8269 (diff)
downloadaur-3de804944375a703352d7168812820763eb18631.tar.gz
qemu-user-static-bin: fix hashes
This fixes the package to use the correct sha256 hashes. Furthermore, it removes the built-in hashes for non-primary architectures (I simply don't want to maintain them). Lastly, on request, this makes sure the downloaded files are correctly indexed on their version. This allows keeping old sources around on update. Signed-off-by: David Herrmann <dh.herrmann@gmail.com>
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD10
2 files changed, 7 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 569983cad3fb..3d7dd6db8a00 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
# Generated by mksrcinfo v8
-# Fri Dec 28 10:15:13 UTC 2018
+# Tue Jan 8 11:44:06 UTC 2019
pkgbase = qemu-user-static-bin
pkgdesc = A generic and open source machine emulator, statically linked
pkgver = 3.1
@@ -15,7 +15,7 @@ pkgbase = qemu-user-static-bin
provides = qemu-user
conflicts = qemu-user-static
conflicts = qemu-user
- source = qemu-user-static.deb::http://ftp.debian.org/debian/pool/main/q/qemu/qemu-user-static_3.1+dfsg-2_.deb
+ source = qemu-user-static-3.1_.deb::http://ftp.debian.org/debian/pool/main/q/qemu/qemu-user-static_3.1+dfsg-2_.deb
source = qemu.binfmt
sha256sums = SKIP
sha256sums = 0c1e998022f3306946cd66678f363b10d93b1309c5bbc9f0e6064080a3b604f9
diff --git a/PKGBUILD b/PKGBUILD
index 215f22ac6033..1cb9ea2c994a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
_pkgname=qemu-user-static
pkgdesc='A generic and open source machine emulator, statically linked'
pkgver=3.1
-pkgrel=1
+pkgrel=2
_debrel=2
pkgname=$_pkgname-bin
@@ -17,20 +17,20 @@ conflicts=("$_pkgname" "qemu-user")
if [ "$CARCH" = 'x86_64' ] ; then
_debsrc="${_pkgname}_${pkgver}+dfsg-${_debrel}_amd64.deb"
- _csum=27aff9179038f561cfdbf0726b5dfda5afb6ff938afa586d255160afce265375
+ _csum=b52b43a2519a97613ac4081e8eadb58300c890be710db19bf6e2607a7fac4948
elif [ "$CARCH" = 'i686' ] ; then
_debsrc="${_pkgname}_${pkgver}+dfsg-${_debrel}_i386.deb"
- _csum=c01ccf333c6e91a4570ea2c99732d6690a8bcf18504c5320d2949539b384cb39
+ _csum=SKIP
elif [ "$CARCH" = 'aarch64' ] ; then
_debsrc="${_pkgname}_${pkgver}+dfsg-${_debrel}_arm64.deb"
- _csum=9cc89a4c912fbd6986ea8e5600a75b3b3d2248593205029756a3814e34c560fc
+ _csum=SKIP
else
_debsrc="${_pkgname}_${pkgver}+dfsg-${_debrel}_${CARCH}.deb"
_csum=SKIP
fi
source=(
- "qemu-user-static.deb::http://ftp.debian.org/debian/pool/main/q/qemu/${_debsrc}"
+ "qemu-user-static-${pkgver}_${CARCH}.deb::http://ftp.debian.org/debian/pool/main/q/qemu/${_debsrc}"
"qemu.binfmt" # http://src.fedoraproject.org/rpms/qemu/raw/master/f/qemu.binfmt
)
sha256sums=(