summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDavid Herrmann2017-11-20 16:22:03 +0100
committerDavid Herrmann2017-11-20 16:22:03 +0100
commit798562f116004115dfea601dd88ba5236f3f04dd (patch)
tree5a9244e082500b062591cbad713f1bd4d1864f10
parentcabb94143c57387846306f93d6fa2b229ee0ddaa (diff)
downloadaur-798562f116004115dfea601dd88ba5236f3f04dd.tar.gz
qemu-user-static-bin: drop i686 support
Arch Linux no longer supports i686, so drop package support as well. Signed-off-by: David Herrmann <dh.herrmann@gmail.com>
-rw-r--r--PKGBUILD21
1 files changed, 11 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 90ec1e9d3fb9..53b1f536d4c9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@ pkgver=2.10.0
pkgrel=1
pkgname=$_pkgname-bin
-arch=('i686' 'x86_64')
+arch=('x86_64')
url="http://wiki.qemu.org"
license=('GPL2' 'LGPL2.1')
depends=()
@@ -14,10 +14,7 @@ makedepends=('perl')
provides=("$_pkgname")
conflicts=("$_pkgname")
-if [ "$CARCH" = 'i686' ] ; then
- _arch=i386
- _csum=31374487e53e533d2fe71fb2cf34d5f4f42e01aadee19a5abd1f76ca92079f84
-elif [ "$CARCH" = 'x86_64' ] ; then
+if [ "$CARCH" = 'x86_64' ] ; then
_arch=amd64
_csum=8b9a049de297ebdb9c69200edaee68c4c94b757829bbcb74235db1a067bc7ad1
else
@@ -89,11 +86,15 @@ create_binfmts() {
x86_64 \
; do
- if [ "$CARCH" = "i686" ] || \
- [ "$CARCH" = "x86_64" ] ; then
- [ "$i" = "i386" ] \
- || [ "$i" = "i486" ] \
- || [ "$i" = "x86_64" ] && continue
+ # Skip emulator of target machine (and dependents)
+ if [ "$CARCH" = "$i" ] ; then
+ continue
+ elif [ "$CARCH" = "x86_64" ] ; then
+ if [ "$i" = "i386" ] || \
+ [ "$i" = "i486" ] || \
+ [ "$i" = "x86_64" ] ; then
+ continue
+ fi
fi
grep "/qemu-$i:\$" "${srcdir}/qemu.binfmt" \