summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsl1pkn072015-08-12 13:05:59 +0200
committersl1pkn072015-08-12 13:05:59 +0200
commitb36ba898661a3c8f7a5e3bd5c482f5027ce1072b (patch)
tree4656f9a1bf5ad02f1d532a8e863895db16e2b34e
downloadaur-b36ba898661a3c8f7a5e3bd5c482f5027ce1072b.tar.gz
Initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD43
3 files changed, 64 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..acd9df622f9e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = qextserialport
+ pkgdesc = Cross-platform serial port class libary for Qt4 and Qt5.
+ pkgver = 1.2rc
+ pkgrel = 5
+ url = https://github.com/qextserialport/qextserialport
+ arch = i686
+ arch = x86_64
+ license = BSD
+ depends = qt4
+ depends = qt5-base
+ source = qextserialport-1.2rc.tar.gz::https://github.com/qextserialport/qextserialport/archive/1.2rc.tar.gz
+ sha1sums = 2cd3ec6771b056db1bdf471517f8e20e8a4ecff2
+
+pkgname = qextserialport-qt4
+
+pkgname = qextserialport-qt5
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..05c6d4d4c97b
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.gitignore
+!.SRCINFO
+!PKGBUILD
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5e6b6fa8f9fc
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Contributor: Kosyak <ObKo@mail.ru>
+pkgbase=qextserialport
+pkgname=('qextserialport-qt4' 'qextserialport-qt5')
+pkgver=1.2rc
+pkgrel=5
+pkgdesc="Cross-platform serial port class libary for Qt4 and Qt5."
+arch=('i686' 'x86_64')
+url='https://github.com/qextserialport/qextserialport'
+license=('BSD')
+depends=('qt4' 'qt5-base')
+source=("${pkgbase}-${pkgver}.tar.gz::https://github.com/qextserialport/qextserialport/archive/${pkgver}.tar.gz")
+sha1sums=('2cd3ec6771b056db1bdf471517f8e20e8a4ecff2')
+
+prepare() {
+ mkdir -p build-{qt4,qt5}
+}
+
+build() {
+ cd "${srcdir}/build-qt4"
+
+ qmake-qt4 "../qextserialport-${pkgver}"
+ make
+ cd "${srcdir}/build-qt5"
+
+ qmake-qt5 "../qextserialport-${pkgver}"
+ make
+}
+
+package_qextserialport-qt4() {
+ make -C build-qt4 INSTALL_ROOT="$pkgdir" install
+
+ # Fix wrong path in prl files
+ find "${pkgdir}/usr/lib" -type f -name '*.prl' \
+ -exec sed -i -e '/^QMAKE_PRL_BUILD_DIR/d;s/\(QMAKE_PRL_LIBS =\).*/\1/' {} \;
+}
+
+package_qextserialport-qt5() {
+ make -C build-qt5 INSTALL_ROOT="$pkgdir" install
+
+ # Fix wrong path in prl files
+ find "${pkgdir}/usr/lib" -type f -name '*.prl' \
+ -exec sed -i -e '/^QMAKE_PRL_BUILD_DIR/d;s/\(QMAKE_PRL_LIBS =\).*/\1/' {} \;
+}