summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSebastian Reuße2015-12-10 10:20:19 +0100
committerSebastian Reuße2015-12-10 10:25:53 +0100
commit1119f691ea7b52577c20794ecd65404d60c77033 (patch)
tree3e6cd00af8d6d76a41c3ed03444dd835f445757f
downloadaur-1119f691ea7b52577c20794ecd65404d60c77033.tar.gz
Init.
-rw-r--r--.SRCINFO22
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD53
-rw-r--r--qfc.install3
4 files changed, 79 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d36d24d7ad44
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+# Generated by mksrcinfo v8
+# Thu Dec 10 09:25:53 UTC 2015
+pkgbase = qfc-git
+ pkgdesc = Quick command-line file completion
+ pkgver = r36.736bd2c
+ pkgrel = 1
+ url = https://github.com/pindexis/qfc
+ install = qfc.install
+ arch = any
+ license = custom:MIT
+ makedepends = git
+ makedepends = python
+ depends = python
+ optdepends = zsh: use qfc in Zsh
+ optdepends = bash: use qfc in Bash
+ provides = qfc
+ conflicts = qfc
+ source = git+https://github.com/pindexis/qfc
+ md5sums = SKIP
+
+pkgname = qfc-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..468cd87d3ce8
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1 @@
+*.pkg.tar.xz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7f81c38bb87c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,53 @@
+# Maintainer: Sebastian Reuße <seb@wirrsal.net>
+pkgname=qfc-git
+_gitname=qfc
+pkgver=r36.736bd2c
+pkgrel=1
+pkgdesc="Quick command-line file completion"
+arch=(any)
+url=https://github.com/pindexis/qfc
+license=(custom:MIT)
+depends=(python)
+optdepends=(
+ "zsh: use qfc in Zsh"
+ "bash: use qfc in Bash"
+)
+makedepends=(
+ git
+ python
+)
+provides=(qfc)
+conflicts=(qfc)
+source=(git+https://github.com/pindexis/qfc)
+md5sums=(SKIP)
+install=qfc.install
+
+
+pkgver() {
+ cd "$_gitname"
+ # No tagged commits. ヽ(´ー`)ノ
+ commit=$(git rev-list --count master)
+ hash=$(git rev-parse --short HEAD)
+ echo "r$commit.$hash"
+}
+
+
+package() {
+ cd "$srcdir/$_gitname"
+
+ python -m compileall qfc/*.py
+
+ local _bin_dir="$pkgdir"/usr/bin
+ local _share_dir="$pkgdir"/usr/share/qfc
+ local _doc_dir="$pkgdir"/usr/share/doc/qfc
+ local _license_dir="$pkgdir"/usr/share/licenses/"$pkgname"
+ local _py_site_pkg="$(python -c 'import site; print(site.getsitepackages()[0])')"
+ local _py_dir="$pkgdir"/"$_py_site_pkg"/qfc
+
+ install -dm755 "$_py_dir"
+ install -m644 qfc/*.{py,pyc} "$_py_dir"
+ install -Dm755 bin/qfc "$_bin_dir"/qfc
+ install -Dm644 bin/qfc.sh "$_share_dir"/qfc.sh
+ install -Dm644 LICENSE "$_license_dir"/LICENSE
+ install -Dm644 README.md "$_doc_dir"/README.md
+}
diff --git a/qfc.install b/qfc.install
new file mode 100644
index 000000000000..687057f2c6d0
--- /dev/null
+++ b/qfc.install
@@ -0,0 +1,3 @@
+post_install() {
+ echo "To use qfc, source the library from /usr/share/qfc/qfc.sh"
+}