summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDoug Newgard2018-02-23 20:16:37 -0600
committerDoug Newgard2018-02-23 20:16:37 -0600
commit687d3fe093eb9b77736d8a91b8a1b59765d6c940 (patch)
tree273e3912448154a826814df2bd290b5d040bd96f
parent2482766474f406b4c3739bb3d0948ba8b8905f0e (diff)
downloadaur-687d3fe093eb9b77736d8a91b8a1b59765d6c940.tar.gz
Upstream update to 3.0
-rw-r--r--.SRCINFO54
-rw-r--r--PKGBUILD84
2 files changed, 66 insertions, 72 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f898261f1b5b..3903f35e2ee7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,50 +1,54 @@
pkgbase = qgis
pkgdesc = Geographic Information System (GIS) that supports vector, raster & database formats
- pkgver = 2.18.16
+ pkgver = 3.0.0
pkgrel = 1
url = https://qgis.org/
- arch = i686
arch = x86_64
license = GPL
makedepends = cmake
makedepends = gsl
makedepends = perl
makedepends = txt2tags
+ makedepends = qt5-tools
+ makedepends = python-six
+ makedepends = python-future
depends = expat
depends = gcc-libs
depends = gdal
depends = geos
depends = glibc
depends = libspatialite
+ depends = libzip
depends = postgresql-libs
depends = proj
- depends = qt4
- depends = qca-qt4
- depends = qjson
- depends = qscintilla-qt4
- depends = qwt-qt4
- depends = qwtpolar-qt4
+ depends = qca-qt5
+ depends = qextserialport
+ depends = qscintilla-qt5
+ depends = qt5-3d
+ depends = qt5-base
+ depends = qt5-location
+ depends = qt5-svg
+ depends = qt5-webkit
+ depends = qtkeychain
+ depends = qwt
+ depends = qwtpolar
depends = spatialindex
depends = sqlite
- depends = python2
- depends = python2-httplib2
- depends = python2-future
- depends = python2-qscintilla-qt4
- depends = python2-sip
- depends = python2-six
+ depends = python
+ depends = python-qscintilla-qt5
+ depends = python-pyqt5
+ depends = python-sip
optdepends = gpsbabel: GPS Tool plugin
optdepends = gsl: Georeferencer plugin
- optdepends = python2-jinja: MetaSearch plugin
- optdepends = python2-owslib: MetaSearch plugin
- optdepends = python2-pygments: MetaSearch plugin
- optdepends = python2-psycopg2: DB Manager plugin
- optdepends = python2-pygments: DB Manager plugin
- optdepends = python2-pyspatialite: DB Manager plugin
- optdepends = python2-psycopg2: Processing plugin
- optdepends = python2-pyspatialite: Processing plugin
- optdepends = python2-yaml: Processing plugin
- source = https://qgis.org/downloads/qgis-2.18.16.tar.bz2
- md5sums = 5c751e4aa9cd8e4119fea6e216065a26
+ optdepends = python-gdal: DB Manager plugin; Processing plugin
+ optdepends = python-jinja: MetaSearch plugin
+ optdepends = python-owslib: MetaSearch plugin
+ optdepends = python-psycopg2: DB Manager plugin; Processing plugin
+ optdepends = python-pygments: MetaSearch plugin; DB Manager plugin
+ optdepends = python-numpy: Processing plugin
+ optdepends = python-yaml: Processing plugin
+ source = https://qgis.org/downloads/qgis-3.0.0.tar.bz2
+ md5sums = ff6e7ad62e98ef32af41db42640f345d
pkgname = qgis
diff --git a/PKGBUILD b/PKGBUILD
index b47886885493..308f882f1e37 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,4 +1,4 @@
-# Maintainer: Doug Newgard <scimmia at archlinux dot info>
+# Maintainer: Doug Newgard <scimmia at archlinux dot org>
# Contributor: XavierCLL <xavier.corredor.llano (a) gmail.com>
# Contributor: SaultDon <sault.don gmail>
# Contributor: Lantald < lantald at gmx.com >
@@ -9,42 +9,39 @@
# Globe Plugin and Map Server are disabled in cmake by default.
# Uncomment them in the build() portion if you'd like them enabled.
-# You will also need to install osgearth-qt4 or fcgi, respectively, before building.
+# You will also need to install osgearth or fcgi, respectively, before building.
pkgname=qgis
-pkgver=2.18.16
+pkgver=3.0.0
pkgrel=1
pkgdesc='Geographic Information System (GIS) that supports vector, raster & database formats'
url='https://qgis.org/'
license=('GPL')
-arch=('i686' 'x86_64')
-depends=('expat' 'gcc-libs' 'gdal' 'geos' 'glibc' 'libspatialite' 'postgresql-libs' 'proj'
- 'qt4' 'qca-qt4' 'qjson' 'qscintilla-qt4' 'qwt-qt4' 'qwtpolar-qt4' 'spatialindex' 'sqlite'
- 'python2' 'python2-httplib2' 'python2-future' 'python2-qscintilla-qt4' 'python2-sip' 'python2-six')
-makedepends=('cmake' 'gsl' 'perl' 'txt2tags')
+arch=('x86_64')
+depends=('expat' 'gcc-libs' 'gdal' 'geos' 'glibc' 'libspatialite' 'libzip' 'postgresql-libs' 'proj'
+ 'qca-qt5' 'qextserialport' 'qscintilla-qt5' 'qt5-3d' 'qt5-base' 'qt5-location' 'qt5-svg'
+ 'qt5-webkit' 'qtkeychain' 'qwt' 'qwtpolar' 'spatialindex' 'sqlite'
+ 'python' 'python-qscintilla-qt5' 'python-pyqt5' 'python-sip')
+makedepends=('cmake' 'gsl' 'perl' 'txt2tags' 'qt5-tools' 'python-six' 'python-future')
optdepends=('gpsbabel: GPS Tool plugin'
'gsl: Georeferencer plugin'
- 'python2-jinja: MetaSearch plugin'
- 'python2-owslib: MetaSearch plugin'
- 'python2-pygments: MetaSearch plugin'
- 'python2-psycopg2: DB Manager plugin'
- 'python2-pygments: DB Manager plugin'
- 'python2-pyspatialite: DB Manager plugin'
- 'python2-psycopg2: Processing plugin'
- 'python2-pyspatialite: Processing plugin'
- 'python2-yaml: Processing plugin')
+ 'python-gdal: DB Manager plugin; Processing plugin'
+ 'python-jinja: MetaSearch plugin'
+ 'python-owslib: MetaSearch plugin'
+ 'python-psycopg2: DB Manager plugin; Processing plugin'
+ 'python-pygments: MetaSearch plugin; DB Manager plugin'
+ 'python-numpy: Processing plugin'
+ 'python-yaml: Processing plugin')
source=("https://qgis.org/downloads/$pkgname-$pkgver.tar.bz2")
-md5sums=('5c751e4aa9cd8e4119fea6e216065a26')
+md5sums=('ff6e7ad62e98ef32af41db42640f345d')
prepare() {
cd $pkgname-$pkgver
- # Make sure we find the -qt4 versions of qwt and qwtpolar
- sed -i '/QWT_LIBRARY_NAMES/ s/qwt /qwt-qt4 /' cmake/FindQwt.cmake
- sed -i '/PATH_SUFFIXES/ s/qwt$/&-qt4/;/LIBRARY NAMES/ s/qwtpolar/&-qt4/' cmake/FindQwtPolar.cmake
-
- # Fix references to "python"
- sed -i 's/\(env \|\/usr\/bin\/\)python$/&2/' $(find . -iname "*.py")
+ # Find Qt5ExtSerialPort
+ sed -e '/include$/ s/$/\/qt/' \
+ -e 's/qextserialport-1.2/Qt5ExtSerialPort/' \
+ -i cmake/FindQextserialport.cmake
# Remove mime types already defined by freedesktop.org
sed -e '/type="image\/tiff"/,/<\/mime-type>/d' \
@@ -63,16 +60,16 @@ build() {
-DCMAKE_INSTALL_PREFIX=/usr \
-DQGIS_MANUAL_SUBDIR=share/man \
-DENABLE_TESTS=FALSE \
- -DCMAKE_SKIP_RPATH=TRUE \
- -DPYTHON_EXECUTABLE=/usr/bin/python2 \
- -DWITH_QTWEBKIT=FALSE \
- -DWITH_INTERNAL_QWTPOLAR=FALSE \
- -DWITH_INTERNAL_{MARKUPSAFE,OWSLIB,DATEUTIL,PYTZ,YAML,NOSE2,SIX,FUTURE}=FALSE \
+ -DWITH_PY_COMPILE=TRUE \
+ -DWITH_3D=TRUE \
+ -DWITH_INTERNAL_QEXTSERIALPORT=FALSE \
+ -DWITH_QWTPOLAR=TRUE \
# -DWITH_SERVER=TRUE \
# -DWITH_GLOBE=TRUE
make
+ # Rebuild srs database, QGIS distributes an old, buggy one
LD_LIBRARY_PATH="$PWD/output/lib/" make synccrsdb
mv /tmp/srs.db ../resources/
}
@@ -81,32 +78,25 @@ package() {
cd $pkgname-$pkgver/build
# Add optional deps based on selected or autodetected options
- [[ -n "$(sed -n '/^GRASS_PREFIX:/ s/.*=//p' CMakeCache.txt)" ]] && optdepends+=('grass6: GRASS6 plugin')
- [[ -n "$(sed -n '/^GRASS_PREFIX7:/ s/.*=//p' CMakeCache.txt)" ]] && optdepends+=('grass: GRASS7 plugin')
+ [[ "$(sed -n '/^WITH_GRASS7:/ s/.*=//p' CMakeCache.txt)" == "TRUE" ]] && optdepends+=('grass: GRASS7 plugin')
[[ "$(sed -n '/^WITH_SERVER:/ s/.*=//p' CMakeCache.txt)" == "TRUE" ]] && optdepends+=('fcgi: Map Server')
- [[ "$(sed -n '/^WITH_GLOBE:/ s/.*=//p' CMakeCache.txt)" == "TRUE" ]] && optdepends+=('osgearth-qt4: Globe plugin')
+ [[ "$(sed -n '/^WITH_GLOBE:/ s/.*=//p' CMakeCache.txt)" == "TRUE" ]] && optdepends+=('osgearth: Globe plugin')
make DESTDIR="$pkgdir" install
cd "$srcdir/$pkgname-$pkgver"
- # install desktop files and icons
- install -Dm644 debian/{qgis,qbrowser}.desktop -t "$pkgdir/usr/share/applications/"
- for icon in qgis-icon{,-16x16,-60x60} qbrowser-icon{,-60x60}; do
- local _resolution="${icon##*-}"; [[ "$_resolution" == "icon" ]] && _resolution="512x512"
- install -Dm644 images/icons/$icon.png "$pkgdir/usr/share/icons/hicolor/$_resolution/apps/${icon%%-*}.png"
- done
- for prog in qgis qbrowser; do
- install -Dm644 images/icons/${prog}_icon.svg "$pkgdir/usr/share/icons/hicolor/scalable/apps/$prog.svg"
+ # install desktop file and icons
+ install -Dm644 debian/qgis.desktop -t "$pkgdir/usr/share/applications/"
+ install -Dm644 images/icons/qgis_icon.svg "$pkgdir/usr/share/icons/hicolor/scalable/apps/qgis.svg"
+ for _res in 16x16 60x60 512x512; do
+ install -Dm644 images/icons/qgis-icon-$_res.png "$pkgdir/usr/share/icons/hicolor/$_res/apps/qgis.png"
done
# install mime information and icons
- install -Dm644 debian/qgis.xml "$pkgdir/usr/share/mime/packages/qgis.xml"
- install -Dm644 images/icons/qgis-mime-icon.png "$pkgdir/usr/share/icons/hicolor/128x128/mimetypes/qgis-mime.png"
- for type in asc ddf dem dt0 dxf gml img mime mldata qgs qlr qml qpt shp sqlite; do
- install -Dm644 images/icons/qgis_${type}_icon.svg "$pkgdir/usr/share/icons/hicolor/scalable/mimetypes/qgis-$type.svg"
+ install -Dm644 debian/qgis.xml -t "$pkgdir/usr/share/mime/packages/"
+ install -Dm644 images/icons/qgis-mime-icon.png "$pkgdir/usr/share/icons/hicolor/64x64/mimetypes/qgis-mime.png"
+ for _type in asc ddf dem dt0 dxf gml img mime mldata qgs qlr qml qpt shp sqlite; do
+ install -Dm644 images/icons/qgis_${_type}_icon.svg "$pkgdir/usr/share/icons/hicolor/scalable/mimetypes/qgis-$_type.svg"
done
-
- # compile python files, since the cmake option doesn't seem to account for DESTDIR
- python2 -m compileall -q "$pkgdir"
}