summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDoug Newgard2017-07-03 22:09:39 -0500
committerDoug Newgard2017-07-03 22:09:39 -0500
commit83123c45adc564557473d2e3c05494accf15e121 (patch)
tree82ad394cad814edee7751a84e1caa49b0ae83c33
parent28ef84dae26aa59fa204125567ccdc43db76c183 (diff)
downloadaur-83123c45adc564557473d2e3c05494accf15e121.tar.gz
Upstream update to 2.18.10
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD10
2 files changed, 12 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ab9b508aeff7..6cc122a07ad1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = qgis
pkgdesc = Geographic Information System (GIS) that supports vector, raster & database formats
- pkgver = 2.18.6
+ pkgver = 2.18.10
pkgrel = 1
url = http://qgis.org/
arch = i686
@@ -21,8 +21,8 @@ pkgbase = qgis
depends = qt4
depends = qca-qt4
depends = qscintilla-qt4
- depends = qwt
- depends = qwtpolar
+ depends = qwt-qt4
+ depends = qwtpolar-qt4
depends = spatialindex
depends = sqlite
depends = python2
@@ -42,9 +42,9 @@ pkgbase = qgis
optdepends = python2-psycopg2: Processing plugin
optdepends = python2-pyspatialite: Processing plugin
optdepends = python2-yaml: Processing plugin
- source = https://qgis.org/downloads/qgis-2.18.6.tar.bz2
+ source = https://qgis.org/downloads/qgis-2.18.10.tar.bz2
source = qgis_sip-ftbfs.patch::https://src.fedoraproject.org/cgit/rpms/qgis.git/plain/qgis_sip-ftbfs.patch?id=25b8f81ccabbfdb183d4850a66e884c183444f14
- md5sums = ea6d736f1b73d3e02867002fa7fabdb1
+ md5sums = 2919028c987dcb364cd28964d0f12ad7
md5sums = 0575d848604f0fc6dda0a643523e7e48
pkgname = qgis
diff --git a/PKGBUILD b/PKGBUILD
index 3dfa8f5b5e56..6e70308669a2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -12,14 +12,14 @@
# You will also need to install osgearth-qt4 or fcgi, respectively, before building.
pkgname=qgis
-pkgver=2.18.6
+pkgver=2.18.10
pkgrel=1
pkgdesc='Geographic Information System (GIS) that supports vector, raster & database formats'
url='http://qgis.org/'
license=('GPL')
arch=('i686' 'x86_64')
depends=('expat' 'gcc-libs' 'gdal' 'geos' 'glibc' 'libspatialite' 'postgresql-libs' 'proj'
- 'qt4' 'qca-qt4' 'qscintilla-qt4' 'qwt' 'qwtpolar' 'spatialindex' 'sqlite'
+ 'qt4' 'qca-qt4' 'qscintilla-qt4' 'qwt-qt4' 'qwtpolar-qt4' 'spatialindex' 'sqlite'
'python2' 'python2-httplib2' 'python2-future' 'python2-qscintilla-qt4' 'python2-sip' 'python2-six')
makedepends=('cmake' 'gsl' 'perl' 'txt2tags')
optdepends=('gpsbabel: GPS Tool plugin'
@@ -35,7 +35,7 @@ optdepends=('gpsbabel: GPS Tool plugin'
'python2-yaml: Processing plugin')
source=("https://qgis.org/downloads/$pkgname-$pkgver.tar.bz2"
"qgis_sip-ftbfs.patch::https://src.fedoraproject.org/cgit/rpms/qgis.git/plain/qgis_sip-ftbfs.patch?id=25b8f81ccabbfdb183d4850a66e884c183444f14")
-md5sums=('ea6d736f1b73d3e02867002fa7fabdb1'
+md5sums=('2919028c987dcb364cd28964d0f12ad7'
'0575d848604f0fc6dda0a643523e7e48')
prepare() {
@@ -44,6 +44,10 @@ prepare() {
# Fedora patch to fix with newer sip/pyqt4
patch -Np1 -i <(sed '184,$d' ../qgis_sip-ftbfs.patch)
+ # Make sure we find the -qt4 versions of qwt and qwtpolar
+ sed -i '/QWT_LIBRARY_NAMES/ s/qwt /qwt-qt4 /' cmake/FindQwt.cmake
+ sed -i '/PATH_SUFFIXES/ s/qwt$/&-qt4/;/LIBRARY NAMES/ s/qwtpolar/&-qt4/' cmake/FindQwtPolar.cmake
+
# Fix references to "python"
sed -i 's/\(env \|\/usr\/bin\/\)python$/&2/' $(find . -iname "*.py")