summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDoug Newgard2016-05-14 22:28:33 -0500
committerDoug Newgard2016-05-14 22:28:33 -0500
commited56d5b4b562b6b3181a1b845f0869fe7526b4bf (patch)
tree722c869da3b9945c4acc7bf1286ead7be261c4b7
parentf56be81e9ad73a31c7246e59fd483cc5487499ba (diff)
downloadaur-ed56d5b4b562b6b3181a1b845f0869fe7526b4bf.tar.gz
Move plugin deps to optional
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD10
2 files changed, 15 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5bf7f929f03b..db4cb859dfa7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -17,13 +17,16 @@ pkgbase = qgis
depends = icu
depends = python2-qscintilla-qt4
depends = python2-sip
- depends = python2-psycopg2
depends = python2-httplib2
- depends = python2-jinja
- depends = python2-owslib
- depends = python2-pygments
depends = python2-six
optdepends = gpsbabel: GPS Tool plugin
+ optdepends = python2-jinja: MetaSearch plugin
+ optdepends = python2-owslib: MetaSearch plugin
+ optdepends = python2-pygments: MetaSearch plugin
+ optdepends = python2-psycopg2: DB Manager plugin
+ optdepends = python2-pygments: DB Manager plugin
+ optdepends = python2-pyspatialite: DB Manager plugin
+ optdepends = python2-psycopg2: Processing plugin
optdepends = python2-pyspatialite: Processing plugin
optdepends = python2-yaml: Processing plugin
source = http://qgis.org/downloads/qgis-2.14.2.tar.bz2
diff --git a/PKGBUILD b/PKGBUILD
index c499edbb52c9..7669d8158c97 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -19,10 +19,16 @@ url='http://qgis.org/'
license=('GPL')
arch=('i686' 'x86_64')
depends=('qca-qt4' 'gdal' 'qwtpolar' 'gsl' 'spatialindex' 'icu'
- 'python2-qscintilla-qt4' 'python2-sip' 'python2-psycopg2'
- python2-{httplib2,jinja,owslib,pygments,six})
+ 'python2-qscintilla-qt4' 'python2-sip' 'python2-httplib2' 'python2-six')
makedepends=('cmake' 'txt2tags' 'perl')
optdepends=('gpsbabel: GPS Tool plugin'
+ 'python2-jinja: MetaSearch plugin'
+ 'python2-owslib: MetaSearch plugin'
+ 'python2-pygments: MetaSearch plugin'
+ 'python2-psycopg2: DB Manager plugin'
+ 'python2-pygments: DB Manager plugin'
+ 'python2-pyspatialite: DB Manager plugin'
+ 'python2-psycopg2: Processing plugin'
'python2-pyspatialite: Processing plugin'
'python2-yaml: Processing plugin')
source=("http://qgis.org/downloads/$pkgname-$pkgver.tar.bz2")