summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authordanitool2015-09-13 11:43:20 +0200
committerdanitool2015-09-13 11:43:20 +0200
commit3ebae8395c7827ccd9b32ccf59949e65b968cd8c (patch)
treefcf32e88c6103828fd386afe3d49a7b95e535626
downloadaur-3ebae8395c7827ccd9b32ccf59949e65b968cd8c.tar.gz
Initial import
-rw-r--r--.SRCINFO51
-rw-r--r--FindPyQt.py96
-rw-r--r--PKGBUILD73
-rw-r--r--fix-bunch_errors.patch107
-rw-r--r--qgis.desktop10
5 files changed, 337 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 00000000000..03466f4c137
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,51 @@
+# Generated by makepkg 4.2.1
+# Sun Sep 13 09:38:54 UTC 2015
+pkgbase = qgis-1.6
+ pkgdesc = Quantum GIS, Geographic Information System; old 1.6 stable version
+ pkgver = 15265
+ pkgrel = 7
+ url = http://qgis.org/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = subversion
+ makedepends = grass64
+ makedepends = gsl
+ makedepends = postgis
+ makedepends = netcdf
+ makedepends = cmake
+ makedepends = fcgi
+ makedepends = python2-sip
+ makedepends = pyqt
+ depends = libmysqlclient
+ depends = postgresql-libs
+ depends = sqlite3
+ depends = jasper
+ depends = curl
+ depends = qt4
+ depends = python2
+ depends = python2-pyqt
+ depends = giflib
+ depends = xerces-c
+ depends = cfitsio
+ depends = qwt5
+ depends = gdal
+ optdepends = postgis: postgis support and SPIT plugin
+ optdepends = fcgi: qgis mapserver
+ optdepends = python2-sip: python-support
+ optdepends = grass64: grass plugin
+ optdepends = gsl: georeferencer
+ provides = qgis
+ conflicts = qgis
+ conflicts = qgis-git
+ conflicts = qwt
+ options = !makeflags
+ source = qgis.desktop
+ source = fix-bunch_errors.patch
+ source = FindPyQt.py
+ md5sums = 8ab66039f2aba519b92f52272ec3c13e
+ md5sums = a4ebe0567ab3c35437039412e27d1ac0
+ md5sums = e14fc64843d36a7301928b4efd4a3274
+
+pkgname = qgis-1.6
+
diff --git a/FindPyQt.py b/FindPyQt.py
new file mode 100644
index 00000000000..2c44cf9d682
--- /dev/null
+++ b/FindPyQt.py
@@ -0,0 +1,96 @@
+# -*- coding: utf-8 -*-
+#
+# Copyright (c) 2007, Simon Edwards <simon@simonzone.com>
+# All rights reserved.
+#
+# Redistribution and use in source and binary forms, with or without
+# modification, are permitted provided that the following conditions are met:
+# * Redistributions of source code must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+# * Redistributions in binary form must reproduce the above copyright
+# notice, this list of conditions and the following disclaimer in the
+# documentation and/or other materials provided with the distribution.
+# * Neither the name of the Simon Edwards <simon@simonzone.com> nor the
+# names of its contributors may be used to endorse or promote products
+# derived from this software without specific prior written permission.
+#
+# THIS SOFTWARE IS PROVIDED BY Simon Edwards <simon@simonzone.com> ''AS IS'' AND ANY
+# EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED
+# WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE
+# DISCLAIMED. IN NO EVENT SHALL Simon Edwards <simon@simonzone.com> BE LIABLE FOR ANY
+# DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES
+# (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES;
+# LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND
+# ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
+# (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS
+# SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+#
+# FindPyQt.py
+# Copyright (c) 2007, Simon Edwards <simon@simonzone.com>
+# Copyright (c) 2015, Alexei Ardyakov <ardjakov@rambler.ru>
+# Redistribution and use is allowed according to the terms of the BSD license.
+# For details see the accompanying COPYING-CMAKE-SCRIPTS file.
+
+import os
+
+def get_pyqt_sip_dir():
+ # Only works for a few popular locations of PyQt4 SIP directory.
+ import sipconfig
+ sipcfg = sipconfig.Configuration()
+ default_sip_dir = sipcfg.default_sip_dir
+ postfixes = ('Py2-PyQt4', 'PyQt4',)
+ for postfix in postfixes:
+ pyqt_sip_dir = os.path.join(default_sip_dir, postfix)
+ if os.path.exists(pyqt_sip_dir) and os.path.exists(
+ os.path.join(pyqt_sip_dir, 'QtCore')):
+ return pyqt_sip_dir
+ return default_sip_dir
+
+
+def get_pyqt_bin_dir():
+ import sipconfig
+ sipcfg = sipconfig.Configuration()
+ return sipcfg.default_bin_dir
+
+
+try:
+ import PyQt4.pyqtconfig
+ pyqtcfg = PyQt4.pyqtconfig.Configuration()
+ pyqt_version = pyqtcfg.pyqt_version
+ pyqt_version_str = pyqtcfg.pyqt_version_str
+ pyqt_mod_dir = pyqtcfg.pyqt_mod_dir
+ pyqt_sip_dir = pyqtcfg.pyqt_sip_dir
+ pyqt_sip_flags = pyqtcfg.pyqt_sip_flags
+ pyqt_bin_dir = pyqtcfg.pyqt_bin_dir
+except ImportError:
+ # PyQt4 built with configure-ng.py has no pyqtconfig module
+ import PyQt4.QtCore
+ pyqt_version = PyQt4.QtCore.PYQT_VERSION
+ pyqt_version_str = PyQt4.QtCore.PYQT_VERSION_STR
+ pyqt_mod_dir = os.path.dirname(os.path.dirname(PyQt4.QtCore.__file__))
+ pyqt_sip_dir = get_pyqt_sip_dir()
+ pyqt_sip_flags = PyQt4.QtCore.PYQT_CONFIGURATION["sip_flags"]
+ pyqt_bin_dir = get_pyqt_bin_dir()
+
+pyqt_version_tag = ""
+in_t = False
+for item in pyqt_sip_flags.split(' '):
+ if item=="-t":
+ in_t = True
+ elif in_t:
+ if item.startswith("Qt_4"):
+ pyqt_version_tag = item
+ else:
+ in_t = False
+
+print("pyqt_version_tag:%s" % pyqt_version_tag)
+print("pyqt_version:%06.0x" % pyqt_version)
+print("pyqt_version_num:%d" % pyqt_version)
+print("pyqt_version_str:%s" % pyqt_version_str)
+print("pyqt_mod_dir:%s" % pyqt_mod_dir)
+print("pyqt_sip_dir:%s" % pyqt_sip_dir)
+print("pyqt_sip_flags:%s" % pyqt_sip_flags)
+print("pyqt_bin_dir:%s" % pyqt_bin_dir)
+
+
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 00000000000..84c3b3a2a03
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,73 @@
+# Contributor: MutantMonkey <mutantmonkey@gmail.com>
+pkgname=qgis-1.6
+pkgver=15265
+pkgrel=7
+pkgdesc="Quantum GIS, Geographic Information System; old 1.6 stable version"
+arch=('i686' 'x86_64')
+url="http://qgis.org/"
+license=('GPL')
+depends=('libmysqlclient' 'postgresql-libs' 'sqlite3' 'jasper' 'curl' 'qt4' 'python2' 'python2-pyqt' 'giflib' 'xerces-c' 'cfitsio' 'qwt5' 'gdal')
+makedepends=('subversion' 'grass64' 'gsl' 'postgis' 'netcdf' 'cmake' 'fcgi' 'python2-sip' 'pyqt')
+optdepends=('postgis: postgis support and SPIT plugin'
+ 'fcgi: qgis mapserver'
+ 'python2-sip: python-support'
+ 'grass64: grass plugin'
+ 'gsl: georeferencer ')
+provides=('qgis')
+conflicts=('qgis' 'qgis-git' 'qwt')
+options=('!makeflags')
+source=('qgis.desktop'
+ 'fix-bunch_errors.patch'
+ 'FindPyQt.py')
+md5sums=('8ab66039f2aba519b92f52272ec3c13e'
+ 'a4ebe0567ab3c35437039412e27d1ac0'
+ 'e14fc64843d36a7301928b4efd4a3274')
+
+_svntrunk=https://svn.osgeo.org/qgis/branches/Release-1_6_0
+_svnmod=qgis-1.6
+
+build() {
+ cd "$srcdir"
+
+ if [ -d $_svnmod/.svn ]; then
+ (cd $_svnmod && svn up -r $pkgver)
+ else
+ svn co $_svntrunk --config-dir ./ -r $pkgver $_svnmod
+ fi
+
+ msg "SVN checkout done or server timeout"
+ msg "Starting make..."
+
+ rm -rf "$srcdir/$_svnmod-build"
+ cp -r "$srcdir/$_svnmod" "$srcdir/$_svnmod-build"
+ cd "$srcdir/$_svnmod-build"
+ patch -p0 -i ${srcdir}/fix-bunch_errors.patch
+
+ mv "${srcdir}/FindPyQt.py" cmake/
+ find . -iname '*.py' | xargs sed -ie 's:^#!/usr/bin/env python$:#!/usr/bin/env python2:'
+ find . -iname '*.py' | xargs sed -ie 's:^#!/usr/bin/python$:#!/usr/bin/env python2:'
+
+
+ cmake . \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DPEDANTIC=TRUE \
+ -DCMAKE_SKIP_RPATH=ON \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DGRASS_PREFIX=/opt/grass64 \
+ -DQGIS_MANUAL_SUBDIR=share/man \
+ -DPYTHON_LIBRARY=/usr/lib/libpython2.7.so \
+ -DPYTHON_EXECUTABLE=/usr/bin/python2 \
+ -DPYTHON_SITE_PACKAGES_DIR=/usr/lib/python2.7/site-packages \
+ -DPYTHON_INCLUDE_PATH=/usr/include/python2.7/
+
+ make || return 1
+}
+
+package() {
+ cd "$srcdir/$_svnmod-build"
+ make install DESTDIR=${pkgdir}
+
+ # install some freedesktop.org compatibility
+ install -D -m644 ${srcdir}/qgis.desktop \
+ ${pkgdir}/usr/share/applications/qgis.desktop
+}
diff --git a/fix-bunch_errors.patch b/fix-bunch_errors.patch
new file mode 100644
index 00000000000..e0fd3f7e80f
--- /dev/null
+++ b/fix-bunch_errors.patch
@@ -0,0 +1,107 @@
+--- cmake/FindGDAL.cmake
++++ cmake/FindGDAL.cmake
+@@ -83,7 +83,7 @@
+ # check for gdal version
+ # version 1.2.5 is known NOT to be supported (missing CPL_STDCALL macro)
+ # According to INSTALL, 1.4.0+ is required
+- IF (GDAL_VERSION_MAJOR LESS 1 OR GDAL_VERSION_MINOR LESS 4)
++ IF (GDAL_VERSION_MAJOR LESS 1)
+ MESSAGE (FATAL_ERROR "GDAL version is too old (${GDAL_VERSION}). Use 1.4.0 or higher.")
+ ENDIF (GDAL_VERSION_MAJOR LESS 1 OR GDAL_VERSION_MINOR LESS 4)
+
+--- cmake/FindQWT.cmake
++++ cmake/FindQWT.cmake
+@@ -18,10 +18,10 @@
+ /usr/local/include
+ "$ENV{LIB_DIR}/include"
+ "$ENV{INCLUDE}"
+- PATH_SUFFIXES qwt-qt4 qwt
++ PATH_SUFFIXES qwt5 qwt-qt4 qwt
+ )
+
+-FIND_LIBRARY(QWT_LIBRARY NAMES qwt qwt5 qwt-qt4 qwt5-qt4 PATHS
++FIND_LIBRARY(QWT_LIBRARY NAMES qwt5 qwt qwt-qt4 qwt5-qt4 PATHS
+ /usr/lib
+ /usr/local/lib
+ "$ENV{LIB_DIR}/lib"
+--- cmake/SIPMacros.cmake
++++ cmake/SIPMacros.cmake
+@@ -85,11 +85,27 @@
+ ENDIF( ${CONCAT_NUM} LESS ${SIP_CONCAT_PARTS} )
+ ENDFOREACH(CONCAT_NUM RANGE 0 ${SIP_CONCAT_PARTS} )
+
++ # Suppress warnings
++ IF(PEDANTIC)
++ IF(MSVC)
++ # 4996 deprecation warnings (bindings re-export deprecated methods)
++ # 4701 potentially uninitialized variable used (sip generated code)
++ # 4702 unreachable code (sip generated code)
++ ADD_DEFINITIONS( /wd4996 /wd4701 /wd4702 )
++ ELSE(MSVC)
++ # disable all warnings
++ ADD_DEFINITIONS( -w )
++ IF(NOT APPLE)
++ ADD_DEFINITIONS( -fpermissive )
++ ENDIF(NOT APPLE)
++ ENDIF(MSVC)
++ ENDIF(PEDANTIC)
++
+ ADD_CUSTOM_COMMAND(
+ OUTPUT ${_sip_output_files}
+ COMMAND ${CMAKE_COMMAND} -E echo ${message}
+ COMMAND ${CMAKE_COMMAND} -E touch ${_sip_output_files}
+- COMMAND ${SIP_BINARY_PATH} ${_sip_tags} ${_sip_x} ${SIP_EXTRA_OPTIONS} -j ${SIP_CONCAT_PARTS} -c ${CMAKE_CURRENT_BINARY_DIR}/${_module_path} ${_sip_includes} ${_abs_module_sip}
++ COMMAND ${SIP_BINARY_PATH} ${_sip_tags} -e ${_sip_x} ${SIP_EXTRA_OPTIONS} -j ${SIP_CONCAT_PARTS} -c ${CMAKE_CURRENT_BINARY_DIR}/${_module_path} ${_sip_includes} ${_abs_module_sip}
+ DEPENDS ${_abs_module_sip} ${SIP_EXTRA_FILES_DEPEND}
+ )
+ # not sure if type MODULE could be uses anywhere, limit to cygwin for now
+--- src/core/qgsmaplayerregistry.h
++++ src/core/qgsmaplayerregistry.h
+@@ -121,16 +121,18 @@
+ //! protected constructor
+ QgsMapLayerRegistry( QObject * parent = 0 );
+
++ /** debugging member
++ invoked when a connect() is made to this object
++ */
++ void connectNotify( const char * signal );
++
+ private:
+
+ static QgsMapLayerRegistry* mInstance;
+
+ QMap<QString, QgsMapLayer*> mMapLayers;
+
+- /** debugging member
+- invoked when a connect() is made to this object
+- */
+- void connectNotify( const char * signal );
++
+
+
+ }; // class QgsMapLayerRegistry
+--- src/gui/qgsmapcanvas.h
++++ src/gui/qgsmapcanvas.h
+@@ -380,6 +380,11 @@
+ /// Handle pattern for implementation object
+ std::auto_ptr<CanvasProperties> mCanvasProperties;
+
++ /**debugging member
++ invoked when a connect() is made to this object
++ */
++ void connectNotify( const char * signal );
++
+ private:
+ /// this class is non-copyable
+ /**
+@@ -424,10 +429,6 @@
+ the last entry in case a lot of resize events arrive in short time*/
+ QList< QPair<int, int> > mResizeQueue;
+
+- /**debugging member
+- invoked when a connect() is made to this object
+- */
+- void connectNotify( const char * signal );
+
+ //! current layer in legend
+ QgsMapLayer* mCurrentLayer;
diff --git a/qgis.desktop b/qgis.desktop
new file mode 100644
index 00000000000..c3db5ad0803
--- /dev/null
+++ b/qgis.desktop
@@ -0,0 +1,10 @@
+[Desktop Entry]
+Name=Quantum GIS
+GenericName="GIS"
+Comment="Geographic Information System (GIS) that supports vector, raster & database formats"
+Exec=/usr/bin/qgis
+Icon=/usr/share/qgis/images/icons/qgis-icon.png
+Terminal=false
+MultipleArgs=false
+Type=Application
+Categories=Application;Science