summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSamuel Mesa2018-10-21 15:37:25 -0500
committerSamuel Mesa2018-10-21 15:37:25 -0500
commit4031294e1d56999bb7da6db55112ccda3323f84f (patch)
tree9c08a35c347883d26653a0f39119ee35637e0970
parent64e3b44d9fe0562c30f3ec361de09ebe0a607bf4 (diff)
downloadaur-4031294e1d56999bb7da6db55112ccda3323f84f.tar.gz
Initial version 3.0.0 for QGIS 3.3.x
-rw-r--r--PKGBUILD36
1 files changed, 9 insertions, 27 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 59f96ad1ade2..b4215ead063a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,36 +1,18 @@
# Author: Samuel Fernando Mesa <samuelmesa at linuxmail dot org>
-pkgname=qgis2-crayfish-plugin
-_pkgname=qgis-crayfish-plugin
-pkgver='2.7.2'
+pkgname=qgis-crayfish-plugin
+pkgver='3.0.0'
pkgrel=1
-pkgdesc="Visualiser for temporal structured and unstructured grids in QGIS 2.x. "
+pkgdesc="Visualiser for temporal structured and unstructured grids in QGIS 3.3.x "
arch=('i686' 'x86_64')
url="https://www.lutraconsulting.co.uk/products/crayfish/"
license=('GPL3')
-depends=('qgis-ltr' 'gdal' 'hdf5' 'netcdf' 'python2' 'python2-sip')
-source=(https://github.com/lutraconsulting/${_pkgname}/archive/release-${pkgver}.tar.gz)
-md5sums=('8c57feba4da7471ee941c9aaec9fef80')
-
-prepare() {
- cd "${_pkgname}-release-${pkgver}"
-
- # Change version of Python2
- sed -i s/python/python2/g install.py
-}
-
-build() {
- cd "${_pkgname}-release-${pkgver}"
-
- qmake-qt4 PREFIX=/usr
-
- make
-}
+depends=('qgis-git' 'gdal' 'hdf5' 'netcdf' 'python2' 'python2-sip')
+source=(https://github.com/lutraconsulting/qgis-crayfish-plugin/archive/release-${pkgver}.tar.gz)
+md5sums=('3195816365e31a46b6575c2bc56d5089')
package() {
- cd "${_pkgname}-release-${pkgver}"
- mkdir -p ${pkgdir}/usr/share/qgis/python/plugins/
- mkdir -p ${pkgdir}/usr/lib/
- cp -dr --no-preserve=ownership crayfish "${pkgdir}/usr/share/qgis/python/plugins/"
- cp --no-preserve=ownership crayfish/*.so* "${pkgdir}/usr/lib/"
+ cd "${pkgname}-release-${pkgver}"
+ mkdir -p ${pkgdir}/opt/qgis-git/share/qgis/python/plugins/
+ cp -dr --no-preserve=ownership crayfish "${pkgdir}/opt/qgis-git/share/qgis/python/plugins/"
}