summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSamuel Mesa2018-10-21 15:16:14 -0500
committerSamuel Mesa2018-10-21 15:16:14 -0500
commit64e3b44d9fe0562c30f3ec361de09ebe0a607bf4 (patch)
treea7026b21737a1d2544f195f165d3b24948da394a
parentfb05cba44de964a972669fca13da4a43da2cda0f (diff)
downloadaur-64e3b44d9fe0562c30f3ec361de09ebe0a607bf4.tar.gz
Update version 2.7.2 and dependencies
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD22
2 files changed, 19 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d23cd84aca93..99914220b34c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,19 @@
-pkgbase = qgis-crayfish-plugin
- pkgdesc = Visualiser for temporal structured and unstructured grids in QGIS.
- pkgver = 2.7.0
+pkgbase = qgis2-crayfish-plugin
+ pkgdesc = Visualiser for temporal structured and unstructured grids in QGIS 2.x.
+ pkgver = 2.7.2
pkgrel = 1
url = https://www.lutraconsulting.co.uk/products/crayfish/
arch = i686
arch = x86_64
license = GPL3
- depends = qt4>=4.7
+ depends = qgis-ltr
depends = gdal
depends = hdf5
depends = netcdf
depends = python2
depends = python2-sip
- source = https://github.com/lutraconsulting/qgis-crayfish-plugin/archive/release-2.7.0.tar.gz
- md5sums = ee80b1b33efc33b907d8f7f330771ef0
+ source = https://github.com/lutraconsulting/qgis-crayfish-plugin/archive/release-2.7.2.tar.gz
+ md5sums = 8c57feba4da7471ee941c9aaec9fef80
-pkgname = qgis-crayfish-plugin
+pkgname = qgis2-crayfish-plugin
diff --git a/PKGBUILD b/PKGBUILD
index 42141b74b3c8..59f96ad1ade2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,26 +1,26 @@
# Author: Samuel Fernando Mesa <samuelmesa at linuxmail dot org>
-pkgname=qgis-crayfish-plugin
-pkgver='2.7.0'
+pkgname=qgis2-crayfish-plugin
+_pkgname=qgis-crayfish-plugin
+pkgver='2.7.2'
pkgrel=1
-pkgdesc="Visualiser for temporal structured and unstructured grids in QGIS. "
+pkgdesc="Visualiser for temporal structured and unstructured grids in QGIS 2.x. "
arch=('i686' 'x86_64')
url="https://www.lutraconsulting.co.uk/products/crayfish/"
license=('GPL3')
-depends=('qt4>=4.7' 'gdal' 'hdf5' 'netcdf' 'python2' 'python2-sip')
-source=(https://github.com/lutraconsulting/${pkgname}/archive/release-${pkgver}.tar.gz)
-md5sums=('ee80b1b33efc33b907d8f7f330771ef0')
-
+depends=('qgis-ltr' 'gdal' 'hdf5' 'netcdf' 'python2' 'python2-sip')
+source=(https://github.com/lutraconsulting/${_pkgname}/archive/release-${pkgver}.tar.gz)
+md5sums=('8c57feba4da7471ee941c9aaec9fef80')
prepare() {
- cd "${pkgname}-release-${pkgver}"
+ cd "${_pkgname}-release-${pkgver}"
# Change version of Python2
sed -i s/python/python2/g install.py
}
build() {
- cd "${pkgname}-release-${pkgver}"
+ cd "${_pkgname}-release-${pkgver}"
qmake-qt4 PREFIX=/usr
@@ -28,7 +28,9 @@ build() {
}
package() {
- cd "${pkgname}-release-${pkgver}"
+ cd "${_pkgname}-release-${pkgver}"
mkdir -p ${pkgdir}/usr/share/qgis/python/plugins/
+ mkdir -p ${pkgdir}/usr/lib/
cp -dr --no-preserve=ownership crayfish "${pkgdir}/usr/share/qgis/python/plugins/"
+ cp --no-preserve=ownership crayfish/*.so* "${pkgdir}/usr/lib/"
}