summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSamuel Mesa2017-12-02 14:33:42 -0500
committerSamuel Mesa2017-12-02 14:33:42 -0500
commitfb05cba44de964a972669fca13da4a43da2cda0f (patch)
tree3f6bd32fe5e9209ebdaba0069beb9e3259adc213
parent8fb7f3290fca2b123cd211720f94548db169ee77 (diff)
downloadaur-fb05cba44de964a972669fca13da4a43da2cda0f.tar.gz
Initial version 2.7.0
-rw-r--r--.SRCINFO33
-rw-r--r--PKGBUILD51
-rw-r--r--appset-helper.service8
-rw-r--r--appset-qt-errno.patch68
-rw-r--r--appset-qt.changelog153
-rw-r--r--appset-qt.install23
6 files changed, 34 insertions, 302 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6b109a6857b7..d23cd84aca93 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,24 +1,19 @@
-# Generated by mksrcinfo v8
-# Tue May 31 14:36:25 UTC 2016
-pkgbase = appset-qt
- pkgdesc = An advanced and feature rich Package Manager Frontend
- pkgver = 0.7.2
- pkgrel = 6
- url = http://appset.sourceforge.net/
- install = appset-qt.install
- changelog = appset-qt.changelog
+pkgbase = qgis-crayfish-plugin
+ pkgdesc = Visualiser for temporal structured and unstructured grids in QGIS.
+ pkgver = 2.7.0
+ pkgrel = 1
+ url = https://www.lutraconsulting.co.uk/products/crayfish/
arch = i686
arch = x86_64
- license = GPL2
+ license = GPL3
depends = qt4>=4.7
- depends = qtwebkit
- optdepends = packer: for AUR support
- source = http://sourceforge.net/projects/appset/files/appset-qt/0.7/0.7.2/appset-qt-0.7.2-sources.tar.gz
- source = appset-qt-errno.patch
- source = appset-helper.service
- md5sums = 8658b6452e1f941af8501a6a772b6cd9
- md5sums = c26afcf570cdc6b954150fe39d116b85
- md5sums = 7791c134cc275b387c1290f771e43a3d
+ depends = gdal
+ depends = hdf5
+ depends = netcdf
+ depends = python2
+ depends = python2-sip
+ source = https://github.com/lutraconsulting/qgis-crayfish-plugin/archive/release-2.7.0.tar.gz
+ md5sums = ee80b1b33efc33b907d8f7f330771ef0
-pkgname = appset-qt
+pkgname = qgis-crayfish-plugin
diff --git a/PKGBUILD b/PKGBUILD
index 7c3f2a3b1627..42141b74b3c8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,45 +1,34 @@
-# Author: Simone Tobia <simone.tobia at gmail dot com>
-# Maintainer: Evgeniy "arcanis" Alekseev <esalexeev@gmail.com>
+# Author: Samuel Fernando Mesa <samuelmesa at linuxmail dot org>
-pkgname=appset-qt
-pkgver='0.7.2'
-pkgrel=6
-pkgdesc="An advanced and feature rich Package Manager Frontend"
+pkgname=qgis-crayfish-plugin
+pkgver='2.7.0'
+pkgrel=1
+pkgdesc="Visualiser for temporal structured and unstructured grids in QGIS. "
arch=('i686' 'x86_64')
-url="http://appset.sourceforge.net/"
-license=('GPL2')
-depends=('qt4>=4.7' 'qtwebkit')
-optdepends=('packer: for AUR support')
-source=(http://sourceforge.net/projects/appset/files/appset-qt/0.7/${pkgver}/${pkgname}-${pkgver}-sources.tar.gz
- appset-qt-errno.patch
- appset-helper.service)
-install=${pkgname}.install
-changelog=${pkgname}.changelog
-md5sums=('8658b6452e1f941af8501a6a772b6cd9'
- 'c26afcf570cdc6b954150fe39d116b85'
- '7791c134cc275b387c1290f771e43a3d')
+url="https://www.lutraconsulting.co.uk/products/crayfish/"
+license=('GPL3')
+depends=('qt4>=4.7' 'gdal' 'hdf5' 'netcdf' 'python2' 'python2-sip')
+source=(https://github.com/lutraconsulting/${pkgname}/archive/release-${pkgver}.tar.gz)
+md5sums=('ee80b1b33efc33b907d8f7f330771ef0')
+
prepare() {
- patch -p0 -i "appset-qt-errno.patch"
+ cd "${pkgname}-release-${pkgver}"
+
+ # Change version of Python2
+ sed -i s/python/python2/g install.py
}
build() {
- cd "${pkgname}-${pkgver}-sources"
+ cd "${pkgname}-release-${pkgver}"
- qmake-qt4 PREFIX=/usr -Wnone
-
- # localization
- lrelease-qt4 Qt/AppSet-Qt/*.ts
- lrelease-qt4 Qt/AppSetTray-Qt/*.ts
- lrelease-qt4 Qt/AppSetRepoEditor-Qt/*.ts
+ qmake-qt4 PREFIX=/usr
make
}
package() {
- cd "${pkgname}-${pkgver}-sources"
-
- make INSTALL_ROOT="${pkgdir}" install
- # appset-helper daemon
- install -D -m644 ../appset-helper.service "${pkgdir}/usr/lib/systemd/system/appset-helper.service"
+ cd "${pkgname}-release-${pkgver}"
+ mkdir -p ${pkgdir}/usr/share/qgis/python/plugins/
+ cp -dr --no-preserve=ownership crayfish "${pkgdir}/usr/share/qgis/python/plugins/"
}
diff --git a/appset-helper.service b/appset-helper.service
deleted file mode 100644
index de8c48d69ff7..000000000000
--- a/appset-helper.service
+++ /dev/null
@@ -1,8 +0,0 @@
-[Unit]
-Description=Appset Helper Daemon
-
-[Service]
-ExecStart=/usr/bin/appset-helper
-
-[Install]
-WantedBy=multi-user.target
diff --git a/appset-qt-errno.patch b/appset-qt-errno.patch
deleted file mode 100644
index 6b71a23d5031..000000000000
--- a/appset-qt-errno.patch
+++ /dev/null
@@ -1,68 +0,0 @@
-diff -ruN appset-qt-0.7.2-sources.orig/Qt/AppSet-Qt/mainwindow.cpp appset-qt-0.7.2-sources/Qt/AppSet-Qt/mainwindow.cpp
---- appset-qt-0.7.2-sources.orig/Qt/AppSet-Qt/mainwindow.cpp 2016-05-31 17:29:22.470617773 +0300
-+++ appset-qt-0.7.2-sources/Qt/AppSet-Qt/mainwindow.cpp 2016-05-31 17:30:12.202129800 +0300
-@@ -84,22 +84,22 @@
- #ifdef unix
- as = new AS::QTNIXEngine(new InputProvider());
-
-- int errno=0;
-+ int errorNumber=0;
- pp=privilegedExecuter(qApp->argc(),qApp->argv());
- bool privileged=pp>0 && pp!=9 && pp!=11;
- if(privileged){
- this->setWindowTitle("AppSet-Qt (SUPERUSER)");
- }else{
- system("appsettray-qt &");
-
- ui->cancelOpsWidget->hide();
- }
- argsParsed=pp!=4 && pp!=0;
- if((errno=((AS::QTNIXEngine*)as)->configure("/etc/appset.conf",privileged?"/tmp/as.tmp":"/tmp/asuser.tmp",!privileged))){
- if(privileged){
- QMessageBox errMsg;
- errMsg.setText(tr("Errors while initializing the system!"));
-- errMsg.setInformativeText(((AS::QTNIXEngine*)as)->getConfErrStr(errno));
-+ errMsg.setInformativeText(((AS::QTNIXEngine*)as)->getConfErrStr(errorNumber));
- errMsg.setIcon(QMessageBox::Critical);
- errMsg.exec();
- }
-diff -ruN appset-qt-0.7.2-sources.orig/Qt/AppSetTray-Qt/trayicon.cpp appset-qt-0.7.2-sources/Qt/AppSetTray-Qt/trayicon.cpp
---- appset-qt-0.7.2-sources.orig/Qt/AppSetTray-Qt/trayicon.cpp 2016-05-31 17:29:22.467284562 +0300
-+++ appset-qt-0.7.2-sources/Qt/AppSetTray-Qt/trayicon.cpp 2016-05-31 17:29:34.096858684 +0300
-@@ -42,8 +42,8 @@
-
- #ifdef unix
- as = new AS::QTNIXEngine(new InputProvider());
-- int errno=0;
-- if((errno=((AS::QTNIXEngine*)as)->configure("/etc/appset.conf","/tmp/astray.tmp",true))){
-+ int errorNumber=0;
-+ if((errorNumber=((AS::QTNIXEngine*)as)->configure("/etc/appset.conf","/tmp/astray.tmp",true))){
- exit(1);
- }
- #endif
-diff -ruN appset-qt-0.7.2-sources.orig/Qt/libappset-qt/asqtnixengine.cpp appset-qt-0.7.2-sources/Qt/libappset-qt/asqtnixengine.cpp
---- appset-qt-0.7.2-sources.orig/Qt/libappset-qt/asqtnixengine.cpp 2016-05-31 17:29:22.470617773 +0300
-+++ appset-qt-0.7.2-sources/Qt/libappset-qt/asqtnixengine.cpp 2016-05-31 17:29:37.086749191 +0300
-@@ -210,8 +210,8 @@
- return status;
- }
-
--QString AS::QTNIXEngine::getConfErrStr(int errno){
-- switch(errno){
-+QString AS::QTNIXEngine::getConfErrStr(int errorNumber){
-+ switch(errorNumber){
- case 1:
- return QObject::tr("Cannot open appset.conf file, check your AppSet configuration");
- case 2:
-diff -ruN appset-qt-0.7.2-sources.orig/Qt/libappset-qt/asqtnixengine.h appset-qt-0.7.2-sources/Qt/libappset-qt/asqtnixengine.h
---- appset-qt-0.7.2-sources.orig/Qt/libappset-qt/asqtnixengine.h 2016-05-31 17:29:22.470617773 +0300
-+++ appset-qt-0.7.2-sources/Qt/libappset-qt/asqtnixengine.h 2016-05-31 17:29:40.893276456 +0300
-@@ -48,7 +48,7 @@
- public:
- QTNIXEngine(InputProvider *ip){inputProvider=ip;stopRequested=false;buildBatch=false;batching = false;}
-
-- QString getConfErrStr(int errno);
-+ QString getConfErrStr(int errorNumber);
-
- int compareVersions(const QString &s1, const QString &s2);
-
diff --git a/appset-qt.changelog b/appset-qt.changelog
deleted file mode 100644
index 8d085418c404..000000000000
--- a/appset-qt.changelog
+++ /dev/null
@@ -1,153 +0,0 @@
-0.7.1 :
- -"Memory leak in trayicon when no sync folder present" bug fixed
- -"Locale format" bug fixed
- -Changed deprecated (in Qt 4.8) function calls for QQueue
- -Updated zh_TW and hu_HU translations
-
-0.7.0 :
- -A button to stop package downloading once started (feature req. #3413922)
- -Owned files tree view tab for installed packages (with desktop theme file icons, not in enhanced view, feature req. #3413878)
- -New packages search filter: repository
- -Per repository statistics
- -An alternative (not for AUR/CCR) way to execute requested operations on an external X Terminal emulator where:
- *the X Terminal Emulator is configurable via options panel
- *in the "check and apply" page you can select (via radio button) to use the internal (like before and default) or external tool
- *AUR/CCR now working only with external tools (also fixes bug #3420465 and #3413000)
- -New option for tray icon visibility (Always or only when there are available updates)
- -New option to enable/disable rss feed reader (feature req. #3353471)
- -New option to enable/disable packages homepage loading (feature req. #3353471)
- -New option to select the first page ("Start" or "All" packages)
- -Tabbed options panel
- -Hungarian translation
-
-0.6.4 :
- -AUR/CCR show installed action fixed (bug #3399666)
- -Main GUI memory optimizations
-
-0.6.3 :
- -Tray icon change after db upgrade (bug #3394196)
- -Minor memory optimizations
-
-0.6.2 :
- -Upgrade not asking for packages replace bug fixed
- -Tray icon increasing amount of memory over time bug fixed
- -Extra info checkbox not working bug fixed
-
-0.6.1 :
- -Black feed reader widget with dark themes bug fixed (bug #3376645)
- -Software categories in packages view as left panel (feature req. #3321918)
- -Packages homepage and details in separated tabs
- -Other minor UI changes
- -Basque translation
- -Russian translation
-
-0.6.0 :
- -The option to manually answer to backend's questions (only in english). There are 3 choices in option panel:
- *Automatic (the old behaviour)
- *Semi-Automatic (few user interactions required - By now only questions like: "Replace ... with ... ?" and "... and ... are in conflict. Remove ...?") DEFAULT
- *Ask everything (All backend questions require user interaction)
- -Repository editor tool (show, modify, add, remove and change priority for repositories)
- -"Report a bug" and "Request a feature" buttons in main GUI
- -The option to disable packages preload on startup to minimize memory and CPU usage on boot
- -Upgrade backend tool integration with new auth structure bug fixed
- -Chinese (China) translation
- -Portuguese (Portugal) translation
- -Portuguese (Brazilian) translation
- -pacman-color + packer + appset conflict fixed
- -"Start Fullscreen" bug fixed
- -"Extra Info" option persistency bug fixed
-
-
-0.5.1 :
- -Some minor bugs fixed for both tray and main GUI
- -Romanian translation
- -Serbian translation
-
-0.5.0 :
- -Completely new authorization structure:
- *Now starts immediately (without asking for password) as unprivileged user (every user can browse apps)
- *Requests superuser authorization for privileged operations (only when needed)
- *Drops superuser privileges immediately when it is not more useful (more secure)
- *Let's the main GUI to be preloaded by the tray (faster startup)
- *Closing/Minimizing the main GUI (also when running privileged operations) is managed by the tray
- *Tray click leads to show/hide the main GUI
- *Closing the tray also closes AppSet instances (when running privileged operations ask for a confirmation)
- *Tray "check for updates NOW!" action is now calling the authorization backend (and really works better than before)
- -Options are now stored "per user" (every possible sudoer has its own options)
- -New option "Auto select system files for upgrade" (checked by default) for "non expert users" (disabled if in expert mode)
- -Search bar delay now default to 1200 ms
- -Removed AppSetTray-Qt desktop file (now there is only AppSet-Qt in DE's menus)
- -Better integration with helper daemon
- -News reader now retries (every 5 seconds) to download feeds when fails (without hiding the panel)
- -Asks DE's Session Manager to cancel shutdown if the main GUI is still opened (to avoid errors caused by user distraction)
- -New About dialog
- -Chinese-Taiwan translation
-
-0.4.4 :
- -Simplified actions for standard view (e.g. install/remove actions with one click, withouth showing a redundant context menu)
- -Tray click when already running leading to a new appset start bug fixed
- -AUR/CCR "list installed" action with no results crash bug fixed
-
-0.4.3 :
- -Generalization of packages size output interpretation for pacman 3.5.2
- -Polish translation
-
-0.4.2 :
- -Installed packages repository information
- -lower niceness (10 -> 15) for appset-helper daemon
- -Infinite loop on upgrade deps check bug fixed
- -Pacman's "Replace %package% with ..." question now get "yes" answer on upgrades (no more using --noconfirm option on upgrade/install)
-
-0.4.1 :
- -New packets view for main repos using QML:
- *more apps listed with the same win size
- *bigger embedded browser for detailed view
- *Touchscreen friendly
- *animated
- -option to switch between Standard (old) and Enhanced (new) views
- -Resize bug fixed for External repo (AUR) view
- -AppSet version in about dialog
- -Localization bug fixed for about dialog (automatic switch between English and Italian)
- -ExtraInfo option now is saved
- -Main backend (pacman) upgrade check and backend post upgrade command (pacman-db-upgrade)
- -Bug fixed for dependencies check
- -Flickering in progress window bug fixed
- -Default search bar delay to 900ms
-
-0.4.0 :
- -Basic support to AUR using packer as backend:
- *Browse packages with an embedded browser for their homepages (searching with a search bar)
- *Install AUR packages (one at a time)
- *Remove AUR packages (one at a time from the AUR specialized GUI - more than one with the normal GUI)
- *Upgrade AUR packages (all in the same time)
- *Automatic activation based on the presence of packer (the backend)
- *A button to show all external installed packages
- -Clean cache command now requires a confirmation from the user
-
-0.3.4 :
- -Repository information added to avoid incorect behaviours (with the management of multiple sources for the same application)
- -Option to view repository in packages table
- -Option to disable countdown for auto confirmation of changes
- -SearchBar now got the focus after a previous search
- -Web Preview now is navigable
- -Tray now shows "repo/package last_version" entries ordered by repo
-
-0.3.3 :
- -New outcome evaluation logic
- -Local precompiled packages installer (from main GUI, shell cmd argument or Desktop's "Open With..." menu)
- -Loading icon
- -Spanish translation
-
-0.3.2 :
- -Packages statistics (enabled via options)
- -Backend's output (enabled via options)
- -Interval between db updates selectable by options
- -Changes in main GUI
- -External Browser Command now accepts arguments
- -Bug fixed for updates operations outcome
-
-0.3.0-1 : Localization support
-
-0.2.X : Embedded browser and feed-reader, helper daemon and tray icon
-
-0.1.X : Basic functions to handle packages
diff --git a/appset-qt.install b/appset-qt.install
deleted file mode 100644
index ab2a660f3a2b..000000000000
--- a/appset-qt.install
+++ /dev/null
@@ -1,23 +0,0 @@
-whisperer(){
- echo "----------------------------------------------------------------"
- echo "Don't forget that this is an alpha release of AppSet-Qt."
- echo "You can test it but it is not recommended for use every day"
- echo "----------------------------------------------------------------"
- echo "AppSet is in your desktop menu under Applications->System"
- echo "To launch AppSet from shell run 'appset-launch.sh' as normal"
- echo "user."
- echo "----------------------------------------------------------------"
- echo "----------------------------------------------------------------"
- echo "IMPORTANT: NOW YOU NEED TO REBOOT YOUR COMPUTER TO LET APPSET"
- echo "WORKING AT ITS BEST"
- echo "----------------------------------------------------------------"
- echo "----------------------------------------------------------------"
-}
-
-post_install(){
- whisperer
-}
-
-post_upgrade(){
- whisperer
-}