summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHannes2023-07-07 13:09:07 +0200
committerHannes2023-07-07 13:09:07 +0200
commit14300cca8888f3cb992343317ec80fdc21b60e5c (patch)
tree089406e47d0d2254897073cb32601c84052c11a1
parentc7833e244bfcac47f16dbd1b6c26666ecf80af21 (diff)
downloadaur-14300cca8888f3cb992343317ec80fdc21b60e5c.tar.gz
Harmonized with qgis package (patches, makedepends, options, add server)
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD38
-rw-r--r--exiv2-0.28.patch52
-rw-r--r--protobuf-23.patch15
4 files changed, 106 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e82be6845bb5..c3910d401054 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,18 @@
pkgbase = qgis-git
pkgdesc = Geographic Information System (GIS) that supports vector, raster & database formats - Development master
- pkgver = 3.99_master.r78162.24a71d05862
+ pkgver = 3.99_master.r82542.5064b265645
pkgrel = 1
url = http://qgis.org/
- arch = i686
arch = x86_64
license = GPL
makedepends = git
makedepends = cmake
- makedepends = txt2tags
makedepends = ninja
makedepends = pyqt-builder
+ makedepends = opencl-clhpp
+ makedepends = fcgi
+ makedepends = qt5-tools
+ makedepends = sip
depends = proj
depends = geos
depends = sqlite
@@ -45,10 +47,13 @@ pkgbase = qgis-git
optdepends = grass: for GRASS providers and plugin (6 or 7)
optdepends = postgresql: for postgis and SPIT support
optdepends = gpsbabel: for gps plugin
- optdepends = fcgi: for qgis mapserver
optdepends = ocilib: oracle provider
provides = qgis
source = qgis::git+https://github.com/qgis/QGIS.git
- md5sums = SKIP
+ source = exiv2-0.28.patch
+ source = protobuf-23.patch
+ sha256sums = SKIP
+ sha256sums = 746ce9fe26f52e1e93b36b0f7738cce618aaaa44393914e9c5661dcfdd374511
+ sha256sums = ac6c96e88346c1cec739b1e628afb02aef1895c0d09213269bad75b1a8cee617
pkgname = qgis-git
diff --git a/PKGBUILD b/PKGBUILD
index ad9d15552caf..79b3ed4c1e45 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,29 +6,32 @@
pkgname=qgis-git
_pkgname=qgis
-pkgver=3.99_master.r78162.24a71d05862
+pkgver=3.99_master.r82542.5064b265645
_pkgver=3.99_master # fake pkgver prefix for the name
pkgrel=1
pkgdesc='Geographic Information System (GIS) that supports vector, raster & database formats - Development master'
url='http://qgis.org/'
license=('GPL')
-arch=('i686' 'x86_64')
+arch=('x86_64')
depends=(
'proj' 'geos' 'sqlite' 'qwtpolar' 'expat' 'spatialindex' 'gsl' 'libzip' 'exiv2' 'ocl-icd' 'protobuf' 'pdal-git'
'qt5-tools' 'qt5-script' 'qtkeychain' 'sip' 'qca-qt5' 'qt5-webkit' 'qt5-3d' 'qt5-serialport' 'qt5-xmlpatterns'
'python-gdal' 'python-owslib' 'python-future' 'python-psycopg2' 'python-yaml' 'python-numpy' 'python-jinja' 'python-pygments'
'python-pyqt5' 'python-qscintilla-qt5'
)
-makedepends=('git' 'cmake' 'txt2tags' 'ninja' 'pyqt-builder')
+makedepends=(git cmake ninja pyqt-builder opencl-clhpp fcgi qt5-tools sip)
optdepends=('grass: for GRASS providers and plugin (6 or 7)'
# 'gsl: for georeferencer'
'postgresql: for postgis and SPIT support'
'gpsbabel: for gps plugin'
- 'fcgi: for qgis mapserver'
'ocilib: oracle provider')
-source=("${_pkgname}::git+https://github.com/qgis/QGIS.git")
-md5sums=('SKIP')
+source=("${_pkgname}::git+https://github.com/qgis/QGIS.git"
+ exiv2-0.28.patch
+ protobuf-23.patch)
+sha256sums=('SKIP'
+ '746ce9fe26f52e1e93b36b0f7738cce618aaaa44393914e9c5661dcfdd374511'
+ 'ac6c96e88346c1cec739b1e628afb02aef1895c0d09213269bad75b1a8cee617')
provides=('qgis')
pkgver(){
@@ -37,6 +40,9 @@ pkgver(){
}
prepare() {
+ patch -d $_pkgname -p1 < exiv2-0.28.patch # Fix build with exiv2 0.28
+ patch -d $_pkgname -p1 < protobuf-23.patch # Fix build with protobuf 23
+
cd $_pkgname
# Fix desktop file for /usr/bin/qgis-github
@@ -63,10 +69,24 @@ build() {
-DCMAKE_INSTALL_PREFIX=/opt/$pkgname \
-DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DQGIS_MANUAL_SUBDIR=share/man \
- -DENABLE_TESTS=FALSE \
-DWITH_3D=TRUE \
- -DWITH_PDAL=TRUE
- #-DWITH_SERVER=TRUE
+ -DWITH_QUICK=TRUE \
+ -DWITH_SERVER=TRUE \
+ -DBINDINGS_GLOBAL_INSTALL=FALSE \
+ -DWITH_QTWEBKIT=FALSE \
+ -DWITH_QWTPOLAR=TRUE \
+ -DQWTPOLAR_LIBRARY=/usr/lib/libqwt.so \
+ -DQWTPOLAR_INCLUDE_DIR=/usr/include/qwt \
+ -DCMAKE_CXX_FLAGS="${CXXFLAGS} -DQWT_POLAR_VERSION=0x060200" \
+ -DWITH_INTERNAL_QWTPOLAR=FALSE \
+ -DWITH_PDAL=TRUE \
+ -DHAS_KDE_QT5_PDF_TRANSFORM_FIX=TRUE \
+ -DHAS_KDE_QT5_SMALL_CAPS_FIX=TRUE \
+ -DHAS_KDE_QT5_FONT_STRETCH_FIX=TRUE
+ # https://github.com/qgis/QGIS/issues/48374
+ #-DWITH_INTERNAL_LAZPERF=FALSE \
+ # https://github.com/qgis/QGIS/issues/35440
+ #-DWITH_PY_COMPILE=TRUE \
ninja
}
diff --git a/exiv2-0.28.patch b/exiv2-0.28.patch
new file mode 100644
index 000000000000..290b20f7e851
--- /dev/null
+++ b/exiv2-0.28.patch
@@ -0,0 +1,52 @@
+diff --git a/src/core/raster/qgsexiftools.cpp b/src/core/raster/qgsexiftools.cpp
+index 7fa2709845..f883d7960c 100644
+--- a/src/core/raster/qgsexiftools.cpp
++++ b/src/core/raster/qgsexiftools.cpp
+@@ -66,7 +66,11 @@ QVariant decodeXmpData( const QString &key, Exiv2::XmpData::const_iterator &it )
+ case Exiv2::signedLong:
+ case Exiv2::unsignedLongLong:
+ case Exiv2::signedLongLong:
++#if EXIV2_TEST_VERSION (0, 28, 0)
++ val = QVariant::fromValue( it->toUint32() );
++#else
+ val = QVariant::fromValue( it->toLong() );
++#endif
+ break;
+
+ case Exiv2::tiffDouble:
+@@ -80,7 +84,11 @@ QVariant decodeXmpData( const QString &key, Exiv2::XmpData::const_iterator &it )
+ case Exiv2::signedByte:
+ case Exiv2::tiffIfd:
+ case Exiv2::tiffIfd8:
++#if EXIV2_TEST_VERSION (0, 28, 0)
++ val = QVariant::fromValue( static_cast< int >( it->toUint32() ) );
++#else
+ val = QVariant::fromValue( static_cast< int >( it->toLong() ) );
++#endif
+ break;
+
+ case Exiv2::date:
+@@ -182,7 +190,11 @@ QVariant decodeExifData( const QString &key, Exiv2::ExifData::const_iterator &it
+ case Exiv2::signedLong:
+ case Exiv2::unsignedLongLong:
+ case Exiv2::signedLongLong:
++#if EXIV2_TEST_VERSION (0, 28, 0)
++ val = QVariant::fromValue( it->toUint32() );
++#else
+ val = QVariant::fromValue( it->toLong() );
++#endif
+ break;
+
+ case Exiv2::tiffDouble:
+@@ -196,7 +208,11 @@ QVariant decodeExifData( const QString &key, Exiv2::ExifData::const_iterator &it
+ case Exiv2::signedByte:
+ case Exiv2::tiffIfd:
+ case Exiv2::tiffIfd8:
++#if EXIV2_TEST_VERSION (0, 28, 0)
++ val = QVariant::fromValue( static_cast< int >( it->toUint32() ) );
++#else
+ val = QVariant::fromValue( static_cast< int >( it->toLong() ) );
++#endif
+ break;
+
+ case Exiv2::date:
diff --git a/protobuf-23.patch b/protobuf-23.patch
new file mode 100644
index 000000000000..8e236e692734
--- /dev/null
+++ b/protobuf-23.patch
@@ -0,0 +1,15 @@
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 48a34626b0..e2b5cca718 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -363,7 +363,9 @@ if(WITH_CORE)
+ message (SEND_ERROR "sqlite3 dependency was not found!")
+ endif()
+
+- find_package(Protobuf REQUIRED) # for decoding of vector tiles in MVT format
++ find_package(Protobuf CONFIG REQUIRED) # for decoding of vector tiles in MVT format
++ find_package(Protobuf) # for protobuf_generate_cpp
++ set(Protobuf_LITE_LIBRARY protobuf::libprotobuf-lite)
+ message(STATUS "Found Protobuf: ${Protobuf_LIBRARIES}")
+ if (NOT Protobuf_PROTOC_EXECUTABLE)
+ message (SEND_ERROR "Protobuf library's 'protoc' tool was not found!")