summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHannes2023-09-10 12:53:32 +0200
committerHannes2023-09-10 12:53:32 +0200
commite1fdbc6c7352ad09f5e8f5401647917ad4e9adab (patch)
tree58b89dd4c2d8934e04003e3498a02449dccf5955
parent14300cca8888f3cb992343317ec80fdc21b60e5c (diff)
downloadaur-e1fdbc6c7352ad09f5e8f5401647917ad4e9adab.tar.gz
Removed protobuf and exiv patches
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD13
-rw-r--r--exiv2-0.28.patch52
-rw-r--r--protobuf-23.patch15
4 files changed, 4 insertions, 82 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c3910d401054..3e9760554bfc 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = qgis-git
pkgdesc = Geographic Information System (GIS) that supports vector, raster & database formats - Development master
- pkgver = 3.99_master.r82542.5064b265645
+ pkgver = 3.99_master.r83167.f4f9432232a
pkgrel = 1
url = http://qgis.org/
arch = x86_64
@@ -50,10 +50,6 @@ pkgbase = qgis-git
optdepends = ocilib: oracle provider
provides = qgis
source = qgis::git+https://github.com/qgis/QGIS.git
- source = exiv2-0.28.patch
- source = protobuf-23.patch
sha256sums = SKIP
- sha256sums = 746ce9fe26f52e1e93b36b0f7738cce618aaaa44393914e9c5661dcfdd374511
- sha256sums = ac6c96e88346c1cec739b1e628afb02aef1895c0d09213269bad75b1a8cee617
pkgname = qgis-git
diff --git a/PKGBUILD b/PKGBUILD
index 79b3ed4c1e45..eef20dd74e1e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@
pkgname=qgis-git
_pkgname=qgis
-pkgver=3.99_master.r82542.5064b265645
+pkgver=3.99_master.r83167.f4f9432232a
_pkgver=3.99_master # fake pkgver prefix for the name
pkgrel=1
pkgdesc='Geographic Information System (GIS) that supports vector, raster & database formats - Development master'
@@ -26,12 +26,8 @@ optdepends=('grass: for GRASS providers and plugin (6 or 7)'
'gpsbabel: for gps plugin'
'ocilib: oracle provider')
-source=("${_pkgname}::git+https://github.com/qgis/QGIS.git"
- exiv2-0.28.patch
- protobuf-23.patch)
-sha256sums=('SKIP'
- '746ce9fe26f52e1e93b36b0f7738cce618aaaa44393914e9c5661dcfdd374511'
- 'ac6c96e88346c1cec739b1e628afb02aef1895c0d09213269bad75b1a8cee617')
+source=("${_pkgname}::git+https://github.com/qgis/QGIS.git")
+sha256sums=('SKIP')
provides=('qgis')
pkgver(){
@@ -40,9 +36,6 @@ pkgver(){
}
prepare() {
- patch -d $_pkgname -p1 < exiv2-0.28.patch # Fix build with exiv2 0.28
- patch -d $_pkgname -p1 < protobuf-23.patch # Fix build with protobuf 23
-
cd $_pkgname
# Fix desktop file for /usr/bin/qgis-github
diff --git a/exiv2-0.28.patch b/exiv2-0.28.patch
deleted file mode 100644
index 290b20f7e851..000000000000
--- a/exiv2-0.28.patch
+++ /dev/null
@@ -1,52 +0,0 @@
-diff --git a/src/core/raster/qgsexiftools.cpp b/src/core/raster/qgsexiftools.cpp
-index 7fa2709845..f883d7960c 100644
---- a/src/core/raster/qgsexiftools.cpp
-+++ b/src/core/raster/qgsexiftools.cpp
-@@ -66,7 +66,11 @@ QVariant decodeXmpData( const QString &key, Exiv2::XmpData::const_iterator &it )
- case Exiv2::signedLong:
- case Exiv2::unsignedLongLong:
- case Exiv2::signedLongLong:
-+#if EXIV2_TEST_VERSION (0, 28, 0)
-+ val = QVariant::fromValue( it->toUint32() );
-+#else
- val = QVariant::fromValue( it->toLong() );
-+#endif
- break;
-
- case Exiv2::tiffDouble:
-@@ -80,7 +84,11 @@ QVariant decodeXmpData( const QString &key, Exiv2::XmpData::const_iterator &it )
- case Exiv2::signedByte:
- case Exiv2::tiffIfd:
- case Exiv2::tiffIfd8:
-+#if EXIV2_TEST_VERSION (0, 28, 0)
-+ val = QVariant::fromValue( static_cast< int >( it->toUint32() ) );
-+#else
- val = QVariant::fromValue( static_cast< int >( it->toLong() ) );
-+#endif
- break;
-
- case Exiv2::date:
-@@ -182,7 +190,11 @@ QVariant decodeExifData( const QString &key, Exiv2::ExifData::const_iterator &it
- case Exiv2::signedLong:
- case Exiv2::unsignedLongLong:
- case Exiv2::signedLongLong:
-+#if EXIV2_TEST_VERSION (0, 28, 0)
-+ val = QVariant::fromValue( it->toUint32() );
-+#else
- val = QVariant::fromValue( it->toLong() );
-+#endif
- break;
-
- case Exiv2::tiffDouble:
-@@ -196,7 +208,11 @@ QVariant decodeExifData( const QString &key, Exiv2::ExifData::const_iterator &it
- case Exiv2::signedByte:
- case Exiv2::tiffIfd:
- case Exiv2::tiffIfd8:
-+#if EXIV2_TEST_VERSION (0, 28, 0)
-+ val = QVariant::fromValue( static_cast< int >( it->toUint32() ) );
-+#else
- val = QVariant::fromValue( static_cast< int >( it->toLong() ) );
-+#endif
- break;
-
- case Exiv2::date:
diff --git a/protobuf-23.patch b/protobuf-23.patch
deleted file mode 100644
index 8e236e692734..000000000000
--- a/protobuf-23.patch
+++ /dev/null
@@ -1,15 +0,0 @@
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index 48a34626b0..e2b5cca718 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -363,7 +363,9 @@ if(WITH_CORE)
- message (SEND_ERROR "sqlite3 dependency was not found!")
- endif()
-
-- find_package(Protobuf REQUIRED) # for decoding of vector tiles in MVT format
-+ find_package(Protobuf CONFIG REQUIRED) # for decoding of vector tiles in MVT format
-+ find_package(Protobuf) # for protobuf_generate_cpp
-+ set(Protobuf_LITE_LIBRARY protobuf::libprotobuf-lite)
- message(STATUS "Found Protobuf: ${Protobuf_LIBRARIES}")
- if (NOT Protobuf_PROTOC_EXECUTABLE)
- message (SEND_ERROR "Protobuf library's 'protoc' tool was not found!")