summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStephan Springer2023-03-15 20:06:21 +0100
committerStephan Springer2023-03-15 21:22:48 +0100
commit034bb2ef340c17b262be252fe4c9d1f583e904e5 (patch)
treec437371e7dc9d4ef3b8569c1cf1c7675fd07f510
parent31645a3172c1264a76fa589f3859d5c500cb8c78 (diff)
downloadaur-034bb2ef340c17b262be252fe4c9d1f583e904e5.tar.gz
update to version 3.28.4
-rw-r--r--.SRCINFO57
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD42
-rw-r--r--qgstyle-infinite-loop.patch61
4 files changed, 54 insertions, 109 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7cc0edb2f0c1..aa812d8e394e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,50 +1,53 @@
pkgbase = qgis-ltr
pkgdesc = Geographic Information System (GIS); Long Term Release
- pkgver = 3.22.16
+ pkgver = 3.28.4
pkgrel = 1
url = https://qgis.org/
arch = x86_64
license = GPL
makedepends = cmake
- makedepends = fcgi
makedepends = ninja
makedepends = opencl-clhpp
- makedepends = python-setuptools
- makedepends = python-six
+ makedepends = fcgi
makedepends = qt5-tools
- makedepends = txt2tags
makedepends = sip
makedepends = pyqt-builder
- depends = exiv2
+ depends = ocl-icd
+ depends = proj
+ depends = geos
depends = gdal
- depends = gsl
- depends = hicolor-icon-theme
+ depends = expat
+ depends = spatialindex
+ depends = qwt
depends = libzip
- depends = ocl-icd
- depends = pdal
+ depends = sqlite3
depends = protobuf
- depends = python-gdal
- depends = python-jinja
- depends = python-owslib
- depends = python-psycopg2
- depends = python-pygments
- depends = python-qscintilla-qt5
- depends = python-yaml
- depends = qca
- depends = qt5-3d
- depends = qt5-imageformats
+ depends = zlib
+ depends = exiv2
+ depends = postgresql-libs
+ depends = libspatialite
+ depends = zstd
+ depends = pdal
+ depends = qt5-base
+ depends = qt5-svg
depends = qt5-serialport
depends = qt5-location
+ depends = qt5-3d
+ depends = qt5-declarative
+ depends = qscintilla-qt5
depends = qtkeychain-qt5
- depends = qwt
- depends = spatialindex
+ depends = qca-qt5
+ depends = gsl
+ depends = python-pyqt5
+ depends = python-qscintilla-qt5
+ depends = hdf5
+ depends = netcdf
+ depends = libxml2
optdepends = fcgi: Map server
optdepends = gpsbabel: GPS Tools plugin
- provides = qgis=3.22.16
+ provides = qgis=3.28.4
conflicts = qgis
- source = https://download.qgis.org/downloads/qgis-3.22.16.tar.bz2
- source = qgstyle-infinite-loop.patch::https://github.com/qgis/QGIS/commit/19823b76.patch
- sha256sums = dbd1f8a639291bb2492eea61e4ef96079d7b27d3dfa538dab8cd98f31429254a
- sha256sums = c5bc388da987c7c21451b3f0f74220c8bd82cfba04657ff599d1896e6ae4b304
+ source = https://download.qgis.org/downloads/qgis-3.28.4.tar.bz2
+ sha256sums = 521c914de3a6753876d5e5d9a5bf9753cfa7b57b565a2df8017858f04c1643e3
pkgname = qgis-ltr
diff --git a/.gitignore b/.gitignore
index 71a9d16c2b38..c9e624e6cf09 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,4 +1,3 @@
*~
-*/
-*.tar.*
+qgis-*.tar.*
*.log
diff --git a/PKGBUILD b/PKGBUILD
index 345b270d21a0..183c7dee96e7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,5 +1,6 @@
# Maintainer: Stephan Springer <buzo+arch@Lini.de>
# Contributor: Balló György <ballogyor+arch at gmail dot com>
+# Contributor: Bruno Pagani <archange@archlinux.org>
# Contributor: Doug Newgard <scimmia at archlinux dot org>
# Contributor: XavierCLL <xavier.corredor.llano (a) gmail.com>
# Contributor: SaultDon <sault.don gmail>
@@ -11,36 +12,31 @@
_pkgname=qgis
pkgname="$_pkgname"-ltr
-pkgver=3.22.16
+pkgver=3.28.4
pkgrel=1
pkgdesc='Geographic Information System (GIS); Long Term Release'
+arch=(x86_64)
url='https://qgis.org/'
-license=('GPL')
-arch=('x86_64')
-depends=('exiv2' 'gdal' 'gsl' 'hicolor-icon-theme' 'libzip' 'ocl-icd' 'pdal' 'protobuf'
- 'python-gdal' 'python-jinja' 'python-owslib' 'python-psycopg2' 'python-pygments'
- 'python-qscintilla-qt5' 'python-yaml' 'qca' 'qt5-3d' 'qt5-imageformats'
- 'qt5-serialport' 'qt5-location' 'qtkeychain-qt5' 'qwt' 'spatialindex')
-makedepends=('cmake' 'fcgi' 'ninja' 'opencl-clhpp' 'python-setuptools' 'python-six' 'qt5-tools'
- 'txt2tags' 'sip' 'pyqt-builder')
+license=(GPL)
+depends=(ocl-icd proj geos gdal expat spatialindex qwt libzip sqlite3 protobuf
+ zlib exiv2 postgresql-libs libspatialite zstd pdal
+ qt5-base qt5-svg qt5-serialport qt5-location qt5-3d qt5-declarative
+ qscintilla-qt5 qtkeychain-qt5 qca-qt5 gsl python-pyqt5 python-qscintilla-qt5
+ hdf5 netcdf libxml2) # laz-perf
+makedepends=(cmake ninja opencl-clhpp fcgi qt5-tools sip pyqt-builder)
optdepends=('fcgi: Map server'
'gpsbabel: GPS Tools plugin')
provides=("$_pkgname=$pkgver")
conflicts=("$_pkgname")
-source=("https://download.qgis.org/downloads/$_pkgname-$pkgver.tar.bz2"
- qgstyle-infinite-loop.patch::https://github.com/qgis/QGIS/commit/19823b76.patch)
-sha256sums=('dbd1f8a639291bb2492eea61e4ef96079d7b27d3dfa538dab8cd98f31429254a'
- 'c5bc388da987c7c21451b3f0f74220c8bd82cfba04657ff599d1896e6ae4b304')
-# curl https://qgis.org/downloads/qgis-latest-ltr.tar.bz2.sha256
-
-prepare() {
- patch -d "$_pkgname-$pkgver" -p1 < qgstyle-infinite-loop.patch # Fix infinite loop
-}
+source=("https://download.qgis.org/downloads/$_pkgname-$pkgver.tar.bz2")
+sha256sums=('521c914de3a6753876d5e5d9a5bf9753cfa7b57b565a2df8017858f04c1643e3')
+# curl https://download.qgis.org/downloads/qgis-latest-ltr.tar.bz2.sha256
build() {
cmake -G Ninja -B build -S "$_pkgname-$pkgver" \
-DCMAKE_INSTALL_PREFIX=/usr \
-DWITH_3D=TRUE \
+ -DWITH_QUICK=TRUE \
-DWITH_SERVER=TRUE \
-DWITH_CUSTOM_WIDGETS=TRUE \
-DBINDINGS_GLOBAL_INSTALL=TRUE \
@@ -51,7 +47,15 @@ build() {
-DQWTPOLAR_INCLUDE_DIR=/usr/include/qwt \
-DCMAKE_CXX_FLAGS="${CXXFLAGS} -DQWT_POLAR_VERSION=0x060200" \
-DWITH_INTERNAL_QWTPOLAR=FALSE \
- -DWITH_PDAL=TRUE
+ -DWITH_PDAL=TRUE \
+ -DHAS_KDE_QT5_PDF_TRANSFORM_FIX=TRUE \
+ -DHAS_KDE_QT5_SMALL_CAPS_FIX=TRUE \
+ -DHAS_KDE_QT5_FONT_STRETCH_FIX=TRUE
+ # https://github.com/qgis/QGIS/issues/48374
+ #-DWITH_INTERNAL_LAZPERF=FALSE \
+ # https://github.com/qgis/QGIS/issues/35440
+ #-DWITH_PY_COMPILE=TRUE \
+
cmake --build build
}
diff --git a/qgstyle-infinite-loop.patch b/qgstyle-infinite-loop.patch
deleted file mode 100644
index f3501f3dd020..000000000000
--- a/qgstyle-infinite-loop.patch
+++ /dev/null
@@ -1,61 +0,0 @@
-From 19823b76c27c3bfbff1d111cf09af948e8db4367 Mon Sep 17 00:00:00 2001
-From: PeterPetrik <zilolv@gmail.com>
-Date: Fri, 2 Jul 2021 14:40:59 +0200
-Subject: [PATCH] fix infinite loop in qgsstyle
-
----
- src/core/symbology/qgsstyle.cpp | 6 ++++++
- 1 file changed, 6 insertions(+)
-
-diff --git a/src/core/symbology/qgsstyle.cpp b/src/core/symbology/qgsstyle.cpp
-index 6ca37dde3a15..c87305b3c8fa 100644
---- a/src/core/symbology/qgsstyle.cpp
-+++ b/src/core/symbology/qgsstyle.cpp
-@@ -2755,6 +2755,7 @@ bool QgsStyle::importXml( const QString &filename, int sinceVersion )
- if ( entityAddedVersion != 0 && sinceVersion != -1 && entityAddedVersion <= sinceVersion )
- {
- // skip the symbol, should already be present
-+ e = e.nextSiblingElement();
- continue;
- }
-
-@@ -2810,6 +2811,7 @@ bool QgsStyle::importXml( const QString &filename, int sinceVersion )
- if ( entityAddedVersion != 0 && sinceVersion != -1 && entityAddedVersion <= sinceVersion )
- {
- // skip the ramp, should already be present
-+ e = e.nextSiblingElement();
- continue;
- }
-
-@@ -2859,6 +2861,7 @@ bool QgsStyle::importXml( const QString &filename, int sinceVersion )
- if ( entityAddedVersion != 0 && sinceVersion != -1 && entityAddedVersion <= sinceVersion )
- {
- // skip the format, should already be present
-+ e = e.nextSiblingElement();
- continue;
- }
-
-@@ -2904,6 +2907,7 @@ bool QgsStyle::importXml( const QString &filename, int sinceVersion )
- if ( entityAddedVersion != 0 && sinceVersion != -1 && entityAddedVersion <= sinceVersion )
- {
- // skip the settings, should already be present
-+ e = e.nextSiblingElement();
- continue;
- }
-
-@@ -2950,6 +2954,7 @@ bool QgsStyle::importXml( const QString &filename, int sinceVersion )
- if ( entityAddedVersion != 0 && sinceVersion != -1 && entityAddedVersion <= sinceVersion )
- {
- // skip the shape, should already be present
-+ e = e.nextSiblingElement();
- continue;
- }
-
-@@ -2995,6 +3000,7 @@ bool QgsStyle::importXml( const QString &filename, int sinceVersion )
- if ( entityAddedVersion != 0 && sinceVersion != -1 && entityAddedVersion <= sinceVersion )
- {
- // skip the symbol, should already be present
-+ e = e.nextSiblingElement();
- continue;
- }
-