summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDoug Newgard2018-02-23 09:21:12 -0600
committerDoug Newgard2018-02-23 09:21:30 -0600
commit1f2565571b2c8ff0f99e8f03a2cb092af475db82 (patch)
tree7e88a629c09d768bb9ef64e9dae635f68edb4e11
parenta5112cd9cc557d38ec76201ddbbedb53794e3101 (diff)
downloadaur-1f2565571b2c8ff0f99e8f03a2cb092af475db82.tar.gz
Upstream update to 2.18.17
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD17
2 files changed, 16 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e4749a85268d..060aab9fb903 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = qgis-ltr
pkgdesc = Geographic Information System (GIS) that supports vector, raster & database formats; Long Term Release
- pkgver = 2.14.22
+ pkgver = 2.18.17
pkgrel = 1
url = https://qgis.org/
arch = i686
@@ -20,14 +20,15 @@ pkgbase = qgis-ltr
depends = proj
depends = qt4
depends = qca-qt4
+ depends = qjson
depends = qscintilla-qt4
- depends = qtwebkit
depends = qwt-qt4
depends = qwtpolar-qt4
depends = spatialindex
depends = sqlite
depends = python2
depends = python2-httplib2
+ depends = python2-future
depends = python2-qscintilla-qt4
depends = python2-sip
depends = python2-six
@@ -42,10 +43,10 @@ pkgbase = qgis-ltr
optdepends = python2-psycopg2: Processing plugin
optdepends = python2-pyspatialite: Processing plugin
optdepends = python2-yaml: Processing plugin
- provides = qgis=2.14.22
+ provides = qgis=2.18.17
conflicts = qgis
- source = https://qgis.org/downloads/qgis-2.14.22.tar.bz2
- md5sums = 72e609f334358f6a2cdc6defbf59e41d
+ source = https://qgis.org/downloads/qgis-2.18.17.tar.bz2
+ md5sums = d3b23c76a84a8d050aa5f5e58c762347
pkgname = qgis-ltr
diff --git a/PKGBUILD b/PKGBUILD
index 60409c4c0d3a..90a5c85786a8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -12,15 +12,15 @@
pkgname=qgis-ltr
_pkgname=${pkgname//-ltr}
-pkgver=2.14.22
+pkgver=2.18.17
pkgrel=1
pkgdesc='Geographic Information System (GIS) that supports vector, raster & database formats; Long Term Release'
url='https://qgis.org/'
license=('GPL')
arch=('i686' 'x86_64')
depends=('expat' 'gcc-libs' 'gdal' 'geos' 'glibc' 'libspatialite' 'postgresql-libs' 'proj'
- 'qt4' 'qca-qt4' 'qscintilla-qt4' 'qtwebkit' 'qwt-qt4' 'qwtpolar-qt4' 'spatialindex' 'sqlite'
- 'python2' 'python2-httplib2' 'python2-qscintilla-qt4' 'python2-sip' 'python2-six')
+ 'qt4' 'qca-qt4' 'qjson' 'qscintilla-qt4' 'qwt-qt4' 'qwtpolar-qt4' 'spatialindex' 'sqlite'
+ 'python2' 'python2-httplib2' 'python2-future' 'python2-qscintilla-qt4' 'python2-sip' 'python2-six')
makedepends=('cmake' 'gsl' 'perl' 'txt2tags')
optdepends=('gpsbabel: GPS Tool plugin'
'gsl: Georeferencer plugin'
@@ -36,7 +36,7 @@ optdepends=('gpsbabel: GPS Tool plugin'
provides=("$_pkgname=$pkgver")
conflicts=("$_pkgname")
source=("https://qgis.org/downloads/$_pkgname-$pkgver.tar.bz2")
-md5sums=('72e609f334358f6a2cdc6defbf59e41d')
+md5sums=('d3b23c76a84a8d050aa5f5e58c762347')
prepare() {
cd $_pkgname-$pkgver
@@ -47,7 +47,6 @@ prepare() {
# Fix references to "python"
sed -i 's/\(env \|\/usr\/bin\/\)python$/&2/' $(find . -iname "*.py")
- sed -i 's/python /python2 /' scripts/pyuic4-wrapper.sh
# Remove mime types already defined by freedesktop.org
sed -e '/type="image\/tiff"/,/<\/mime-type>/d' \
@@ -68,8 +67,9 @@ build() {
-DENABLE_TESTS=FALSE \
-DCMAKE_SKIP_RPATH=TRUE \
-DPYTHON_EXECUTABLE=/usr/bin/python2 \
+ -DWITH_QTWEBKIT=FALSE \
-DWITH_INTERNAL_QWTPOLAR=FALSE \
- -DWITH_INTERNAL_{HTTPLIB2,JINJA2,MARKUPSAFE,OWSLIB,PYGMENTS,DATEUTIL,PYTZ,YAML,NOSE2,SIX}=FALSE \
+ -DWITH_INTERNAL_{MARKUPSAFE,OWSLIB,DATEUTIL,PYTZ,YAML,NOSE2,SIX,FUTURE}=FALSE \
# -DWITH_SERVER=TRUE \
# -DWITH_GLOBE=TRUE
@@ -102,9 +102,12 @@ package() {
install -Dm644 images/icons/${prog}_icon.svg "$pkgdir/usr/share/icons/hicolor/scalable/apps/$prog.svg"
done
- # install mime information and icon
+ # install mime information and icons
install -Dm644 debian/qgis.xml "$pkgdir/usr/share/mime/packages/qgis.xml"
install -Dm644 images/icons/qgis-mime-icon.png "$pkgdir/usr/share/icons/hicolor/128x128/mimetypes/qgis-mime.png"
+ for type in asc ddf dem dt0 dxf gml img mime mldata qgs qlr qml qpt shp sqlite; do
+ install -Dm644 images/icons/qgis_${type}_icon.svg "$pkgdir/usr/share/icons/hicolor/scalable/mimetypes/qgis-$type.svg"
+ done
# compile python files, since the cmake option doesn't seem to account for DESTDIR
python2 -m compileall -q "$pkgdir"