summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStephan Springer2018-11-07 11:51:17 +0100
committerStephan Springer2018-11-07 11:51:17 +0100
commit2ea5851475e0878d6bf2e53ae2129f0cfe6b5b25 (patch)
treec8f62f0d23528d4adb4db10264f398358e5addcc
parent6d46bc0b843f78c2930e97522c722fed489ccd6b (diff)
downloadaur-2ea5851475e0878d6bf2e53ae2129f0cfe6b5b25.tar.gz
update description; fix quotes
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD10
2 files changed, 6 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 61489a45b33b..791e188fa2ac 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
pkgbase = qgis-ltr
- pkgdesc = Geographic Information System (GIS) that supports vector, raster & database formats; Long Term Release
+ pkgdesc = Geographic Information System (GIS); Old Long Term Release
pkgver = 2.18.25
pkgrel = 1
url = https://qgis.org/
diff --git a/PKGBUILD b/PKGBUILD
index 487c8fe3bea5..55a3dbfc9962 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -15,7 +15,7 @@ _pkgname=qgis
pkgname="$_pkgname"-ltr
pkgver=2.18.25
pkgrel=1
-pkgdesc='Geographic Information System (GIS) that supports vector, raster & database formats; Long Term Release'
+pkgdesc='Geographic Information System (GIS); Old Long Term Release'
url='https://qgis.org/'
license=('GPL')
arch=('i686' 'x86_64')
@@ -36,11 +36,11 @@ optdepends=('gpsbabel: GPS Tool plugin'
provides=("$_pkgname=$pkgver")
conflicts=("$_pkgname")
source=("https://qgis.org/downloads/$_pkgname-$pkgver.tar.bz2")
-# curl -s https://qgis.org/downloads/qgis-latest-ltr.tar.bz2.md5
+# curl https://qgis.org/downloads/qgis-latest-ltr.tar.bz2.md5
md5sums=('7b176867671981c45cbe859288ff9fb3')
prepare() {
- cd $_pkgname-$pkgver
+ cd "$_pkgname-$pkgver"
# Make sure we find the -qt4 versions of qwt and qwtpolar
sed -i '/QWT_LIBRARY_NAMES/ s/qwt /qwt-qt4 /' cmake/FindQwt.cmake
@@ -60,7 +60,7 @@ prepare() {
}
build() {
- cd $_pkgname-$pkgver/build
+ cd "$_pkgname-$pkgver"/build
cmake -G "Unix Makefiles" ../ \
-DCMAKE_INSTALL_PREFIX=/usr \
@@ -80,7 +80,7 @@ build() {
}
package() {
- cd $_pkgname-$pkgver/build
+ cd "$_pkgname-$pkgver"/build
# Add optional deps based on selected or autodetected options
[[ -n "$(sed -n '/^GRASS_PREFIX:/ s/.*=//p' CMakeCache.txt)" ]] && optdepends+=('grass6: GRASS6 plugin')