summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStephan Springer2020-07-26 17:58:48 +0200
committerStephan Springer2020-07-26 17:58:48 +0200
commitb25331b58c214e1b798a009ded695956d86c9971 (patch)
tree4f0d0bfb2f596f3aea8fb47f1e1dc022ccc9e985
parenta2059ea01acbd4543e81376859165fd57a7c8217 (diff)
downloadaur-b25331b58c214e1b798a009ded695956d86c9971.tar.gz
update to version 3.10.8 and build with Ninja
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD13
2 files changed, 11 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a389209ac2fb..4ca4d7bfd374 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,12 @@
pkgbase = qgis-ltr
pkgdesc = Geographic Information System (GIS); Long Term Release
- pkgver = 3.10.7
+ pkgver = 3.10.8
pkgrel = 1
url = https://qgis.org/
arch = x86_64
license = GPL
makedepends = cmake
+ makedepends = ninja
makedepends = fcgi
makedepends = gsl
makedepends = python-six
@@ -37,12 +38,12 @@ pkgbase = qgis-ltr
optdepends = python-pygments: MetaSearch plugin
optdepends = python-numpy: Processing plugin
optdepends = python-yaml: Processing plugin
- provides = qgis=3.10.7
+ provides = qgis=3.10.8
conflicts = qgis
- source = https://qgis.org/downloads/qgis-3.10.7.tar.bz2
+ source = https://qgis.org/downloads/qgis-3.10.8.tar.bz2
source = qgis-pyqt5-sip5.patch
source = t2t-toc-level.patch
- sha256sums = f6c02489e065bae355d2f4374b84a1624379634c34a770b6d65bf38eb7e71564
+ sha256sums = b37ccc6228610301232c50fdd9660fdd878c9f822dfe60cd949b94391e19d94c
sha256sums = 47fdab75c94ecf5b61a41b334e23714226e895cef507c35a3bc4b46c7d307981
sha256sums = f7e91914cfe366a63383b39c63d5731f6f20a1a0a0d7e9f3d16809a40bb5acff
diff --git a/PKGBUILD b/PKGBUILD
index a3dc64ff167c..c83ef4c85864 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,7 +9,7 @@
_pkgname=qgis
pkgname="$_pkgname"-ltr
-pkgver=3.10.7
+pkgver=3.10.8
pkgrel=1
pkgdesc='Geographic Information System (GIS); Long Term Release'
url='https://qgis.org/'
@@ -17,7 +17,7 @@ license=(GPL)
arch=(x86_64)
depends=(desktop-file-utils exiv2 gdal hicolor-icon-theme libzip python-qscintilla-qt5 qca qt5-3d
qt5-serialport qt5-webkit qtkeychain qwtpolar spatialindex python-sip)
-makedepends=(cmake fcgi gsl python-six qt5-tools txt2tags sip python-setuptools)
+makedepends=(cmake ninja fcgi gsl python-six qt5-tools txt2tags sip python-setuptools)
optdepends=('fcgi: Map server'
'gpsbabel: GPS Tools plugin'
'gsl: Georeferencer plugin'
@@ -35,7 +35,7 @@ source=("https://qgis.org/downloads/$_pkgname-$pkgver.tar.bz2"
t2t-toc-level.patch
)
# curl https://qgis.org/downloads/qgis-latest-ltr.tar.bz2.sha256
-sha256sums=('f6c02489e065bae355d2f4374b84a1624379634c34a770b6d65bf38eb7e71564'
+sha256sums=('b37ccc6228610301232c50fdd9660fdd878c9f822dfe60cd949b94391e19d94c'
'47fdab75c94ecf5b61a41b334e23714226e895cef507c35a3bc4b46c7d307981'
'f7e91914cfe366a63383b39c63d5731f6f20a1a0a0d7e9f3d16809a40bb5acff')
@@ -48,7 +48,7 @@ prepare() {
build() {
cd build
- cmake -G "Unix Makefiles" ../"$_pkgname-$pkgver" \
+ cmake -G Ninja ../"$_pkgname-$pkgver" \
-DCMAKE_INSTALL_PREFIX=/usr \
-DWITH_3D=TRUE \
-DWITH_SERVER=TRUE \
@@ -57,10 +57,9 @@ build() {
-DQGIS_MANUAL_SUBDIR=share/man \
-DWITH_QWTPOLAR=TRUE \
-DWITH_INTERNAL_QWTPOLAR=FALSE
- make
+ cmake --build .
}
package() {
- cd build
- make DESTDIR="$pkgdir" install
+ DESTDIR="$pkgdir" cmake --build build --target install
}