summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorspider-mario2023-11-07 11:26:45 +0100
committerspider-mario2023-11-07 11:28:50 +0100
commit0c503e4f8589a56ced5515c6ea623c2fa1c3232a (patch)
tree24a6db6bf6a462d078a5e552be93be1cf97ca7fe
parent64b88280d1a5948065b1850faa36c3653f0a8a38 (diff)
downloadaur-qgnomeplatform-git.tar.gz
Add missing dependency and make qt5 and qt6 variants compatible
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD24
2 files changed, 32 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0f0af31cfa2e..43ca4119c9ec 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = qgnomeplatform-git
pkgdesc = QPlatformTheme for a better Qt application inclusion in GNOME
- pkgver = 0.7.0.r78.g6505fb8
+ pkgver = 0.7.0.r99.gd86d6ba
pkgrel = 1
url = https://github.com/FedoraQt/QGnomePlatform
arch = x86_64
@@ -12,6 +12,7 @@ pkgbase = qgnomeplatform-git
makedepends = qt6-wayland
makedepends = adwaita-qt5
makedepends = adwaita-qt6
+ options = !emptydirs
source = git+https://github.com/FedoraQt/QGnomePlatform.git
sha256sums = SKIP
@@ -19,7 +20,9 @@ pkgname = qgnomeplatform-qt5-git
pkgdesc = QPlatformTheme for a better Qt5 application inclusion in GNOME
depends = gtk3
depends = qt5-wayland
+ depends = qt5-quickcontrols2
depends = adwaita-qt5
+ depends = qgnomeplatform-common-git
provides = qgnomeplatform-qt5
conflicts = qgnomeplatform-qt5
replaces = qgnomeplatform
@@ -30,5 +33,13 @@ pkgname = qgnomeplatform-qt6-git
depends = gtk3
depends = qt6-wayland
depends = adwaita-qt6
+ depends = qgnomeplatform-common-git
provides = qgnomeplatform-qt6
conflicts = qgnomeplatform-qt6
+
+pkgname = qgnomeplatform-common-git
+ pkgdesc = QPlatformTheme for a better Qt application inclusion in GNOME (common files)
+ arch = any
+ depends =
+ provides = qgnomeplatform-common
+ conflicts = qgnomeplatform-common
diff --git a/PKGBUILD b/PKGBUILD
index 45dbbfa9a96e..a7ffb1155fd6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,14 +7,15 @@
pkgbase=qgnomeplatform-git
_pkgname=QGnomePlatform
-pkgname=(qgnomeplatform-qt5-git qgnomeplatform-qt6-git)
-pkgver=0.7.0.r78.g6505fb8
+pkgname=(qgnomeplatform-qt5-git qgnomeplatform-qt6-git qgnomeplatform-common-git)
+pkgver=0.7.0.r99.gd86d6ba
pkgrel=1
pkgdesc='QPlatformTheme for a better Qt application inclusion in GNOME'
arch=(x86_64)
url='https://github.com/FedoraQt/QGnomePlatform'
license=(LGPL2.1)
makedepends=(cmake git gtk3 qt5-wayland qt6-wayland adwaita-qt5 adwaita-qt6)
+options=('!emptydirs')
source=(git+https://github.com/FedoraQt/$_pkgname.git)
sha256sums=('SKIP')
@@ -35,21 +36,36 @@ build() {
cmake --build build-qt6
}
+package_qgnomeplatform-common-git() {
+ pkgdesc='QPlatformTheme for a better Qt application inclusion in GNOME (common files)'
+ arch=(any)
+ depends=()
+ provides=(qgnomeplatform-common)
+ conflicts=(qgnomeplatform-common)
+
+ DESTDIR="destdir-common" cmake --install build-qt6
+ for f in destdir-common/usr/share/color-schemes/*; do
+ install -Dm644 "$f" "$pkgdir/usr/share/color-schemes/$f"
+ done
+}
+
package_qgnomeplatform-qt5-git() {
pkgdesc='QPlatformTheme for a better Qt5 application inclusion in GNOME'
- depends=(gtk3 qt5-wayland adwaita-qt5)
+ depends=(gtk3 qt5-wayland qt5-quickcontrols2 adwaita-qt5 qgnomeplatform-common-git)
replaces=(qgnomeplatform qgnomeplatform-git)
provides=(qgnomeplatform-qt5)
conflicts=(qgnomeplatform-qt5)
DESTDIR="$pkgdir" cmake --install build-qt5
+ rm "$pkgdir"/usr/share/color-schemes/*
}
package_qgnomeplatform-qt6-git() {
pkgdesc='QPlatformTheme for a better Qt6 application inclusion in GNOME'
- depends=(gtk3 qt6-wayland adwaita-qt6)
+ depends=(gtk3 qt6-wayland adwaita-qt6 qgnomeplatform-common-git)
provides=(qgnomeplatform-qt6)
conflicts=(qgnomeplatform-qt6)
DESTDIR="$pkgdir" cmake --install build-qt6
+ rm "$pkgdir"/usr/share/color-schemes/*
}