summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorspider-mario2016-02-02 23:31:00 +0100
committerspider-mario2016-02-03 23:29:09 +0100
commitcfb1ceed2b193b9e340e1f8d1756f92f0c98781c (patch)
tree5d272ce6ed7c7c4fe2cb5d7bfc72053730b0f631
downloadaur-cfb1ceed2b193b9e340e1f8d1756f92f0c98781c.tar.gz
First version
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD36
2 files changed, 55 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5e8ce7885f19
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+# Generated by mksrcinfo v8
+# Wed Feb 3 22:29:02 UTC 2016
+pkgbase = qgnomeplatform-git
+ pkgdesc = Qt Platform Theme aimed to accomodate as much of GNOME settings as possible
+ pkgver = 0.0.5
+ pkgrel = 1
+ url = https://github.com/MartinBriza/QGnomePlatform
+ arch = i686
+ arch = x86_64
+ license = LGPL2.1
+ makedepends = git
+ depends = qt5-base
+ provides = qgnomeplatform
+ conflicts = qgnomeplatform
+ source = git+https://github.com/MartinBriza/QGnomePlatform.git
+ md5sums = SKIP
+
+pkgname = qgnomeplatform-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4dd46894bb02
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: spider-mario <spidermario@free.fr>
+pkgname=qgnomeplatform-git
+pkgver=0.0.5
+pkgrel=1
+pkgdesc="Qt Platform Theme aimed to accomodate as much of GNOME settings as possible"
+arch=('i686' 'x86_64')
+url="https://github.com/MartinBriza/QGnomePlatform"
+license=('LGPL2.1')
+depends=('qt5-base')
+makedepends=('git')
+provides=('qgnomeplatform')
+conflicts=('qgnomeplatform')
+source=('git+https://github.com/MartinBriza/QGnomePlatform.git')
+md5sums=('SKIP')
+
+pkgver() {
+ cd QGnomePlatform
+ echo -n "0.0."
+ git rev-list --count master
+}
+
+build() {
+ cd QGnomePlatform
+ qmake-qt5
+ make
+}
+
+check() {
+ cd QGnomePlatform
+ make -k check
+}
+
+package() {
+ cd QGnomePlatform
+ make INSTALL_ROOT="$pkgdir/" install
+}