summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKye Morton2018-09-28 23:50:34 +1000
committerKye Morton2018-09-28 23:50:34 +1000
commitbc42b59a5214e7e09df1b490147523c37e17802f (patch)
tree2b8d06b7c791dcb9d0093bad62b8e3cb0c20bfe0
parent95c96859662fa8bef33429266f1313122dcfc2d5 (diff)
downloadaur-bc42b59a5214e7e09df1b490147523c37e17802f.tar.gz
Updated to 3.4.4 and switched depends to better reflect .so links
-rw-r--r--.SRCINFO37
-rw-r--r--PKGBUILD33
2 files changed, 53 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index feb956c78ca..dbd4a0372f8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,35 @@
pkgbase = qgroundcontrol
pkgdesc = Ground control for unmanned vehicles.
- pkgver = 3.4.1
- pkgrel = 2
+ pkgver = 3.4.4
+ pkgrel = 1
url = http://qgroundcontrol.org/
arch = any
license = GPL3
- depends = espeak
- depends = qt5-svg
- depends = qt5-graphicaleffects
- depends = qt5-webkit
- depends = qt5-serialport
- depends = qt5-quickcontrols
- source = qgroundcontrol-3.4.1-2::https://github.com/mavlink/qgroundcontrol/releases/download/v3.4.1/qgroundcontrol.tar.bz2
- sha256sums = 24d56ec916943c94439bbb55e74af72e352d21f174973ea78c07879a8750284f
+ depends = bzip2
+ depends = dbus
+ depends = flac
+ depends = gst-plugins-base-libs
+ depends = libasyncns
+ depends = libffi
+ depends = libgcrypt
+ depends = libgpg-error
+ depends = libogg
+ depends = libsndfile
+ depends = libsystemd
+ depends = libunwind
+ depends = libx11
+ depends = libxau
+ depends = libxcb
+ depends = libxdmcp
+ depends = libxext
+ depends = lz4
+ depends = orc
+ depends = pcre
+ depends = sdl2
+ depends = xz
+ depends = zlib
+ source = qgroundcontrol-3.4.4-1::https://github.com/mavlink/qgroundcontrol/releases/download/v3.4.4/qgroundcontrol.tar.bz2
+ sha256sums = 7eca7d9bf921dea381728f2914d260b926b5807df5e0d463c25beb7f92acbfc3
pkgname = qgroundcontrol
diff --git a/PKGBUILD b/PKGBUILD
index 82330592854..12e2f034668 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,18 +1,37 @@
# Maintainer: Kye Morton <pryre.dev@outlook.com>
pkgname=qgroundcontrol
-pkgver=3.4.1
-pkgrel=2
+pkgver=3.4.4
+pkgrel=1
pkgdesc="Ground control for unmanned vehicles."
arch=('any')
url="http://qgroundcontrol.org/"
license=('GPL3')
-depends=(\
- 'espeak' # optional but you have to decide if you want it at built-time\
- 'qt5-svg' 'qt5-graphicaleffects' 'qt5-webkit' 'qt5-serialport'\
- 'qt5-quickcontrols')
+depends=( 'bzip2' \
+ 'dbus' \
+ 'flac' \
+ 'gst-plugins-base-libs' \
+ 'libasyncns' \
+ 'libffi' \
+ 'libgcrypt' \
+ 'libgpg-error' \
+ 'libogg' \
+ 'libsndfile' \
+ 'libsystemd' \
+ 'libunwind' \
+ 'libx11' \
+ 'libxau' \
+ 'libxcb' \
+ 'libxdmcp' \
+ 'libxext' \
+ 'lz4' \
+ 'orc' \
+ 'pcre' \
+ 'sdl2' \
+ 'xz' \
+ 'zlib')
source=('qgroundcontrol-'${pkgver}'-'${pkgrel}'::https://github.com/mavlink/qgroundcontrol/releases/download/v'${pkgver}'/qgroundcontrol.tar.bz2')
-sha256sums=('24d56ec916943c94439bbb55e74af72e352d21f174973ea78c07879a8750284f')
+sha256sums=('7eca7d9bf921dea381728f2914d260b926b5807df5e0d463c25beb7f92acbfc3')
build() {
echo "[Desktop Entry]