summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoracxz2023-12-16 22:24:30 -0600
committeracxz2023-12-16 22:24:30 -0600
commite94bda32f9d90fb4ff70256bca134eaaacb5249b (patch)
tree944e872e765c52b507146e56924bc22546338ebe
parent6813725585092d781b372f2778bbfa1a20bd226e (diff)
downloadaur-e94bda32f9d90fb4ff70256bca134eaaacb5249b.tar.gz
upgpkg: qgroundcontrol 4.3.0-1
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD11
2 files changed, 17 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f8a225dfe118..a106b6ed2b1e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = qgroundcontrol
pkgdesc = Micro air vehicle ground control station.
- pkgver = 4.2.9
+ pkgver = 4.3.0
pkgrel = 1
url = https://github.com/mavlink/qgroundcontrol
arch = x86_64
@@ -44,15 +44,20 @@ pkgbase = qgroundcontrol
depends = qt5-tools
depends = qt5-wayland
depends = qt5-x11extras
- source = qgroundcontrol-4.2.9::git+https://github.com/mavlink/qgroundcontrol.git#tag=v4.2.9
+ depends = speech-dispatcher
+ source = qgroundcontrol-4.3.0::git+https://github.com/mavlink/qgroundcontrol.git#tag=v4.3.0
source = qgroundcontrol-GpsDrivers::git+https://github.com/PX4/GpsDrivers.git
source = qgroundcontrol-c_library_v2::git+https://github.com/mavlink/c_library_v2.git
- source = qgroundcontrol-android_openssl::git+https://github.com/Auterion/android_openssl.git
+ source = qgroundcontrol-android_openssl::git+https://github.com/KDAB/android_openssl.git
source = qgroundcontrol-gst-plugins-good::git+https://github.com/mavlink/gst-plugins-good.git
source = qgroundcontrol-xz-embedded::git+https://github.com/Auterion/xz-embedded.git
source = qgroundcontrol-libevents::git+https://github.com/mavlink/libevents.git
source = qgroundcontrol-eigen::git+https://gitlab.com/libeigen/eigen.git
source = qgroundcontrol-qmdnsengine::git+https://github.com/patrickelectric/qmdnsengine.git
+ source = qgroundcontrol-shapelib::git+https://github.com/OSGeo/shapelib.git
+ source = qgroundcontrol-ArduPilot-Parameter-Repository::git+https://github.com/ArduPilot/ArduPilot-Parameter-Repository.git
+ sha256sums = SKIP
+ sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 7d6b8047174d..98938fe7ab8e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: K. Morton <pryre.dev@outlook.com>
# Contributor: Anselmo L. S. Melo <anselmo.melo@intel.com>
pkgname=qgroundcontrol
-pkgver=4.2.9
+pkgver=4.3.0
pkgrel=1
pkgdesc="Micro air vehicle ground control station."
arch=('x86_64')
@@ -45,6 +45,7 @@ depends=('bzip2'
'qt5-tools'
'qt5-wayland'
'qt5-x11extras'
+ 'speech-dispatcher'
)
makedepends=('git' 'qt5-base' 'patchelf')
@@ -52,12 +53,14 @@ makedepends=('git' 'qt5-base' 'patchelf')
source=("${pkgname}-${pkgver}::git+https://github.com/mavlink/qgroundcontrol.git#tag=v${pkgver}"
"${pkgname}-GpsDrivers::git+https://github.com/PX4/GpsDrivers.git"
"${pkgname}-c_library_v2::git+https://github.com/mavlink/c_library_v2.git"
- "${pkgname}-android_openssl::git+https://github.com/Auterion/android_openssl.git"
+ "${pkgname}-android_openssl::git+https://github.com/KDAB/android_openssl.git"
"${pkgname}-gst-plugins-good::git+https://github.com/mavlink/gst-plugins-good.git"
"${pkgname}-xz-embedded::git+https://github.com/Auterion/xz-embedded.git"
"${pkgname}-libevents::git+https://github.com/mavlink/libevents.git"
"${pkgname}-eigen::git+https://gitlab.com/libeigen/eigen.git"
"${pkgname}-qmdnsengine::git+https://github.com/patrickelectric/qmdnsengine.git"
+ "${pkgname}-shapelib::git+https://github.com/OSGeo/shapelib.git"
+ "${pkgname}-ArduPilot-Parameter-Repository::git+https://github.com/ArduPilot/ArduPilot-Parameter-Repository.git"
)
sha256sums=('SKIP'
@@ -69,6 +72,8 @@ sha256sums=('SKIP'
'SKIP'
'SKIP'
'SKIP'
+ 'SKIP'
+ 'SKIP'
)
prepare() {
@@ -84,6 +89,8 @@ prepare() {
git config submodule."libs/libevents/libevents".url "${srcdir}/${pkgname}"-libevents
git config submodule."libs/eigen".url "${srcdir}/${pkgname}"-eigen
git config submodule."libs/qmdnsengine".url "${srcdir}/${pkgname}"-qmdnsengine
+ git config submodule."libs/shapelib".url "${srcdir}/${pkgname}"-shapelib
+ git config submodule."src/FirmwarePlugin/APM/ArduPilot-Parameter-Repository".url "${srcdir}/${pkgname}"-ArduPilot-Parameter-Repository
git -c protocol.file.allow=always submodule update --init --recursive
}