summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAnselmo L. S. Melo2016-02-14 22:15:45 -0200
committerAnselmo L. S. Melo2016-02-14 22:16:55 -0200
commit0686ce181eb677da94b920c7b72acc8436c5ac0b (patch)
tree57939838867da73cd3d67f1fce19ee2361fe1171
parent378e4273df11cb5fa74e40e293234fca7fe6973d (diff)
downloadaur-0686ce181eb677da94b920c7b72acc8436c5ac0b.tar.gz
Out-of-source build
QGroundControl now requires a shadow build, this patch updates the PKGBUILD to handle that.
-rw-r--r--PKGBUILD7
1 files changed, 4 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 76c814e90052..4cfbfb96d75e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Milan Oberkirch <aur@oberkirch.org>
pkgname=qgroundcontrol-git
pkgver=2.5.0
-pkgrel=1
+pkgrel=2
pkgdesc="Micro air vehicle ground control station."
arch=('any')
url="http://qgroundcontrol.org/"
@@ -38,13 +38,14 @@ build() {
cd "$srcdir/$_gitname-build"
git submodule init && git submodule update
- qmake qgroundcontrol.pro
+ mkdir build && cd build
+ qmake ../qgroundcontrol.pro
make
}
package() {
mkdir -p "${pkgdir}/opt" "${pkgdir}/usr/bin"
- cp -R "$srcdir/$_gitname-build/release" "${pkgdir}/opt/qgroundcontrol"
+ cp -R "$srcdir/$_gitname-build/build/release" "${pkgdir}/opt/qgroundcontrol"
cat <<EndOfFile > "${pkgdir}/usr/bin/qgroundcontrol"
#!/bin/bash
cd /opt/qgroundcontrol/