summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichal Krenek (Mikos)2015-06-22 14:16:49 +0200
committerMichal Krenek (Mikos)2015-06-22 14:16:49 +0200
commit9983e22c93ba62e7c4461c4d68df295d8ac2b76d (patch)
treeb84b4eec518014d930ece39465afae43d5e213e9
downloadaur-9983e22c93ba62e7c4461c4d68df295d8ac2b76d.tar.gz
Initial import
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD25
2 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..fd772a2bafac
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = qhangups
+ pkgdesc = Alternative client for Google Hangouts written in PyQt
+ pkgver = 1.6.0
+ pkgrel = 1
+ url = https://github.com/xmikos/qhangups
+ arch = any
+ license = GPL3
+ makedepends = python-setuptools
+ depends = hangups-git
+ depends = python-quamash
+ depends = python-pyqt4
+ depends = python-appdirs
+ source = https://github.com/xmikos/qhangups/archive/v1.6.0.tar.gz
+ md5sums = fe96c8a8ae206fcb0668ebe5b22417db
+
+pkgname = qhangups
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..10f004d6d44e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Michal Krenek (Mikos) <m.krenek@gmail.com>
+pkgname=qhangups
+pkgver=1.6.0
+pkgrel=1
+pkgdesc="Alternative client for Google Hangouts written in PyQt"
+arch=('any')
+url="https://github.com/xmikos/qhangups"
+license=('GPL3')
+depends=('hangups-git' 'python-quamash' 'python-pyqt4' 'python-appdirs')
+makedepends=('python-setuptools')
+source=(https://github.com/xmikos/qhangups/archive/v$pkgver.tar.gz)
+md5sums=('fe96c8a8ae206fcb0668ebe5b22417db')
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ python setup.py build
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ sed -i 's/^.*asyncio.*$//' setup.py
+ python setup.py install --root="$pkgdir"
+}
+
+# vim:set ts=2 sw=2 et: