summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPatrick José Pereira2019-12-09 16:57:35 -0300
committerPatrick José Pereira2019-12-09 16:57:35 -0300
commit4a9cee4381736786145f3655b9490e5d87b9a018 (patch)
tree10b6fb7507466a22275b64cf67888a4952092d16
downloadaur-4a9cee4381736786145f3655b9490e5d87b9a018.tar.gz
First commit
Signed-off-by: Patrick José Pereira <patrickelectric@gmail.com>
-rw-r--r--.SRCINFO29
-rw-r--r--PKGBUILD65
2 files changed, 94 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..eab5d3a28432
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,29 @@
+pkgbase = qhot-git
+ pkgdesc = Hot reload for nested QML files!
+ pkgver = 9a37bf6
+ pkgrel = 1
+ url = https://github.com/patrickelectric/qhot
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ depends = qt5-base
+ depends = qt5-declarative
+ depends = qt5-3d
+ depends = qt5-charts
+ depends = qt5-graphicaleffects
+ depends = qt5-imageformats
+ depends = qt5-location
+ depends = qt5-multimedia
+ depends = qt5-quickcontrols
+ depends = qt5-quickcontrols2
+ depends = qt5-svg
+ depends = qt5-tools
+ depends = qt5-translations
+ depends = qt5-webengine
+ depends = qt5-websockets
+ depends = qt5-webglplugin
+ source = git://github.com/patrickelectric/qhot.git
+ md5sums = SKIP
+
+pkgname = qhot-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..775c7bca8d7a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,65 @@
+# Maintainer: Patrick josé Pereira <gmail.com@patrickelectric>
+pkgname=qhot-git
+_realname=qhot
+confilicts=('qhot')
+pkgver=9a37bf6
+pkgrel=1
+pkgdesc="Hot reload for nested QML files!"
+arch=('i686' 'x86_64')
+url="https://github.com/patrickelectric/qhot"
+license=('GPL3')
+buildDepends=('git')
+depends=(
+ 'qt5-base'
+ 'qt5-declarative'
+ 'qt5-3d'
+ 'qt5-charts'
+ 'qt5-graphicaleffects'
+ 'qt5-imageformats'
+ 'qt5-location'
+ 'qt5-multimedia'
+ 'qt5-quickcontrols'
+ 'qt5-quickcontrols2'
+ 'qt5-svg'
+ 'qt5-tools'
+ 'qt5-translations'
+ 'qt5-webengine'
+ 'qt5-websockets'
+ 'qt5-webglplugin'
+)
+source=('git://github.com/patrickelectric/qhot.git')
+md5sums=(SKIP)
+
+pkgver() {
+ cd $_realname
+ git log --pretty=format:'%h' -n 1
+}
+
+build() {
+ cd $_realname
+ mkdir "build" || true
+ cd "build"
+ qmake ..
+ make PREFIX=/usr
+
+ echo "[Desktop Entry]
+Type=Application
+Name=QHot
+Comment=${pkgdesc}
+Path=/opt/${pkgname}/
+Exec=/usr/bin/$_realname
+Terminal=true
+Categories=Qt;Utility;" > "$_realname.desktop"
+}
+
+package(){
+ cd $_realname
+ cd "build"
+
+
+ mkdir -p "${pkgdir}/opt/" "${pkgdir}/usr/bin" "${pkgdir}/usr/share/applications"
+ cp $_realname "${pkgdir}/usr/bin/$_realname"
+ cp "$_realname.desktop" "${pkgdir}/opt/${pkgname}"
+
+ ln -s "/opt/${pkgname}/${pkgname}.desktop" "${pkgdir}/usr/share/applications/${pkgname}.desktop"
+}