summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMagnus Boman2022-02-11 20:03:06 +0100
committerMagnus Boman2022-02-11 20:03:06 +0100
commite10aa44e20382f546cec54b7cc7f512a80dc561d (patch)
tree511c33b84562f58009ed6af88e2305be04a76168
parent649321dd5bcd8eccb1ed7a8fc7265c7e6ae99aad (diff)
downloadaur-e10aa44e20382f546cec54b7cc7f512a80dc561d.tar.gz
upgpkg: qimgv-light 1.0.2-2
Add patch for qt6.3
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD12
2 files changed, 12 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 591b64e12b27..e53e1e5d1035 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = qimgv-light
pkgdesc = Qt6 image viewer (without any optional features)
pkgver = 1.0.2
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/easymodo/qimgv
arch = x86_64
arch = i686
@@ -20,6 +20,8 @@ pkgbase = qimgv-light
provides = qimgv
conflicts = qimgv
source = qimgv-1.0.2.tar.gz::https://github.com/easymodo/qimgv/archive/refs/tags/v1.0.2.tar.gz
+ source = https://github.com/easymodo/qimgv/commit/b8d3a5f56af71a928465223ac0d99085b029c59d.patch
sha256sums = ace75077c5b6f3cb2b0d40b24482b3778728d98dce75ed8186c7ae4282e57634
+ sha256sums = e8bba9dd1e0b62298ce4831a2ebfa6a63cf6784877e853ece78255af7b42c653
pkgname = qimgv-light
diff --git a/PKGBUILD b/PKGBUILD
index 15db204a5f47..01e3d248cd3c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=qimgv-light
pkgver=1.0.2
-pkgrel=1
+pkgrel=2
pkgdesc='Qt6 image viewer (without any optional features)'
arch=(x86_64 i686 armv6h armv7h aarch64)
url=https://github.com/easymodo/qimgv
@@ -14,8 +14,14 @@ provides=("${pkgname%-light}")
conflicts=("${pkgname%-light}")
optdepends=('kimageformats: support for more image formats'
'qtraw: raw images support')
-source=("${pkgname%-light}"-"${pkgver}".tar.gz::"${url}"/archive/refs/tags/v"${pkgver}".tar.gz)
-sha256sums=('ace75077c5b6f3cb2b0d40b24482b3778728d98dce75ed8186c7ae4282e57634')
+source=("${pkgname%-light}"-"${pkgver}".tar.gz::"${url}"/archive/refs/tags/v"${pkgver}".tar.gz
+ https://github.com/easymodo/qimgv/commit/b8d3a5f56af71a928465223ac0d99085b029c59d.patch)
+sha256sums=('ace75077c5b6f3cb2b0d40b24482b3778728d98dce75ed8186c7ae4282e57634'
+ 'e8bba9dd1e0b62298ce4831a2ebfa6a63cf6784877e853ece78255af7b42c653')
+
+prepare() {
+ patch --directory="${pkgname%-light}"-"${pkgver}" --forward --strip=1 --input="${srcdir}/b8d3a5f56af71a928465223ac0d99085b029c59d.patch"
+}
build() {
cmake -B build -S "${pkgname%-light}"-"${pkgver}" \