summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMagnus Boman2021-08-08 01:13:46 +0200
committerMagnus Boman2021-08-08 01:13:46 +0200
commitb9dda1ad1f0fe40c0cff4809ce16eb567f819064 (patch)
tree140774f7ec50730c993d2ea811d16b5fa186bf0a
downloadaur-b9dda1ad1f0fe40c0cff4809ce16eb567f819064.tar.gz
Initial upload: qimgv-light-git 0.9.2.alpha2.r73.gdee226f6-1
-rw-r--r--.SRCINFO26
-rw-r--r--PKGBUILD37
2 files changed, 63 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6445882b569e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,26 @@
+pkgbase = qimgv-light-git
+ pkgdesc = Qt6 image viewer (git, without any optional features)
+ pkgver = 0.9.2.alpha2.r73.gdee226f6
+ pkgrel = 1
+ url = https://github.com/easymodo/qimgv
+ arch = x86_64
+ arch = i686
+ arch = armv6h
+ arch = armv7h
+ arch = aarch64
+ license = GPL3
+ makedepends = cmake
+ makedepends = qt6-tools
+ makedepends = git
+ depends = qt6-base
+ depends = qt6-imageformats
+ depends = qt6-svg
+ depends = qt6-5compat
+ optdepends = kimageformats: support for more image formats
+ optdepends = qtraw: raw images support
+ provides = qimgv
+ conflicts = qimgv
+ source = git+https://github.com/easymodo/qimgv.git
+ sha256sums = SKIP
+
+pkgname = qimgv-light-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6cc8e87081ed
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: katt <magunasu.b97@gmail.com>
+
+pkgname=qimgv-light-git
+pkgver=0.9.2.alpha2.r73.gdee226f6
+pkgrel=1
+pkgdesc='Qt6 image viewer (git, without any optional features)'
+arch=(x86_64 i686 armv6h armv7h aarch64)
+url=https://github.com/easymodo/qimgv
+license=(GPL3)
+depends=(qt6-base qt6-imageformats qt6-svg qt6-5compat)
+makedepends=(cmake qt6-tools git)
+provides=("${pkgname%-light-git}")
+conflicts=("${pkgname%-light-git}")
+optdepends=('kimageformats: support for more image formats'
+ 'qtraw: raw images support')
+source=(git+"${url}".git)
+sha256sums=('SKIP')
+
+pkgver() {
+ git -C "${pkgname%-light-git}" describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cmake -B build -S "${pkgname%-light-git}" \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=lib \
+ -DEXIV2=OFF \
+ -DVIDEO_SUPPORT=OFF \
+ -DOPENCV_SUPPORT=OFF \
+ -Wno-dev
+ cmake --build build
+}
+
+package() {
+ DESTDIR="$pkgdir" cmake --install build
+}