summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorel-wumbus2022-10-21 16:39:02 -0400
committerel-wumbus2022-10-21 16:39:02 -0400
commit6baf43b3fcbafc643e3e5f7a72dc24cf2f04809b (patch)
tree5e712e5ece632464af9eda457e1d94c606f7f468
parent02495f29a668f2803f3d2037076df491023512e9 (diff)
downloadaur-6baf43b3fcbafc643e3e5f7a72dc24cf2f04809b.tar.gz
update build steps
-rw-r--r--PKGBUILD16
1 files changed, 11 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ae3d093b14dd..df29d509ea04 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,15 +1,15 @@
# Maintainer: Aidan Neal <decator(dot)c(at)proton(dot)me>
pkgname="qinfo-git"
_pkgname="qinfo"
-pkgver=r70.rb3f292d.
+pkgver=r97.rc3c6e44.
pkgrel=1
pkgdesc="A system info program. Fetches system info and displays it."
arch=("x86_64")
url="https://github.com/El-Wumbus/qinfo"
license=("LGPL3")
provides=("qinfo")
-makedepends=("gcc" "make" "git")
-depends=("coreutils")
+makedepends=("meson" "ninja")
+depends=()
optdepends=("snapd: List number of snap packages"
"flatpak: List number of flatpak packages")
source=($_pkgname::"git+https://github.com/El-Wumbus/qinfo.git")
@@ -20,7 +20,13 @@ pkgver() {
printf "r%s.$s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
+build() {
+ cd "$_pkgname"
+ mkdir -p build
+ meson setup build
+ meson compile -C build
+}
package() {
cd "$_pkgname"
- make DESTDIR="${pkgdir}" install
-} \ No newline at end of file
+ install build/qinfo -Dm755 ${pkgdir}/usr/bin/qinfo
+}