summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLukas Sabota2015-12-16 00:48:01 -0500
committerLukas Sabota2015-12-16 00:48:01 -0500
commit708454190178a2835dc749e90554a8123812fe27 (patch)
tree2a9ecd4fa9a1945b9f68bc5011356eb3b370c59e
downloadaur-708454190178a2835dc749e90554a8123812fe27.tar.gz
initial commit
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD44
-rw-r--r--qjoypad.desktop13
-rw-r--r--qjoypad.install12
-rw-r--r--x11.patch11
5 files changed, 102 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f0804803ec12
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+# Generated by mksrcinfo v8
+# Wed Dec 16 05:47:28 UTC 2015
+pkgbase = qjoypad
+ pkgdesc = Program with a QT interface that converts gamepad/joystick events into key strokes and mouse actions in XWindows
+ pkgver = 4.1.0
+ pkgrel = 4
+ url = http://qjoypad.sourceforge.net/
+ install = qjoypad.install
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = qt4
+ depends = libxtst
+ source = http://downloads.sourceforge.net/qjoypad/qjoypad-4.1.0.tar.gz
+ source = qjoypad.desktop
+ source = x11.patch
+ md5sums = d4a262c29bd3955c0fe51e9a0d31f619
+ md5sums = a90839531415df510410558c47076cfc
+ md5sums = f6e8a44d0a4b53c7f28e6b98beb265de
+
+pkgname = qjoypad
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..be5807f7cd54
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+# Maintainer: Lukas Sabota <lukas@lwsabota.com>
+# Contributor: Fabian Schoelzel <myfirstname.mylastname@googlemail.com>
+# Contributor: mightyjaym <jm.ambrosino@free.fr>
+# Contributor: Travis Nickles <ryoohki7@yahoo.com>
+
+pkgname=qjoypad
+pkgver=4.1.0
+pkgrel=5
+pkgdesc='Program with a QT interface that converts gamepad/joystick events into key strokes and mouse actions in XWindows'
+arch=('i686' 'x86_64')
+url='http://qjoypad.sourceforge.net/'
+license=('GPL')
+depends=('qt4' 'libxtst')
+install=${pkgname}.install
+
+source=("http://downloads.sourceforge.net/$pkgname/$pkgname-$pkgver.tar.gz"
+ 'qjoypad.desktop'
+ 'x11.patch')
+
+md5sums=('d4a262c29bd3955c0fe51e9a0d31f619'
+ 'a90839531415df510410558c47076cfc'
+ 'f6e8a44d0a4b53c7f28e6b98beb265de')
+
+prepare() {
+ cd "${srcdir}/${pkgname}-${pkgver}/src"
+ patch -p3 <../../x11.patch
+ sed -i 's/ qmake / qmake-qt4 /' config
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}/src"
+
+ ./config --prefix=/usr --install-dir=$pkgdir --devdir=/dev/input --debug --qmake4bin=/usr/lib/qt4/bin/qmake
+ make
+
+ make DESTDIR="$pkgdir/" install
+
+ install -d "${pkgdir}/usr/share/applications/"
+ install -d "${pkgdir}/usr/share/icons/hicolor/24x24/apps/"
+ install -d "${pkgdir}/usr/share/icons/hicolor/64x64/apps/"
+ install -m644 "${srcdir}/qjoypad.desktop" "${pkgdir}/usr/share/applications/"
+ install -m644 "${srcdir}/$pkgname-$pkgver/icons/gamepad4-24x24.png" "${pkgdir}/usr/share/icons/hicolor/24x24/apps/qjoypad.png"
+ install -m644 "${srcdir}/$pkgname-$pkgver/icons/gamepad4-64x64.png" "${pkgdir}/usr/share/icons/hicolor/64x64/apps/qjoypad.png"
+}
diff --git a/qjoypad.desktop b/qjoypad.desktop
new file mode 100644
index 000000000000..633db1da851f
--- /dev/null
+++ b/qjoypad.desktop
@@ -0,0 +1,13 @@
+[Desktop Entry]
+Name=QJoyPad
+GenericName=Simulated Keystrokes
+GenericName[de]=Simulierte Tastendrücke
+Comment=Trigger keystrokes and mouse actions with gamepads/joysticks
+Comment[de]=Löse mit dem Gamepad/Joystick Tastendrücke und Mausbewegungen aus
+Icon=qjoypad
+Exec=qjoypad
+Terminal=false
+Type=Application
+Categories=Utility;Game;
+StartupNotify=false
+Encoding=UTF-8
diff --git a/qjoypad.install b/qjoypad.install
new file mode 100644
index 000000000000..68b8e971a741
--- /dev/null
+++ b/qjoypad.install
@@ -0,0 +1,12 @@
+post_install() {
+ xdg-icon-resource forceupdate --theme hicolor &> /dev/null
+ update-desktop-database -q
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+post_remove() {
+ post_install $1
+}
diff --git a/x11.patch b/x11.patch
new file mode 100644
index 000000000000..dee1f61c9009
--- /dev/null
+++ b/x11.patch
@@ -0,0 +1,11 @@
+--- branches/multikey/src/qjoypad.pro 2011/01/20 16:14:37132
++++ branches/multikey/src/qjoypad.pro 2011/12/22 15:17:14133
+@@ -31,7 +31,7 @@
+
+ TEMPLATE = app
+ INCLUDEPATH += .
+-QMAKE_LIBS += -lXtst
++QMAKE_LIBS += -lXtst -lX11
+
+ # Input
+ HEADERS += axis.h \ \ No newline at end of file