summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLukas Sabota2015-12-30 21:54:36 -0500
committerLukas Sabota2015-12-30 21:54:36 -0500
commit9fa1aaf0eb3a39c422c8fdf97da793c25f054c7f (patch)
tree8049a77b14cae09608fecf18a7ff9372718af99f
downloadaur-9fa1aaf0eb3a39c422c8fdf97da793c25f054c7f.tar.gz
initial commit
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD55
2 files changed, 74 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..73312cdeac0b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+# Generated by mksrcinfo v8
+# Thu Dec 31 02:54:25 UTC 2015
+pkgbase = qjoypad-panzi-git
+ pkgdesc = Panzi's fork of QJoyPad with some small additional features and some bug/memory leak fixes.
+ pkgver = v4.2.1.r1.gf9816ca
+ pkgrel = 1
+ url = https://github.com/panzi/qjoypad
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ makedepends = git
+ depends = qt4
+ depends = libxt
+ depends = libsystemd
+ provides = qjoypad
+ conflicts = qjoypad
+
+pkgname = qjoypad-panzi-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..444267067ab0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,55 @@
+# Maintainer: Lukas Sabota <lukas@lwsabota.com>
+# Contributor: Lukas Sabota <lukas@lwsabota.com>
+pkgname=qjoypad-panzi-git
+pkgver=v4.2.1.r1.gf9816ca
+pkgrel=1
+pkgdesc="Panzi's fork of QJoyPad with some small additional features and some bug/memory leak fixes."
+arch=('i686' 'x86_64')
+url="https://github.com/panzi/qjoypad"
+license=('GPL2')
+depends=('qt4' 'libxt' 'libsystemd')
+makedepends=('git')
+provides=('qjoypad')
+conflicts=('qjoypad')
+
+_gitroot=https://github.com/panzi/qjoypad.git
+_gitname=qjoypad
+
+build() {
+ cd "$srcdir"
+ msg "Connecting to GIT server...."
+
+ if [[ -d "$_gitname" ]]; then
+ cd "$_gitname" && git pull origin
+ msg "The local files are updated."
+ else
+ git clone "$_gitroot"
+ fi
+
+ msg "GIT checkout done or server timeout"
+ msg "Starting build..."
+
+ rm -rf "$srcdir/$_gitname-build"
+ git clone "$srcdir/$_gitname" "$srcdir/$_gitname-build"
+ cd "$srcdir/$_gitname-build"
+
+ #
+ # BUILD HERE
+ #
+ mkdir build
+ cd build
+ cmake .. -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_BUILD_TYPE=Release
+ make
+}
+
+package() {
+ cd "$srcdir/$_gitname-build/build"
+ make DESTDIR="$pkgdir/" install
+}
+
+pkgver() {
+ cd "$srcdir/$_gitname-build"
+ git describe --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+# vim:set ts=2 sw=2 et: