summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarkus Heidelberg2019-07-01 19:47:54 +0200
committerMarkus Heidelberg2019-07-01 19:47:54 +0200
commitca7ccd7f9ecd70359d38ec8e98c3133d63b8e4d2 (patch)
tree8d981cd21f32b57f74f91a16cb1c1c933a188f7d
parent5d30f76ca53a7688e02b287679addbbf4982a52b (diff)
downloadaur-ca7ccd7f9ecd70359d38ec8e98c3133d63b8e4d2.tar.gz
qlandkartegt-1.8.1-12: workaround for deprecated proj API and fix for Qt related build error
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD8
-rw-r--r--fix-incomplete-type.patch25
-rw-r--r--fix-proj_api.patch32
4 files changed, 69 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9336c4139d05..1ccbf7361120 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = qlandkartegt
pkgdesc = Use your GPS with Linux
pkgver = 1.8.1
- pkgrel = 11
+ pkgrel = 12
url = http://www.qlandkarte.org/
arch = i686
arch = x86_64
@@ -30,6 +30,8 @@ pkgbase = qlandkartegt
source = fix-ver_str.patch
source = fix-qtgui-include.patch
source = fix-gps_read.patch
+ source = fix-proj_api.patch
+ source = fix-incomplete-type.patch
source = improve-gpx-creator.patch
source = improve-gpx-name.patch
sha256sums = 9e0605ab8f4cbd27741b507f252f08370e9ccca4e05ec35878256c59b22a9be7
@@ -38,6 +40,8 @@ pkgbase = qlandkartegt
sha256sums = 143a79f7ff17850faf571f65f719db0d68de6e8d2943790431d21776e7b67458
sha256sums = 44da55424a616a74114882a7b4f1bad81d2d9d506b747b7984a5faf493362d17
sha256sums = 84447833e68fa0d79c0cbeeb5ce67bc4d5c331b0661badcbc1883afbe05ff242
+ sha256sums = a305b18e44748745d79fbadea3ae54d6139f4fbf63303d322e9309fe1a816818
+ sha256sums = c59ba3121c47e8b965eecd9b2bc52c0daded0b2067053ea05f70adcbaf7761e3
sha256sums = c6af42ba9d1958d45c0b0e2acc3a41cb4372a299b7b06bfbb6c05cf778c45e7f
sha256sums = 26efbc57123a81c6ced6809f48c3a8ea1bca36f1098a5226a5052f7ad6bb613b
diff --git a/PKGBUILD b/PKGBUILD
index bf7d0ddbe614..184f0eeff64d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
pkgname=qlandkartegt
pkgver=1.8.1
-pkgrel=11
+pkgrel=12
pkgdesc="Use your GPS with Linux"
arch=('i686' 'x86_64')
url="http://www.qlandkarte.org/"
@@ -21,6 +21,8 @@ source=(https://bitbucket.org/maproom/qlandkarte-gt/downloads/$pkgname-$pkgver.t
fix-ver_str.patch
fix-qtgui-include.patch
fix-gps_read.patch
+ fix-proj_api.patch
+ fix-incomplete-type.patch
improve-gpx-creator.patch
improve-gpx-name.patch)
sha256sums=('9e0605ab8f4cbd27741b507f252f08370e9ccca4e05ec35878256c59b22a9be7'
@@ -29,6 +31,8 @@ sha256sums=('9e0605ab8f4cbd27741b507f252f08370e9ccca4e05ec35878256c59b22a9be7'
'143a79f7ff17850faf571f65f719db0d68de6e8d2943790431d21776e7b67458'
'44da55424a616a74114882a7b4f1bad81d2d9d506b747b7984a5faf493362d17'
'84447833e68fa0d79c0cbeeb5ce67bc4d5c331b0661badcbc1883afbe05ff242'
+ 'a305b18e44748745d79fbadea3ae54d6139f4fbf63303d322e9309fe1a816818'
+ 'c59ba3121c47e8b965eecd9b2bc52c0daded0b2067053ea05f70adcbaf7761e3'
'c6af42ba9d1958d45c0b0e2acc3a41cb4372a299b7b06bfbb6c05cf778c45e7f'
'26efbc57123a81c6ced6809f48c3a8ea1bca36f1098a5226a5052f7ad6bb613b')
@@ -38,6 +42,8 @@ prepare() {
patch -Np1 -i ../fix-ver_str.patch
patch -Np1 -i ../fix-qtgui-include.patch
patch -Np1 -i ../fix-gps_read.patch
+ patch -Np1 -i ../fix-proj_api.patch
+ patch -Np1 -i ../fix-incomplete-type.patch
patch -Np1 -i ../improve-gpx-creator.patch
patch -Np1 -i ../improve-gpx-name.patch
diff --git a/fix-incomplete-type.patch b/fix-incomplete-type.patch
new file mode 100644
index 000000000000..2ba1e68bcb7f
--- /dev/null
+++ b/fix-incomplete-type.patch
@@ -0,0 +1,25 @@
+From 54f10bc69465c3dab3342b691829825dc130598e Mon Sep 17 00:00:00 2001
+From: Markus Heidelberg <markus.heidelberg@web.de>
+Date: Mon, 1 Jul 2019 18:55:54 +0200
+Subject: [PATCH] Fix compile error "field 'levels' has incomplete type
+ 'QList<CInputFile::level_t>'"
+
+---
+ 3rdparty/map2rmap/CInputFile.h | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/3rdparty/map2rmap/CInputFile.h b/3rdparty/map2rmap/CInputFile.h
+index f3ce8cb..40515a8 100644
+--- a/3rdparty/map2rmap/CInputFile.h
++++ b/3rdparty/map2rmap/CInputFile.h
+@@ -20,6 +20,7 @@
+
+ #include <QString>
+ #include <QVector>
++#include <QList>
+ #include <gdal_priv.h>
+ #include <proj_api.h>
+
+--
+2.22.0
+
diff --git a/fix-proj_api.patch b/fix-proj_api.patch
new file mode 100644
index 000000000000..b4c977374cc7
--- /dev/null
+++ b/fix-proj_api.patch
@@ -0,0 +1,32 @@
+From 27dca08166234d0c650a5e32f83e90f02a3287b2 Mon Sep 17 00:00:00 2001
+From: Markus Heidelberg <markus.heidelberg@web.de>
+Date: Mon, 1 Jul 2019 16:44:33 +0200
+Subject: [PATCH] Allow deprecated "proj_api.h" header file
+
+In the long term the API has to be adapted from version 4 to 6 (see
+https://proj.org/development/migration.html#) if this package should be
+kept usable.
+
+See also https://proj.org/development/index.html:
+"The proj_api.h header and the functions related to it is considered
+deprecated from version 5.0.0 and onwards. The header will be removed
+from PROJ in version 7.0.0 scheduled for release February 1st 2020."
+---
+ CMakeLists.txt | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index cbad161..046841a 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -26,6 +26,7 @@ set(APPLICATION_VERSION_PATCH "1")
+
+
+ add_definitions(-DVER_MAJOR=${APPLICATION_VERSION_MAJOR} -DVER_MINOR=${APPLICATION_VERSION_MINOR} -DVER_STEP=${APPLICATION_VERSION_PATCH})
++add_definitions(-DACCEPT_USE_OF_DEPRECATED_PROJ_API_H)
+
+ set(EXECUTABLE_OUTPUT_PATH ${CMAKE_BINARY_DIR}/bin)
+ if (APPLE)
+--
+2.22.0
+