summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeo Verto2019-08-15 04:51:56 +0200
committerLeo Verto2019-08-15 04:51:56 +0200
commit184b024575a633e2dd7828a0f98301ca7e695769 (patch)
treede707f7627284fe94490d8969ded229c5616f575
downloadaur-184b024575a633e2dd7828a0f98301ca7e695769.tar.gz
Initial commit
-rw-r--r--.SRCINFO28
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD41
-rw-r--r--qlcplus-git.install12
4 files changed, 82 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f80f094fcfb4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,28 @@
+pkgbase = qlcplus-git
+ pkgdesc = Q Light Controller - The open DMX lighting desk software for controlling professional lighting fixtures.
+ pkgver = 4.11.2.r1024.g50b228e64
+ pkgrel = 1
+ url = http://qlcplus.org/
+ install = qlcplus-git.install
+ arch = i686
+ arch = x86_64
+ license = APACHE
+ makedepends = git
+ makedepends = qt5-tools
+ depends = qt5-script
+ depends = qt5-multimedia
+ depends = libftdi-compat
+ depends = libsndfile
+ depends = libmad
+ depends = shared-mime-info
+ depends = fftw
+ depends = libftdi
+ depends = desktop-file-utils
+ optdepends = ola: Open Lighting Architecture plugin
+ provides = qlcplus
+ conflicts = qlcplus
+ source = git+https://github.com/mcallegari/qlcplus.git
+ sha1sums = SKIP
+
+pkgname = qlcplus-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..72e8ffc0db8a
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1 @@
+*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4d5abaa4d703
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# Maintainer: Leo Verto <leotheverto+aur@gmail.com>
+
+pkgname=qlcplus-git
+_pkgname=qlcplus
+pkgver=4.11.2.r1024.g50b228e64
+pkgrel=1
+pkgdesc="Q Light Controller - The open DMX lighting desk software for controlling professional lighting fixtures."
+arch=('i686' 'x86_64')
+url="http://qlcplus.org/"
+license=('APACHE')
+depends=('qt5-script' 'qt5-multimedia' 'libftdi-compat' 'libsndfile' 'libmad' 'shared-mime-info' 'fftw' 'libftdi' 'desktop-file-utils')
+makedepends=('git' 'qt5-tools')
+optdepends=('ola: Open Lighting Architecture plugin')
+provides=("${_pkgname}")
+conflicts=("${_pkgname}")
+install=${pkgname}.install
+source=('git+https://github.com/mcallegari/qlcplus.git')
+sha1sums=('SKIP')
+pkgver() {
+ cd "$srcdir/${_pkgname}"
+
+ # Remove 'QLC+_' prefix from git tag
+ git describe --long | sed 's/^QLC+_//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+prepare() {
+ cd "$srcdir/${_pkgname}"
+
+}
+
+build() {
+ cd "$srcdir/${_pkgname}"
+
+ qmake-qt5 FORCECONFIG=release
+ make
+}
+
+package() {
+ cd "$srcdir/${_pkgname}"
+ make INSTALL_ROOT="$pkgdir/" install
+}
diff --git a/qlcplus-git.install b/qlcplus-git.install
new file mode 100644
index 000000000000..3227b09631d9
--- /dev/null
+++ b/qlcplus-git.install
@@ -0,0 +1,12 @@
+post_install() {
+ update-mime-database /usr/share/mime
+ update-desktop-database -q
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+post_remove() {
+ post_install $1
+}