summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlin Porcic2017-09-26 03:38:48 +0200
committerAlin Porcic2017-09-26 03:38:48 +0200
commit5c068c22875a5d81df10df434141a1c6317cd848 (patch)
tree34b8fec81d91a594023554e06929df25ebb16f19
downloadaur-5c068c22875a5d81df10df434141a1c6317cd848.tar.gz
Inital commit, added PKGBUILD and .SRCINFO
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD42
2 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8bd074102c55
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,12 @@
+pkgbase = qlibc
+ pkgdesc = A simple and powerful C library.
+ pkgver = 2.4.2
+ pkgrel = 1
+ url = https://github.com/wolkykim/qlibc
+ arch = any
+ license = custom
+ source = https://github.com/wolkykim/qlibc/archive/v2.4.2.tar.gz
+ md5sums = 86d434674491d9f9906a238f7bea8837
+
+pkgname = qlibc
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c9d3b6144d8d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# Maintainer: Alin Porcic <alin.porcic@gmail.com
+pkgname=qlibc
+pkgver=2.4.2
+pkgrel=1
+epoch=
+pkgdesc="A simple and powerful C library."
+arch=('any')
+url="https://github.com/wolkykim/qlibc"
+license=('custom')
+groups=()
+depends=()
+makedepends=()
+checkdepends=()
+optdepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source=("https://github.com/wolkykim/qlibc/archive/v2.4.2.tar.gz")
+noextract=()
+md5sums=("86d434674491d9f9906a238f7bea8837")
+validpgpkeys=()
+
+build() {
+ cd "$pkgname-$pkgver"
+ ./configure --prefix=/usr
+ make
+}
+
+check() {
+ cd "$pkgname-$pkgver"
+ make tests
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ make DESTDIR="$pkgdir/" install
+ install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+}