summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVladislav Tyulbashev2015-06-30 21:17:52 +0300
committerVladislav Tyulbashev2015-06-30 21:17:52 +0300
commit850e85af99bd47d2bdc43fedd0d070bf56a20595 (patch)
tree50651e1c25e5a5b76e311358a7e7fc665ff3a86c
downloadaur-850e85af99bd47d2bdc43fedd0d070bf56a20595.tar.gz
Initial import
-rw-r--r--.AURINFO22
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD33
3 files changed, 77 insertions, 0 deletions
diff --git a/.AURINFO b/.AURINFO
new file mode 100644
index 000000000000..6e97664ba86d
--- /dev/null
+++ b/.AURINFO
@@ -0,0 +1,22 @@
+pkgbase = qlivebittorrent-git
+ pkgdesc = Simple bittorrent client with very interesting live feature
+ pkgver = 20140909
+ pkgrel = 1
+ url = https://github.com/vtyulb/QLiveBittorrent
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = wget
+ makedepends = unzip
+ makedepends = fuse
+ makedepends = geoip
+ makedepends = libtorrent-rasterbar
+ makedepends = qt5-base
+ makedepends = boost
+ depends = qt5-base
+ depends = boost-libs
+ depends = libtorrent-rasterbar
+ depends = ncurses
+
+pkgname = qlivebittorrent-git
+
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6e97664ba86d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = qlivebittorrent-git
+ pkgdesc = Simple bittorrent client with very interesting live feature
+ pkgver = 20140909
+ pkgrel = 1
+ url = https://github.com/vtyulb/QLiveBittorrent
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = wget
+ makedepends = unzip
+ makedepends = fuse
+ makedepends = geoip
+ makedepends = libtorrent-rasterbar
+ makedepends = qt5-base
+ makedepends = boost
+ depends = qt5-base
+ depends = boost-libs
+ depends = libtorrent-rasterbar
+ depends = ncurses
+
+pkgname = qlivebittorrent-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..dc736ffd3a2c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Vladislav Tyulbashev <vladislav.tyulbashev@yandex.ru>
+
+pkgname=qlivebittorrent-git
+pkgver=20140909
+pkgrel=1
+pkgdesc="Simple bittorrent client with very interesting live feature"
+arch=('i686' 'x86_64')
+url="https://github.com/vtyulb/QLiveBittorrent"
+license=('GPL')
+depends=('qt5-base' 'boost-libs' 'libtorrent-rasterbar' 'ncurses')
+makedepends=('wget' 'unzip' 'fuse' 'geoip' 'libtorrent-rasterbar' 'qt5-base' 'boost')
+
+build() {
+ cd ${srcdir}
+ rm -fv master.zip
+ wget https://github.com/vtyulb/QLiveBittorrent/archive/master.zip
+ rm -rfv QLiveBittorrent-master
+ unzip master.zip
+ cd QLiveBittorrent-master/src/
+ gcc -g `pkg-config fuse --cflags --libs` driver.c -o qlivebittorrent-driver
+ echo "Disabling portable version"
+ cat QLiveBittorrent.pro | grep -v PORTABLE > tmp
+ mv tmp QLiveBittorrent.pro
+ qmake-qt5 -makefile
+ make
+}
+
+package() {
+ cd ${srcdir}/QLiveBittorrent-master/src/
+ mkdir -p $pkgdir/usr/bin
+ cp -f QLiveBittorrent $pkgdir/usr/bin/qlivebittorrent
+ cp -f qlivebittorrent-driver $pkgdir/usr/bin/qlivebittorrent-driver
+}