summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorScott Percival2016-12-04 20:10:27 +0800
committerScott Percival2016-12-04 20:10:27 +0800
commit8a0cb13a5ec9c3261fee77ef8606d29ab7b54c0f (patch)
tree3875d9101e05015b5843641ad7d850bdbfeff174
downloadaur-8a0cb13a5ec9c3261fee77ef8606d29ab7b54c0f.tar.gz
Initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD44
2 files changed, 60 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d4131ff941fe
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = qm-dsp
+ pkgdesc = A C++ library of functions for DSP and Music Informatics purposes
+ pkgver = 1.7.1
+ pkgrel = 1
+ url = http://ardour.org/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = git
+ provides = qm-dsp
+ conflicts = qm-dsp
+ source = qm-dsp-1.7.1::git://github.com/c4dm/qm-dsp.git#tag=v1.7.1
+ md5sums = SKIP
+
+pkgname = qm-dsp
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b0ee6144564e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+# Maintainer: Scott Percival <code at moral.net.au>
+
+pkgname=qm-dsp
+pkgver=1.7.1
+pkgrel=1
+pkgdesc="A C++ library of functions for DSP and Music Informatics purposes"
+arch=('i686' 'x86_64')
+url="http://ardour.org/"
+license=('GPL')
+depends=()
+makedepends=('git')
+provides=("${pkgname}")
+conflicts=("${pkgname}")
+source=("${pkgname}-${pkgver}::git://github.com/c4dm/qm-dsp.git#tag=v${pkgver}")
+md5sums=('SKIP')
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ make -f build/linux/Makefile.linux32
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ install -Dm644 -t ${pkgdir}/usr/lib libqm-dsp.a
+ install -Dm644 -t ${pkgdir}/usr/include/qm-dsp/base base/*.h
+ install -Dm644 -t ${pkgdir}/usr/include/qm-dsp/dsp/chromagram dsp/chromagram/*.h
+ install -Dm644 -t ${pkgdir}/usr/include/qm-dsp/dsp/keydetection dsp/keydetection/*.h
+ install -Dm644 -t ${pkgdir}/usr/include/qm-dsp/dsp/mfcc dsp/mfcc/*.h
+ install -Dm644 -t ${pkgdir}/usr/include/qm-dsp/dsp/onsets dsp/onsets/*.h
+ install -Dm644 -t ${pkgdir}/usr/include/qm-dsp/dsp/phasevocoder dsp/phasevocoder/*.h
+ install -Dm644 -t ${pkgdir}/usr/include/qm-dsp/dsp/rateconversion dsp/rateconversion/*.h
+ install -Dm644 -t ${pkgdir}/usr/include/qm-dsp/dsp/rhythm dsp/rhythm/*.h
+ install -Dm644 -t ${pkgdir}/usr/include/qm-dsp/dsp/segmentation dsp/segmentation/*.h
+ install -Dm644 -t ${pkgdir}/usr/include/qm-dsp/dsp/signalconditioning dsp/signalconditioning/*.h
+ install -Dm644 -t ${pkgdir}/usr/include/qm-dsp/dsp/tempotracking dsp/tempotracking/*.h
+ install -Dm644 -t ${pkgdir}/usr/include/qm-dsp/dsp/tonal dsp/tonal/*.h
+ install -Dm644 -t ${pkgdir}/usr/include/qm-dsp/dsp/transforms dsp/transforms/*.h
+ install -Dm644 -t ${pkgdir}/usr/include/qm-dsp/dsp/wavelet dsp/wavelet/*.h
+ install -Dm644 -t ${pkgdir}/usr/include/qm-dsp/maths maths/*.h
+ install -Dm644 -t ${pkgdir}/usr/include/qm-dsp/thread thread/*.h
+
+}
+
+# vim:set ts=2 sw=2 et: