summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVincent PRELAT2015-06-27 09:36:45 +0200
committerVincent PRELAT2015-06-27 09:36:45 +0200
commit62f8ae7172b30f5ffec2e434a343f6619563a1d6 (patch)
treee098ce5fda984ded07d5ac74288a99b608b82801
downloadaur-qmagneto-bzr.tar.gz
Initial import
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD47
2 files changed, 63 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..896ae1d51459
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = qmagneto-bzr
+ pkgdesc = French TV guide with record function
+ pkgver = r228
+ pkgrel = 2
+ url = https://launchpad.net/qmagneto
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = bzr
+ depends = qt4
+ replaces = qmagneto
+ source = bzr+lp:qmagneto
+ md5sums = SKIP
+
+pkgname = qmagneto-bzr
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e72d6227369d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,47 @@
+# Maintainer: Vincent Prelat <prelatv [at] gmail.com>
+
+pkgname=qmagneto-bzr
+pkgver=r228
+pkgrel=2
+pkgdesc="French TV guide with record function"
+url="https://launchpad.net/qmagneto"
+arch=('i686' 'x86_64')
+license=('GPL')
+depends=('qt4')
+makedepends=('bzr')
+replaces=('qmagneto')
+source=(bzr+lp:qmagneto)
+md5sums=('SKIP')
+
+pkgver() {
+ cd qmagneto
+
+ echo "r$(bzr revno)"
+}
+
+
+build() {
+ cd qmagneto
+
+ qmake-qt4 || return 1
+ make || return 1
+
+}
+
+package() {
+ cd qmagneto
+
+ #binary file
+ install -d "$pkgdir/usr/"
+ install -d "$pkgdir/usr/bin"
+ install -m 755 "bin/qmagneto" "$pkgdir/usr/bin/qmagneto"
+
+ #icon and desktop file
+ install -d "$pkgdir/usr/share"
+ install -d "$pkgdir/usr/share/pixmaps"
+ install -d "$pkgdir/usr/share/applications"
+ install -m 755 "resources/images/logo_qmagneto.xpm" "$pkgdir/usr/share/pixmaps/logo_qmagneto.xpm"
+ install -m 755 "debian/qmagneto.desktop" "$pkgdir/usr/share/applications/qmagneto.desktop"
+
+}
+