summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPantelis Panayiotou2023-12-19 20:59:57 +0200
committerPantelis Panayiotou2023-12-19 20:59:57 +0200
commit64a44fbd0127daedd3abfb9fd16b5c554a8933ec (patch)
treee6756493e824d3e9c0a7953df0235a9b4b3b3cca
downloadaur-64a44fbd0127daedd3abfb9fd16b5c554a8933ec.tar.gz
Initial commit
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD28
2 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6c1dd09baf96
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = qman-git
+ pkgdesc = A more modern manual page viewer for our terminals
+ pkgver = nightly
+ pkgrel = 1
+ url = https://github.com/plp13/qman
+ arch = x86_64
+ license = BSD-2-CLAUSE
+ makedepends = git
+ makedepends = meson
+ depends = ncurses
+ depends = libinih
+ source = qman-git::git+https://github.com/plp13/qman.git
+ sha256sums = SKIP
+
+pkgname = qman-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0c8a49278f2a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Pantelis Panayiotou <p.panayiotou@gmail.com>
+
+pkgname=qman-git
+pkgver=nightly
+pkgrel=1
+pkgdesc="A more modern manual page viewer for our terminals"
+
+arch=('x86_64')
+url="https://github.com/plp13/qman"
+license=('BSD-2-CLAUSE')
+depends=('ncurses' 'libinih')
+makedepends=('git' 'meson')
+source=("$pkgname"::"git+https://github.com/plp13/qman.git")
+sha256sums=('SKIP')
+
+build() {
+ cd "${pkgname}"
+ meson setup "build/" "src/"
+ cd "build/"
+ meson configure -Dprefix="/usr"
+ meson compile
+}
+
+package() {
+ cd "${pkgname}"
+ cd "build/"
+ meson install --destdir "${pkgdir}"
+}