summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPeter K. Moss2020-11-04 18:37:11 +0100
committerPeter K. Moss2020-11-04 18:37:11 +0100
commitc0d23d027a9dc263d735e3c1cf6c071e54a41ab2 (patch)
treecfd01f400aa3bf51918bcf68bb91cd94ac22f0be
parent52806a40ca99b76f5fcdbb5c9afdefaf2f32340b (diff)
downloadaur-c0d23d027a9dc263d735e3c1cf6c071e54a41ab2.tar.gz
Added update script
-rwxr-xr-xupdate.sh7
1 files changed, 7 insertions, 0 deletions
diff --git a/update.sh b/update.sh
new file mode 100755
index 000000000000..5d41d34c74b0
--- /dev/null
+++ b/update.sh
@@ -0,0 +1,7 @@
+#!/bin/sh
+
+makepkg -f &&
+makepkg --printsrcinfo > .SRCINFO &&
+git add PKGBUILD .SRCINFO &&
+git commit -m "Updated to version $(makepkg --printsrcinfo | grep pkgver | cut -d ' ' -f 3)" &&
+git push