summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzhullyb2020-09-07 23:27:20 +0800
committerzhullyb2020-09-07 23:27:20 +0800
commit8de4379d6ce3df579a73870bde68b60a5a0e34f7 (patch)
tree2436a2c6690a2d96929cfc0d7adfdd3c93ce2326
downloadaur-8de4379d6ce3df579a73870bde68b60a5a0e34f7.tar.gz
First Version on Archlinux!
-rw-r--r--.SRCINFO15
-rw-r--r--LICENSE21
-rw-r--r--PKGBUILD30
3 files changed, 66 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..50275a8733b9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = qmc-decoder-bin
+ pkgdesc = Fastest & best convert qmc 2 mp3 | flac tools
+ pkgver = 2.5
+ pkgrel = 1
+ url = https://github.com/Presburger/qmc-decoder
+ arch = x86_64
+ license = MIT
+ provides = qmc-decoder
+ source = https://github.com/Presburger/qmc-decoder/releases/download/2.5/decoder-linux
+ source = LICENSE
+ md5sums = cce6bb6250763450397608e6875d004b
+ md5sums = 60b38304a9a9aa2422b233fc02dedc56
+
+pkgname = qmc-decoder-bin
+
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..fa2b98bfee75
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,21 @@
+MIT License
+
+Copyright (c) 2019 Presburger
+
+Permission is hereby granted, free of charge, to any person obtaining a copy
+of this software and associated documentation files (the "Software"), to deal
+in the Software without restriction, including without limitation the rights
+to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
+copies of the Software, and to permit persons to whom the Software is
+furnished to do so, subject to the following conditions:
+
+The above copyright notice and this permission notice shall be included in all
+copies or substantial portions of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
+SOFTWARE.
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..560ef894ee36
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: zhullyb <zhullyb@outlook.com>
+# Author: presburger <mayushengmusic@gmail.com>
+
+pkgname=qmc-decoder-bin
+pkgver=2.5
+pkgrel=1
+pkgdesc="Fastest & best convert qmc 2 mp3 | flac tools"
+arch=('x86_64')
+url="https://github.com/Presburger/qmc-decoder"
+license=('MIT')
+depends=()
+provides=('qmc-decoder')
+conflicts=()
+
+source=(
+ "${url}/releases/download/2.5/decoder-linux"
+ "LICENSE"
+)
+
+md5sums=(
+ 'cce6bb6250763450397608e6875d004b'
+ '60b38304a9a9aa2422b233fc02dedc56'
+)
+
+package() {
+ cd "$srcdir"
+
+ install -Dm755 "decoder-linux" "$pkgdir/usr/bin/qmc-decoder"
+ install -Dm644 "LICENSE" "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+}