summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAdam Reichold2022-03-11 10:02:35 +0100
committerAdam Reichold2022-03-11 10:02:35 +0100
commit3b1df6003b674a5b4c4e986ac8863e0819d0a4f0 (patch)
treef8e1808b120a34a7426a52140cc63029f77150d0
parentfc874420db4b759a54f4be618ea4e8eb6682e207 (diff)
downloadaur-3b1df6003b674a5b4c4e986ac8863e0819d0a4f0.tar.gz
Update to Qt version 6 and disable LTO as it breaks linking C into Rust into C++.
-rw-r--r--.SRCINFO37
-rw-r--r--PKGBUILD10
2 files changed, 24 insertions, 23 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 238dfac5b315..02e069570a0b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,22 +1,21 @@
pkgbase = qmediathekview-git
- pkgdesc = An alternative front-end to the MediathekView database. (development version)
- pkgver = r89.0e7fcdb
- pkgrel = 1
- url = https://github.com/adamreichold/QMediathekView
- arch = i686
- arch = x86_64
- arch = armv7h
- license = GPL3
- makedepends = git
- makedepends = qt5-tools
- makedepends = rust
- makedepends = cargo
- depends = qt5-base
- depends = hicolor-icon-theme
- optdepends = vlc: for direct playback of shows
- conflicts = qmediathekview
- source = git+https://github.com/adamreichold/QMediathekView.git
- md5sums = SKIP
+ pkgdesc = An alternative front-end to the MediathekView database. (development version)
+ pkgver = r131.602a3f4
+ pkgrel = 1
+ url = https://github.com/adamreichold/QMediathekView
+ arch = i686
+ arch = x86_64
+ arch = armv7h
+ license = GPL3
+ makedepends = git
+ makedepends = qt6-tools
+ makedepends = rust
+ makedepends = cargo
+ depends = qt6-base
+ depends = hicolor-icon-theme
+ optdepends = vlc: for direct playback of shows
+ conflicts = qmediathekview
+ source = git+https://github.com/adamreichold/QMediathekView.git
+ md5sums = SKIP
pkgname = qmediathekview-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 78aed2bc7553..462224e51a02 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,15 +1,15 @@
# Maintainer: Adam Reichold <adam.reichold@t-online.de>
pkgname=qmediathekview-git
-pkgver=r89.0e7fcdb
+pkgver=r131.602a3f4
pkgrel=1
pkgdesc='An alternative front-end to the MediathekView database. (development version)'
arch=('i686' 'x86_64' 'armv7h')
url='https://github.com/adamreichold/QMediathekView'
license=('GPL3')
-depends=('qt5-base' 'hicolor-icon-theme')
+depends=('qt6-base' 'hicolor-icon-theme')
optdepends=('vlc: for direct playback of shows')
-makedepends=('git' 'qt5-tools' 'rust' 'cargo')
+makedepends=('git' 'qt6-tools' 'rust' 'cargo')
conflicts=('qmediathekview')
source=('git+https://github.com/adamreichold/QMediathekView.git')
md5sums=('SKIP')
@@ -23,7 +23,9 @@ pkgver() {
build() {
cd "$srcdir/QMediathekView"
- qmake-qt5
+ # disable LTO since this breaks linking static libraries built by GCC into the static library built by rustc into the binary built by GCC,
+ # c.f. https://github.com/adamreichold/QMediathekView/issues/18
+ qmake6 CONFIG-=ltcg
make
}