summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAdam Reichold2023-08-04 18:31:12 +0200
committerAdam Reichold2023-08-04 18:32:55 +0200
commit58da94bf4486460e6c33753edef5846a54a30f3a (patch)
treef1c793c881b6d852e99e5f270a1c4fdf2e4408ee
parent3b1df6003b674a5b4c4e986ac8863e0819d0a4f0 (diff)
downloadaur-58da94bf4486460e6c33753edef5846a54a30f3a.tar.gz
Try harder to disable LTO which still breaks linking.
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD7
2 files changed, 6 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 02e069570a0b..4aa5287c288c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = qmediathekview-git
pkgdesc = An alternative front-end to the MediathekView database. (development version)
- pkgver = r131.602a3f4
+ pkgver = r142.e5bfec2
pkgrel = 1
url = https://github.com/adamreichold/QMediathekView
arch = i686
@@ -15,6 +15,7 @@ pkgbase = qmediathekview-git
depends = hicolor-icon-theme
optdepends = vlc: for direct playback of shows
conflicts = qmediathekview
+ options = !lto
source = git+https://github.com/adamreichold/QMediathekView.git
md5sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 462224e51a02..1a02b1390a2d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -13,6 +13,9 @@ makedepends=('git' 'qt6-tools' 'rust' 'cargo')
conflicts=('qmediathekview')
source=('git+https://github.com/adamreichold/QMediathekView.git')
md5sums=('SKIP')
+# disable LTO since this breaks linking static libraries built by GCC into the static library built by rustc into the binary built by GCC,
+# c.f. https://github.com/adamreichold/QMediathekView/issues/18
+options+=('!lto')
pkgver() {
cd "$srcdir/QMediathekView"
@@ -23,9 +26,7 @@ pkgver() {
build() {
cd "$srcdir/QMediathekView"
- # disable LTO since this breaks linking static libraries built by GCC into the static library built by rustc into the binary built by GCC,
- # c.f. https://github.com/adamreichold/QMediathekView/issues/18
- qmake6 CONFIG-=ltcg
+ qmake6
make
}