summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAdam Reichold2016-01-28 21:07:08 +0100
committerAdam Reichold2016-01-28 21:07:08 +0100
commitac33270b949d14599107c4cd74e9415f83fced25 (patch)
tree66afd67f59a5402a218622999d2b8a6733b16f2d
downloadaur-ac33270b949d14599107c4cd74e9415f83fced25.tar.gz
Initial commit.
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD34
2 files changed, 58 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8108921f648c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+# Generated by mksrcinfo v8
+# Thu Jan 28 20:06:29 UTC 2016
+pkgbase = qmediathekview-git
+ pkgdesc = An alternative front-end to the MediathekView database. (development version)
+ pkgver = r17.01f4578
+ pkgrel = 1
+ url = https://github.com/adamreichold/QMediathekView
+ arch = i686
+ arch = x86_64
+ arch = armv7h
+ license = GPL3
+ makedepends = git
+ makedepends = qt5-tools
+ makedepends = boost
+ depends = qt5-base
+ depends = xz
+ depends = hicolor-icon-theme
+ optdepends = vlc: for direct playback of shows
+ conflicts = qmediathekview
+ source = git+https://github.com/adamreichold/QMediathekView.git
+ md5sums = SKIP
+
+pkgname = qmediathekview-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..74c07071ee8a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Adam Reichold <adam.reichold@t-online.de>
+
+pkgname=qmediathekview-git
+pkgver=r17.01f4578
+pkgrel=1
+pkgdesc='An alternative front-end to the MediathekView database. (development version)'
+arch=('i686' 'x86_64' 'armv7h')
+url='https://github.com/adamreichold/QMediathekView'
+license=('GPL3')
+depends=('qt5-base' 'xz' 'hicolor-icon-theme')
+optdepends=('vlc: for direct playback of shows')
+makedepends=('git' 'qt5-tools' 'boost')
+conflicts=('qmediathekview')
+source=('git+https://github.com/adamreichold/QMediathekView.git')
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/QMediathekView"
+
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "$srcdir/QMediathekView"
+
+ qmake-qt5
+ make
+}
+
+package() {
+ cd "$srcdir/QMediathekView"
+
+ make "INSTALL_ROOT=$pkgdir" install
+}