summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGary Wang2022-10-09 00:12:04 +0800
committerGary Wang2022-10-09 00:12:04 +0800
commitcce8a9b40835018be449bebf95ebd9d71e8db0de (patch)
tree615cb9b78d165cebdfe91816cb2c2dd77a8d6af2
parentc55b29aa49373c4a87a5bcf483df3860b8e7b341 (diff)
downloadaur-cce8a9b40835018be449bebf95ebd9d71e8db0de.tar.gz
add conflict to non-git version
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD5
2 files changed, 5 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 88c0228f202a..d685b787741e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = qmidiplayer-git
pkgdesc = A cross-platform midi file player based on libfluidsynth and Qt.
- pkgver = r204.5e6e461
+ pkgver = r237.07ee50b
pkgrel = 1
url = https://chrisoft.org/QMidiPlayer/
arch = x86_64
@@ -19,10 +19,10 @@ pkgbase = qmidiplayer-git
depends = glew
depends = openal
depends = devil
+ conflicts = qmidiplayer
source = git+https://git.chrisoft.org/git/QMidiPlayer.git
source = git+https://git.chrisoft.org/git/SMELT.git
md5sums = SKIP
md5sums = SKIP
pkgname = qmidiplayer-git
-
diff --git a/PKGBUILD b/PKGBUILD
index a6a6b956e553..6a459f5464f2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,12 +1,13 @@
# Maintainer: Gary Wang <wzc782970009@gmail.com>
pkgname=qmidiplayer-git
-pkgver=r204.5e6e461
+pkgver=r237.07ee50b
pkgrel=1
pkgdesc='A cross-platform midi file player based on libfluidsynth and Qt.'
arch=('x86_64')
url='https://chrisoft.org/QMidiPlayer/'
license=('GPLv3')
+conflicts=('qmidiplayer')
depends=(
'qt5-base' 'qt5-quickcontrols'
'rtmidi' 'fluidsynth'
@@ -42,7 +43,7 @@ prepare() {
build () {
cd ${srcdir}/QMidiPlayer
cmake -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_INSTALL_LIBDIR=lib .
- make
+ cmake --build . -j
}
package() {