summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorafernandezh2019-10-05 18:24:47 +0200
committerafernandezh2019-10-05 18:24:47 +0200
commit3a2c1a05c6b82b883ba19afaefdcc12054d38476 (patch)
treeae653aec8644c4190d15de80fba68c95f2eb65de
parent44c5856dcdb126471574c445ca4701ac3fc0814c (diff)
downloadaur-3a2c1a05c6b82b883ba19afaefdcc12054d38476.tar.gz
Fixed license
-rw-r--r--.SRCINFO2
-rw-r--r--LICENSE21
-rw-r--r--PKGBUILD5
3 files changed, 25 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 61e80a772d1b..9467a89ec836 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -4,7 +4,7 @@ pkgbase = qmk
pkgrel = 1
url = https://qmk.fm/
arch = any
- license = GPL
+ license = MIT
makedepends = python-setuptools
depends = python-appdirs
depends = python-argcomplete
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..3b5e3d820f8d
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,21 @@
+MIT License
+
+Copyright (c) 2019 QMK
+
+Permission is hereby granted, free of charge, to any person obtaining a copy
+of this software and associated documentation files (the "Software"), to deal
+in the Software without restriction, including without limitation the rights
+to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
+copies of the Software, and to permit persons to whom the Software is
+furnished to do so, subject to the following conditions:
+
+The above copyright notice and this permission notice shall be included in all
+copies or substantial portions of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
+SOFTWARE.
diff --git a/PKGBUILD b/PKGBUILD
index d6f98d5fffbd..e918bab32a48 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@ pkgrel=1
pkgdesc="CLI tool for customizing supported mechanical keyboards."
arch=('any')
url="https://qmk.fm/"
-license=('GPL')
+license=('MIT')
depends=(
'python-appdirs'
'python-argcomplete'
@@ -21,4 +21,5 @@ build() {
package() {
cd "${srcdir}/${pkgname}-${pkgver}"
python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
-} \ No newline at end of file
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}