summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAkaash Suresh2020-04-19 08:20:29 -0500
committerAkaash Suresh2020-04-19 08:20:29 -0500
commitb398d96e7b41659a863f2e080b86150a6e0d9a76 (patch)
tree6561f611e5e28ecf42c79a8dcb8ee942bc8769d4
parenta5e16ac3a736fcd710a5950f291ea75ca687d6da (diff)
downloadaur-b398d96e7b41659a863f2e080b86150a6e0d9a76.tar.gz
Update to v0.0.33
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD68
2 files changed, 38 insertions, 38 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 10fbd0c2fd0a..959067d7ff1b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = qmk
pkgdesc = CLI tool for customizing supported mechanical keyboards.
- pkgver = 0.0.31
- pkgrel = 2
+ pkgver = 0.0.33
+ pkgrel = 1
url = https://github.com/qmk/qmk_cli
arch = any
license = MIT
@@ -30,8 +30,8 @@ pkgbase = qmk
depends = unzip
depends = wget
depends = zip
- source = https://files.pythonhosted.org/packages/source/q/qmk/qmk-0.0.31.tar.gz
- sha256sums = 843c89914ac9749880913c2f54739c7c7ff15b45cfa988008385615f85403deb
+ source = https://files.pythonhosted.org/packages/source/q/qmk/qmk-0.0.33.tar.gz
+ sha256sums = 48c0c77929f5e795516beb2c44f851b9083420d7b6e0f76c9d716f827b2fc893
pkgname = qmk
diff --git a/PKGBUILD b/PKGBUILD
index 6fe1380bb382..eef07c4d7eb6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,49 +1,49 @@
# Maintainer: Akaash Suresh <https://github.com/Curry>
pkgname=qmk
-pkgver=0.0.31
-pkgrel=2
+pkgver=0.0.33
+pkgrel=1
pkgdesc="CLI tool for customizing supported mechanical keyboards."
arch=('any')
url="https://github.com/qmk/qmk_cli"
license=('MIT')
depends=(
- 'arm-none-eabi-binutils'
- 'arm-none-eabi-gcc'
- 'arm-none-eabi-newlib'
- 'avrdude'
- 'avr-binutils'
- 'avr-libc'
- 'python-appdirs'
- 'python-argcomplete'
- 'python-colorama'
- 'python-nose2'
- 'flake8'
- 'avr-gcc'
- 'clang'
- 'dfu-programmer'
- 'dfu-util'
- 'diffutils'
- 'gcc'
- 'git'
- 'libusb-compat'
- 'unzip'
- 'wget'
- 'zip'
- )
+ 'arm-none-eabi-binutils'
+ 'arm-none-eabi-gcc'
+ 'arm-none-eabi-newlib'
+ 'avrdude'
+ 'avr-binutils'
+ 'avr-libc'
+ 'python-appdirs'
+ 'python-argcomplete'
+ 'python-colorama'
+ 'python-nose2'
+ 'flake8'
+ 'avr-gcc'
+ 'clang'
+ 'dfu-programmer'
+ 'dfu-util'
+ 'diffutils'
+ 'gcc'
+ 'git'
+ 'libusb-compat'
+ 'unzip'
+ 'wget'
+ 'zip'
+)
makedepends=('python-setuptools' 'python' 'python-pip')
source=("https://files.pythonhosted.org/packages/source/q/qmk/qmk-${pkgver}.tar.gz")
-sha256sums=('843c89914ac9749880913c2f54739c7c7ff15b45cfa988008385615f85403deb')
+sha256sums=('48c0c77929f5e795516beb2c44f851b9083420d7b6e0f76c9d716f827b2fc893')
build() {
- pip install --no-deps --target="deps" yapf hjson
- cd "${srcdir}/${pkgname}-${pkgver}"
- python setup.py build
+ pip install --no-deps --target="deps" yapf hjson
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ python setup.py build
}
package() {
- sitepackages=$(python -c "import site; print(site.getsitepackages()[0])")
- cd "${srcdir}/${pkgname}-${pkgver}"
- python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
- cp -r $srcdir/deps/* $pkgdir/"$sitepackages"
- install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ sitepackages=$(python -c "import site; print(site.getsitepackages()[0])")
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
+ cp -r $srcdir/deps/* $pkgdir/"$sitepackages"
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}