summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAkaash Suresh2020-01-14 15:03:24 -0600
committerAkaash Suresh2020-01-14 15:03:24 -0600
commite05cb8718fa3aad688e60f2f9b0549491128cf38 (patch)
tree2be59e0f61bb37a77df51ec2c102543e5a58db4b
downloadaur-e05cb8718fa3aad688e60f2f9b0549491128cf38.tar.gz
sync to git
-rw-r--r--.SRCINFO35
-rw-r--r--LICENSE21
-rw-r--r--PKGBUILD54
3 files changed, 110 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..166728fb4175
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,35 @@
+pkgbase = qmk-git
+ pkgdesc = CLI tool for customizing supported mechanical keyboards.
+ pkgver = 0.0.26
+ pkgrel = 3
+ url = https://github.com/qmk/qmk_cli
+ arch = any
+ license = MIT
+ makedepends = python-setuptools
+ makedepends = python
+ makedepends = python-pip
+ depends = arm-none-eabi-binutils
+ depends = arm-none-eabi-gcc
+ depends = arm-none-eabi-newlib
+ depends = avrdude
+ depends = avr-binutils
+ depends = avr-libc
+ depends = python-appdirs
+ depends = python-argcomplete
+ depends = python-colorama
+ depends = avr-gcc
+ depends = clang
+ depends = dfu-programmer
+ depends = dfu-util
+ depends = diffutils
+ depends = gcc
+ depends = git
+ depends = libusb-compat
+ depends = unzip
+ depends = wget
+ depends = zip
+ source = git+https://github.com/qmk/qmk_cli.git
+ sha256sums = SKIP
+
+pkgname = qmk-git
+
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..3b5e3d820f8d
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,21 @@
+MIT License
+
+Copyright (c) 2019 QMK
+
+Permission is hereby granted, free of charge, to any person obtaining a copy
+of this software and associated documentation files (the "Software"), to deal
+in the Software without restriction, including without limitation the rights
+to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
+copies of the Software, and to permit persons to whom the Software is
+furnished to do so, subject to the following conditions:
+
+The above copyright notice and this permission notice shall be included in all
+copies or substantial portions of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
+SOFTWARE.
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0873d82d4709
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,54 @@
+# Maintainer: Akaash Suresh <https://github.com/Curry>
+pkgname=qmk-git
+pkgver=0.0.26
+pkgrel=3
+pkgdesc="CLI tool for customizing supported mechanical keyboards."
+arch=('any')
+url="https://github.com/qmk/qmk_cli"
+license=('MIT')
+_branch=qmk_cli
+depends=(
+ 'arm-none-eabi-binutils'
+ 'arm-none-eabi-gcc'
+ 'arm-none-eabi-newlib'
+ 'avrdude'
+ 'avr-binutils'
+ 'avr-libc'
+ 'python-appdirs'
+ 'python-argcomplete'
+ 'python-colorama'
+ 'avr-gcc'
+ 'clang'
+ 'dfu-programmer'
+ 'dfu-util'
+ 'diffutils'
+ 'gcc'
+ 'git'
+ 'libusb-compat'
+ 'unzip'
+ 'wget'
+ 'zip'
+ )
+makedepends=('python-setuptools' 'python' 'python-pip')
+source=('git+https://github.com/qmk/qmk_cli.git')
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$_branch"
+ echo $(git describe --tags)
+
+}
+
+build() {
+ pip install --no-deps --target="deps" yapf hjson
+ cd "$_branch"
+ python setup.py build
+}
+
+package() {
+ sitepackages=$(python -c "import site; print(site.getsitepackages()[0])")
+ cd "$_branch"
+ python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
+ cp -r $srcdir/deps/* $pkgdir/"$sitepackages"
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}