summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPier Luigi Fiorini2018-10-20 10:08:56 +0200
committerPier Luigi Fiorini2018-10-20 10:08:56 +0200
commit4fff74b8a702b33a30b5da7b43f393c13abf37aa (patch)
tree8b5e70c6622f612e7c4b1b39b25217c70d10b499
downloadaur-4fff74b8a702b33a30b5da7b43f393c13abf37aa.tar.gz
Initial import
-rw-r--r--.SRCINFO29
-rw-r--r--PKGBUILD48
2 files changed, 77 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7f4a3d8e9b4d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,29 @@
+# Generated by mksrcinfo v8
+# Sat Oct 20 08:08:47 UTC 2018
+pkgbase = qml-xwayland-git
+ pkgdesc = QtWayland additions and QPA plugin
+ pkgver = 20180924.67.8ffd882
+ pkgrel = 1
+ url = https://liri.io
+ arch = i686
+ arch = x86_64
+ arch = armv6h
+ arch = armv7h
+ groups = liri-git
+ license = GPL3
+ makedepends = git
+ makedepends = liri-qbs-shared-git
+ makedepends = xcb-util-cursor
+ makedepends = libxcursor
+ depends = qt5-declarative
+ depends = qt5-wayland
+ provides = qml-xwayland
+ conflicts = qml-xwayland
+ replaces = qml-xwayland
+ options = debug
+ options = !strip
+ source = qml-xwayland::git://github.com/lirios/qml-xwayland.git#branch=develop
+ md5sums = SKIP
+
+pkgname = qml-xwayland-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c8d6420ce90b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,48 @@
+# Maintainer: Pier Luigi Fiorini <pierluigi.fiorini@gmail.com>
+
+pkgname=qml-xwayland-git
+pkgver=20180924.67.8ffd882
+pkgrel=1
+pkgdesc="QtWayland additions and QPA plugin"
+arch=('i686' 'x86_64' 'armv6h' 'armv7h')
+url='https://liri.io'
+license=('GPL3')
+depends=('qt5-declarative' 'qt5-wayland')
+makedepends=('git' 'liri-qbs-shared-git' 'xcb-util-cursor' 'libxcursor')
+options=(debug !strip)
+conflicts=('qml-xwayland')
+replaces=('qml-xwayland')
+provides=('qml-xwayland')
+groups=('liri-git')
+
+_gitroot="git://github.com/lirios/qml-xwayland.git"
+_gitbranch=develop
+_gitname=qml-xwayland
+source=(${_gitname}::${_gitroot}#branch=${_gitbranch})
+md5sums=('SKIP')
+
+pkgver() {
+ cd ${srcdir}/${_gitname}
+ echo "$(git log -1 --format="%cd" --date=short | tr -d '-').$(git rev-list --count HEAD).$(git log -1 --format="%h")"
+}
+
+prepare() {
+ cd ${srcdir}/${_gitname}
+ git submodule update --init
+}
+
+build() {
+ cd ${srcdir}/${_gitname}
+ qbs setup-toolchains --type gcc /usr/bin/g++ gcc
+ qbs setup-qt /usr/bin/qmake-qt5 qt5
+ qbs config profiles.qt5.baseProfile gcc
+ qbs build --no-install -d build profile:qt5 \
+ modules.lirideployment.prefix:/usr \
+ modules.lirideployment.qmlDir:/usr/lib/qt/qml \
+ modules.lirideployment.pluginsDir:/usr/lib/qt/plugins
+}
+
+package() {
+ cd ${srcdir}/${_gitname}
+ qbs install -d build --no-build -v --install-root $pkgdir profile:qt5
+}